Rebuild for OpenEXR/Imath 3.

This commit is contained in:
Richard Shaw 2021-08-01 22:19:02 -05:00
parent eabd61d4dd
commit 4881623b3b
2 changed files with 56 additions and 3 deletions

38
hugin-openexr3.patch Normal file
View File

@ -0,0 +1,38 @@
Index: hugin-2020.0.0/CMakeLists.txt
===================================================================
--- hugin-2020.0.0.orig/CMakeLists.txt
+++ hugin-2020.0.0/CMakeLists.txt
@@ -214,7 +214,17 @@ ENDIF()
ENDIF()
-FIND_PACKAGE(OpenEXR REQUIRED)
+FIND_PACKAGE(Imath CONFIG)
+IF(TARGET Imath::Imath)
+ FIND_PACKAGE(OpenEXR CONFIG REQUIRED)
+ FIND_PACKAGE(ZLIB REQUIRED)
+ get_target_property(OPENEXR_INCLUDE_DIR OpenEXR::OpenEXRConfig INTERFACE_INCLUDE_DIRECTORIES)
+ get_target_property(IMATH_INCLUDE_DIR Imath::ImathConfig INTERFACE_INCLUDE_DIRECTORIES)
+ list(APPEND OPENEXR_INCLUDE_DIR ${IMATH_INCLUDE_DIR})
+ set(OPENEXR_LIBRARIES OpenEXR::OpenEXR Imath::Imath ${ZLIB_LIBRARIES})
+ELSE()
+ FIND_PACKAGE(OpenEXR REQUIRED)
+ENDIF()
include_directories(${OPENEXR_INCLUDE_DIR})
FIND_PACKAGE(VIGRA 1.9.0 REQUIRED)
Index: hugin-2020.0.0/src/hugin_base/vigra_ext/ReduceOpenEXR.h
===================================================================
--- hugin-2020.0.0.orig/src/hugin_base/vigra_ext/ReduceOpenEXR.h
+++ hugin-2020.0.0/src/hugin_base/vigra_ext/ReduceOpenEXR.h
@@ -25,8 +25,8 @@
#include <vigra_ext/HDRUtils.h>
#include <vigra_ext/FileRAII.h>
-#include <ImfRgbaFile.h>
-#include <ImfArray.h>
+#include <OpenEXR/ImfRgbaFile.h>
+#include <OpenEXR/ImfArray.h>
// hack to read pgm header

View File

@ -1,9 +1,10 @@
Summary: A panoramic photo stitcher and more
Name: hugin
Version: 2020.0.0
Release: 8%{?dist}
Release: 9%{?dist}
License: GPLv2+
Source: http://downloads.sourceforge.net/hugin/%{name}-%{version}.tar.bz2
Patch0: hugin-openexr3.patch
URL: http://hugin.sourceforge.net/
Requires: shared-mime-info
Requires: webclient
@ -11,10 +12,16 @@ Requires: %{name}-base = %{version}-%{release}
BuildRequires: gcc-c++
BuildRequires: libpano13-devel zlib-devel libtiff-devel libjpeg-devel
BuildRequires: libpng-devel gettext-devel wxGTK3-devel boost-devel freeglut-devel
BuildRequires: cmake desktop-file-utils OpenEXR-devel exiv2-devel glew-devel
BuildRequires: cmake desktop-file-utils exiv2-devel glew-devel
BuildRequires: python3-devel swig flann-devel perl-Image-ExifTool
BuildRequires: mesa-libGLU-devel libXmu-devel sqlite-devel vigra-devel
BuildRequires: perl-podlators fftw-devel lcms2-devel
%if 0%{?fedora} > 34
BuildRequires: cmake(OpenEXR)
BuildRequires: cmake(Imath)
%else
BuildRequires: OpenEXR-devel
%endif
%description
hugin can be used to stitch multiple images together. The resulting image can
@ -32,12 +39,17 @@ separately from hugin if you want to batch-process hugin projects on a machine
without a GUI environment.
%prep
%setup -q
%autosetup -p1
sed -i 's^/usr/bin/env python3^/usr/bin/python3^' \
src/hugin_script_interface/plugins-dev/*.py \
src/hugin_script_interface/*.py \
src/hugin_script_interface/plugins/*.py
# Bundled version does not define ZLIB::ZLIB
%if 0%{?fedora} > 33
rm CMakeModules/FindZLIB.cmake
%endif
%build
%cmake -DBUILD_HSI=1
%cmake_build
@ -193,6 +205,9 @@ EOF
%{_mandir}/man1/hugin_lensdb.*
%changelog
* Mon Aug 02 2021 Richard Shaw <hobbes1069@gmail.com> - 2020.0.0-9
- Rebuild for OpenEXR/Imath 3.
* Thu Jul 29 2021 Bruno Postle <bruno@postle.net> - 2020.0.0-8
- Rebuilt