cmake 3.14 fix (updated)

This commit is contained in:
Bruno Postle 2019-03-23 11:59:18 +00:00
parent ae043e63c3
commit 3297e5c739
1 changed files with 7 additions and 12 deletions

View File

@ -1,18 +1,13 @@
diff -r 05a55c15585c -r 2a4ddd1a0fed CMakeLists.txt
--- a/CMakeLists.txt Sat Mar 23 10:11:35 2019 +0100
+++ b/CMakeLists.txt Sat Mar 23 08:20:27 2019 +0100
@@ -159,12 +159,11 @@
diff -r 5abfb4de7961 CMakeLists.txt
--- a/CMakeLists.txt Sun Jan 21 12:56:33 2018 +0100
+++ b/CMakeLists.txt Sat Mar 23 11:56:35 2019 +0000
@@ -162,8 +162,7 @@
##
# This must come before FINDs for tiff, jpeg, png, zlib to enable
# finding the wxWidgets distributions of those packages (Win32 only).
IF(WIN32)
- SET(wxWidgets_USE_LIBS base core aui xrc html xml adv gl qa)
+ FIND_PACKAGE(wxWidgets REQUIRED base core aui xrc html xml adv gl qa)
ELSE()
# Unix needs also wxWidgets net library
- SET(wxWidgets_USE_LIBS base core aui xrc html xml adv gl net qa)
+ FIND_PACKAGE(wxWidgets REQUIRED base core aui xrc html xml adv gl net qa)
ENDIF()
-SET(wxWidgets_USE_LIBS base core aui xrc html xml adv gl net qa)
-FIND_PACKAGE(wxWidgets REQUIRED)
+FIND_PACKAGE(wxWidgets REQUIRED base core aui xrc html xml adv gl net qa)
# hugin requires wxwidgets 3.0 or above
IF (UNIX)