update to 0.24
This commit is contained in:
parent
e63af7a588
commit
d993725823
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
/hledger-0.17.tar.gz
|
||||
/hledger-0.19.3.tar.gz
|
||||
/hledger-0.23.2.tar.gz
|
||||
/hledger-0.24.tar.gz
|
||||
|
42
hledger-0.24-no-pretty-show.patch
Normal file
42
hledger-0.24-no-pretty-show.patch
Normal file
@ -0,0 +1,42 @@
|
||||
diff -u -r -U5 hledger-0.24/hledger.cabal hledger-0.24.no-pretty-show/hledger.cabal
|
||||
--- hledger-0.24/hledger.cabal 2014-12-25 14:40:58.000000000 -0500
|
||||
+++ hledger-0.24.no-pretty-show/hledger.cabal 2015-03-01 21:56:38.361487372 -0500
|
||||
@@ -98,12 +98,10 @@
|
||||
,text >= 0.11
|
||||
,tabular >= 0.2 && < 0.3
|
||||
,time
|
||||
,utf8-string >= 0.3.5 && < 0.4
|
||||
,wizards == 1.0.*
|
||||
- if impl(ghc >= 7.4)
|
||||
- build-depends: pretty-show >= 1.6.4
|
||||
|
||||
|
||||
executable hledger
|
||||
main-is: hledger-cli.hs
|
||||
hs-source-dirs: app
|
||||
@@ -140,12 +138,10 @@
|
||||
,tabular >= 0.2 && < 0.3
|
||||
,text >= 0.11
|
||||
,time
|
||||
,utf8-string >= 0.3.5 && < 0.4
|
||||
,wizards == 1.0.*
|
||||
- if impl(ghc >= 7.4)
|
||||
- build-depends: pretty-show >= 1.6.4
|
||||
|
||||
|
||||
test-suite tests
|
||||
type: exitcode-stdio-1.0
|
||||
main-is: suite.hs
|
||||
@@ -181,12 +177,10 @@
|
||||
, test-framework-hunit
|
||||
, text
|
||||
, time
|
||||
, transformers
|
||||
, wizards == 1.0.*
|
||||
- if impl(ghc >= 7.4)
|
||||
- build-depends: pretty-show >= 1.6.4
|
||||
|
||||
|
||||
-- not a standard cabal bench test, I think
|
||||
benchmark bench
|
||||
type: exitcode-stdio-1.0
|
@ -1,28 +0,0 @@
|
||||
--- hledger-0.23.2/hledger.cabal~ 2014-05-09 06:34:03.000000000 +0900
|
||||
+++ hledger-0.23.2/hledger.cabal 2014-08-29 18:32:43.377075655 +0900
|
||||
@@ -98,8 +98,6 @@
|
||||
,time
|
||||
,utf8-string >= 0.3.5 && < 0.4
|
||||
,wizards == 1.0.*
|
||||
- if impl(ghc >= 7.4)
|
||||
- build-depends: pretty-show >= 1.6.4
|
||||
|
||||
-- should depend on the above to avoid double compilation but this is
|
||||
-- still too complicated as of 2011/6/1 because:
|
||||
@@ -159,8 +157,6 @@
|
||||
,time
|
||||
,utf8-string >= 0.3.5 && < 0.4
|
||||
,wizards == 1.0.*
|
||||
- if impl(ghc >= 7.4)
|
||||
- build-depends: pretty-show >= 1.6.4
|
||||
|
||||
test-suite tests
|
||||
type: exitcode-stdio-1.0
|
||||
@@ -195,5 +191,3 @@
|
||||
, time
|
||||
, transformers
|
||||
, wizards == 1.0.*
|
||||
- if impl(ghc >= 7.4)
|
||||
- build-depends: pretty-show >= 1.6.4
|
||||
|
||||
Diff finished. Fri Aug 29 18:32:49 2014
|
38
hledger.spec
38
hledger.spec
@ -5,21 +5,24 @@
|
||||
%bcond_with tests
|
||||
|
||||
Name: %{pkg_name}
|
||||
Version: 0.23.2
|
||||
Version: 0.24
|
||||
Release: 1%{?dist}
|
||||
Summary: A double-entry accounting tool
|
||||
Summary: The main command-line interface for the hledger accounting tool
|
||||
|
||||
License: GPLv3
|
||||
Url: https://hackage.haskell.org/package/%{name}
|
||||
Source0: https://hackage.haskell.org/package/%{name}-%{version}/%{name}-%{version}.tar.gz
|
||||
Patch0: hledger-no-pretty-show.patch
|
||||
# rhbz(974725)
|
||||
Patch0: hledger-0.24-no-pretty-show.patch
|
||||
|
||||
BuildRequires: ghc-Cabal-devel
|
||||
BuildRequires: ghc-rpm-macros
|
||||
# Begin cabal-rpm deps:
|
||||
BuildRequires: chrpath
|
||||
BuildRequires: ghc-HUnit-devel
|
||||
BuildRequires: ghc-cmdargs-devel
|
||||
BuildRequires: ghc-containers-devel
|
||||
BuildRequires: ghc-csv-devel
|
||||
BuildRequires: ghc-directory-devel
|
||||
BuildRequires: ghc-filepath-devel
|
||||
BuildRequires: ghc-haskeline-devel
|
||||
@ -28,7 +31,9 @@ BuildRequires: ghc-mtl-devel
|
||||
BuildRequires: ghc-old-locale-devel
|
||||
BuildRequires: ghc-old-time-devel
|
||||
BuildRequires: ghc-parsec-devel
|
||||
#BuildRequires: ghc-pretty-show-devel
|
||||
BuildRequires: ghc-process-devel
|
||||
BuildRequires: ghc-regex-tdfa-devel
|
||||
BuildRequires: ghc-regexpr-devel
|
||||
BuildRequires: ghc-safe-devel
|
||||
BuildRequires: ghc-shakespeare-devel
|
||||
@ -40,23 +45,18 @@ BuildRequires: ghc-time-devel
|
||||
BuildRequires: ghc-utf8-string-devel
|
||||
BuildRequires: ghc-wizards-devel
|
||||
%if %{with tests}
|
||||
BuildRequires: ghc-csv-devel
|
||||
BuildRequires: ghc-test-framework-devel
|
||||
BuildRequires: ghc-test-framework-hunit-devel
|
||||
BuildRequires: ghc-transformers-devel
|
||||
%endif
|
||||
# End cabal-rpm deps
|
||||
# bug 992478
|
||||
#ExcludeArch: armv7hl
|
||||
|
||||
%description
|
||||
hledger reads a plain text general journal or time log
|
||||
describing your transactions and displays precise
|
||||
balance and register reports on the console.
|
||||
It is a remix, in haskell, of John Wiegley's excellent c++
|
||||
ledger. hledger aims to be a practical, accessible tool
|
||||
for end users and a useful library for finance-minded
|
||||
haskell programmers.
|
||||
Hledger is a library and set of user tools for working with financial data (or
|
||||
anything that can be tracked in a double-entry accounting ledger.) It is a
|
||||
haskell port and friendly fork of John Wiegley's Ledger. hledger provides
|
||||
command-line, curses and web interfaces, and aims to be a reliable, practical
|
||||
tool for daily use.
|
||||
|
||||
|
||||
%package -n ghc-%{name}
|
||||
@ -80,7 +80,7 @@ This package provides the Haskell %{name} library development files.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .orig
|
||||
%patch0 -p1 -b .no-pretty-show
|
||||
|
||||
|
||||
%build
|
||||
@ -90,9 +90,13 @@ This package provides the Haskell %{name} library development files.
|
||||
%install
|
||||
%ghc_lib_install
|
||||
|
||||
%ghc_fix_dynamic_rpath %{pkg_name}
|
||||
|
||||
|
||||
%check
|
||||
%cabal_test
|
||||
%if %{with tests}
|
||||
%cabal test
|
||||
%endif
|
||||
|
||||
|
||||
%post -n ghc-%{name}-devel
|
||||
@ -116,6 +120,10 @@ This package provides the Haskell %{name} library development files.
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Mar 01 2015 Ben Boeckel <mathstuf@gmail.com> - 0.24-1
|
||||
- update to 0.24
|
||||
- cblrpm refresh
|
||||
|
||||
* Fri Feb 6 2015 Jens Petersen <petersen@redhat.com> - 0.23.2-1
|
||||
- update to 0.23.2
|
||||
- cblrpm refresh
|
||||
|
Loading…
x
Reference in New Issue
Block a user