update to 0.23.2
- patch out pretty-show for now - needs new tabular and wizard to build!!
This commit is contained in:
parent
a8b6077645
commit
d33f61fcc2
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
/hledger-0.17.tar.gz
|
||||
/hledger-0.19.3.tar.gz
|
||||
/hledger-0.23.2.tar.gz
|
||||
|
28
hledger-no-pretty-show.patch
Normal file
28
hledger-no-pretty-show.patch
Normal file
@ -0,0 +1,28 @@
|
||||
--- hledger-0.23.2/hledger.cabal~ 2014-05-09 06:34:03.000000000 +0900
|
||||
+++ hledger-0.23.2/hledger.cabal 2014-08-29 18:32:43.377075655 +0900
|
||||
@@ -98,8 +98,6 @@
|
||||
,time
|
||||
,utf8-string >= 0.3.5 && < 0.4
|
||||
,wizards == 1.0.*
|
||||
- if impl(ghc >= 7.4)
|
||||
- build-depends: pretty-show >= 1.6.4
|
||||
|
||||
-- should depend on the above to avoid double compilation but this is
|
||||
-- still too complicated as of 2011/6/1 because:
|
||||
@@ -159,8 +157,6 @@
|
||||
,time
|
||||
,utf8-string >= 0.3.5 && < 0.4
|
||||
,wizards == 1.0.*
|
||||
- if impl(ghc >= 7.4)
|
||||
- build-depends: pretty-show >= 1.6.4
|
||||
|
||||
test-suite tests
|
||||
type: exitcode-stdio-1.0
|
||||
@@ -195,5 +191,3 @@
|
||||
, time
|
||||
, transformers
|
||||
, wizards == 1.0.*
|
||||
- if impl(ghc >= 7.4)
|
||||
- build-depends: pretty-show >= 1.6.4
|
||||
|
||||
Diff finished. Fri Aug 29 18:32:49 2014
|
38
hledger.spec
38
hledger.spec
@ -2,14 +2,20 @@
|
||||
|
||||
%global pkg_name hledger
|
||||
|
||||
%bcond_with tests
|
||||
|
||||
# no useful debuginfo for Haskell packages without C sources
|
||||
%global debug_package %{nil}
|
||||
|
||||
Name: %{pkg_name}
|
||||
Version: 0.19.3
|
||||
Release: 5%{?dist}
|
||||
Version: 0.23.2
|
||||
Release: 1%{?dist}
|
||||
Summary: A double-entry accounting tool
|
||||
|
||||
License: GPLv3
|
||||
URL: http://hackage.haskell.org/package/%{name}
|
||||
Source0: http://hackage.haskell.org/packages/archive/%{name}/%{version}/%{name}-%{version}.tar.gz
|
||||
Source0: http://hackage.haskell.org/package/%{name}-%{version}/%{name}-%{version}.tar.gz
|
||||
Patch0: hledger-no-pretty-show.patch
|
||||
|
||||
BuildRequires: ghc-Cabal-devel
|
||||
BuildRequires: ghc-rpm-macros
|
||||
@ -25,14 +31,24 @@ BuildRequires: ghc-mtl-devel
|
||||
BuildRequires: ghc-old-locale-devel
|
||||
BuildRequires: ghc-old-time-devel
|
||||
BuildRequires: ghc-parsec-devel
|
||||
BuildRequires: ghc-pretty-show-devel
|
||||
BuildRequires: ghc-process-devel
|
||||
BuildRequires: ghc-regexpr-devel
|
||||
BuildRequires: ghc-safe-devel
|
||||
BuildRequires: ghc-shakespeare-devel
|
||||
BuildRequires: ghc-shakespeare-text-devel
|
||||
BuildRequires: ghc-split-devel
|
||||
BuildRequires: ghc-tabular-devel
|
||||
BuildRequires: ghc-text-devel
|
||||
BuildRequires: ghc-time-devel
|
||||
BuildRequires: ghc-utf8-string-devel
|
||||
BuildRequires: ghc-wizards-devel
|
||||
%if %{with tests}
|
||||
BuildRequires: ghc-csv-devel
|
||||
BuildRequires: ghc-test-framework-devel
|
||||
BuildRequires: ghc-test-framework-hunit-devel
|
||||
BuildRequires: ghc-transformers-devel
|
||||
%endif
|
||||
# End cabal-rpm deps
|
||||
# bug 992478
|
||||
ExcludeArch: armv7hl
|
||||
@ -56,10 +72,11 @@ This package provides the Haskell %{name} shared library.
|
||||
|
||||
%package -n ghc-%{name}-devel
|
||||
Summary: Haskell %{name} library development files
|
||||
Provides: ghc-%{name}-static = %{version}-%{release}
|
||||
Requires: ghc-compiler = %{ghc_version}
|
||||
Requires(post): ghc-compiler = %{ghc_version}
|
||||
Requires(postun): ghc-compiler = %{ghc_version}
|
||||
Requires: ghc-%{name} = %{version}-%{release}
|
||||
Requires: ghc-%{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description -n ghc-%{name}-devel
|
||||
This package provides the Haskell %{name} library development files.
|
||||
@ -67,6 +84,7 @@ This package provides the Haskell %{name} library development files.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .orig
|
||||
|
||||
|
||||
%build
|
||||
@ -77,6 +95,12 @@ This package provides the Haskell %{name} library development files.
|
||||
%ghc_lib_install
|
||||
|
||||
|
||||
%check
|
||||
%if %{with tests}
|
||||
%cabal test
|
||||
%endif
|
||||
|
||||
|
||||
%post -n ghc-%{name}-devel
|
||||
%ghc_pkg_recache
|
||||
|
||||
@ -98,6 +122,12 @@ This package provides the Haskell %{name} library development files.
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Aug 29 2014 Jens Petersen <petersen@redhat.com> - 0.23.2-1
|
||||
- update to 0.23.2
|
||||
- refresh to cblrpm-0.8.11
|
||||
- patch out pretty-show for now
|
||||
- still needs new tabular and wizard to build!!
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.19.3-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user