update to 0.27.1
This commit is contained in:
parent
35aae7abcd
commit
34b18fb70e
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@
|
|||||||
/hledger-0.19.3.tar.gz
|
/hledger-0.19.3.tar.gz
|
||||||
/hledger-0.23.2.tar.gz
|
/hledger-0.23.2.tar.gz
|
||||||
/hledger-0.24.tar.gz
|
/hledger-0.24.tar.gz
|
||||||
|
/hledger-0.27.1.tar.gz
|
||||||
|
@ -1,42 +0,0 @@
|
|||||||
diff -u -r -U5 hledger-0.24/hledger.cabal hledger-0.24.no-pretty-show/hledger.cabal
|
|
||||||
--- hledger-0.24/hledger.cabal 2014-12-25 14:40:58.000000000 -0500
|
|
||||||
+++ hledger-0.24.no-pretty-show/hledger.cabal 2015-03-01 21:56:38.361487372 -0500
|
|
||||||
@@ -98,12 +98,10 @@
|
|
||||||
,text >= 0.11
|
|
||||||
,tabular >= 0.2 && < 0.3
|
|
||||||
,time
|
|
||||||
,utf8-string >= 0.3.5 && < 0.4
|
|
||||||
,wizards == 1.0.*
|
|
||||||
- if impl(ghc >= 7.4)
|
|
||||||
- build-depends: pretty-show >= 1.6.4
|
|
||||||
|
|
||||||
|
|
||||||
executable hledger
|
|
||||||
main-is: hledger-cli.hs
|
|
||||||
hs-source-dirs: app
|
|
||||||
@@ -140,12 +138,10 @@
|
|
||||||
,tabular >= 0.2 && < 0.3
|
|
||||||
,text >= 0.11
|
|
||||||
,time
|
|
||||||
,utf8-string >= 0.3.5 && < 0.4
|
|
||||||
,wizards == 1.0.*
|
|
||||||
- if impl(ghc >= 7.4)
|
|
||||||
- build-depends: pretty-show >= 1.6.4
|
|
||||||
|
|
||||||
|
|
||||||
test-suite tests
|
|
||||||
type: exitcode-stdio-1.0
|
|
||||||
main-is: suite.hs
|
|
||||||
@@ -181,12 +177,10 @@
|
|
||||||
, test-framework-hunit
|
|
||||||
, text
|
|
||||||
, time
|
|
||||||
, transformers
|
|
||||||
, wizards == 1.0.*
|
|
||||||
- if impl(ghc >= 7.4)
|
|
||||||
- build-depends: pretty-show >= 1.6.4
|
|
||||||
|
|
||||||
|
|
||||||
-- not a standard cabal bench test, I think
|
|
||||||
benchmark bench
|
|
||||||
type: exitcode-stdio-1.0
|
|
@ -1,40 +0,0 @@
|
|||||||
--- hledger-0.24/hledger.cabal~ 2015-09-03 18:08:49.256055251 +0900
|
|
||||||
+++ hledger-0.24/hledger.cabal 2015-09-03 18:09:14.827088132 +0900
|
|
||||||
@@ -84,16 +84,7 @@
|
|
||||||
,regex-tdfa
|
|
||||||
,regexpr >= 0.5.1
|
|
||||||
,safe >= 0.2
|
|
||||||
--- http://www.yesodweb.com/blog/2014/04/consolidation-progress
|
|
||||||
--- in order to support both the old and new versions of shakespeare,
|
|
||||||
--- you just need to ensure that you have both the shakespeare and
|
|
||||||
--- deprecated packages listed in your cabal file. In other words, if
|
|
||||||
--- previously you depended on hamlet, now you should depend on hamlet
|
|
||||||
--- and shakespeare. When you're ready to drop backwards compatibility,
|
|
||||||
--- simply put a lower bound of >= 2.0 on shakespeare and remove the
|
|
||||||
--- deprecated packages.
|
|
||||||
- ,shakespeare-text >= 1.0 && < 1.2
|
|
||||||
- ,shakespeare >= 1.0 && < 2.1
|
|
||||||
+ ,shakespeare >= 2.0 && < 2.1
|
|
||||||
,split >= 0.1 && < 0.3
|
|
||||||
,text >= 0.11
|
|
||||||
,tabular >= 0.2 && < 0.3
|
|
||||||
@@ -132,8 +123,7 @@
|
|
||||||
,regex-tdfa
|
|
||||||
,regexpr >= 0.5.1
|
|
||||||
,safe >= 0.2
|
|
||||||
- ,shakespeare-text >= 1.0 && < 1.2
|
|
||||||
- ,shakespeare >= 1.0 && < 2.1
|
|
||||||
+ ,shakespeare >= 2.0 && < 2.1
|
|
||||||
,split >= 0.1 && < 0.3
|
|
||||||
,tabular >= 0.2 && < 0.3
|
|
||||||
,text >= 0.11
|
|
||||||
@@ -169,8 +159,7 @@
|
|
||||||
, regex-tdfa
|
|
||||||
, regexpr
|
|
||||||
, safe
|
|
||||||
- , shakespeare-text >= 1.0 && < 1.2
|
|
||||||
- , shakespeare >= 1.0 && < 2.1
|
|
||||||
+ , shakespeare >= 2.0 && < 2.1
|
|
||||||
, split
|
|
||||||
,tabular >= 0.2 && < 0.3
|
|
||||||
, test-framework
|
|
26
hledger-mtl-compat.patch
Normal file
26
hledger-mtl-compat.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
--- hledger-0.27.1/hledger.cabal~ 2016-05-28 02:34:17.000000000 +0900
|
||||||
|
+++ hledger-0.27.1/hledger.cabal 2016-09-05 16:35:19.499499817 +0900
|
||||||
|
@@ -69,7 +69,6 @@
|
||||||
|
, haskeline >= 0.6 && <= 0.8
|
||||||
|
, HUnit
|
||||||
|
, mtl
|
||||||
|
- , mtl-compat
|
||||||
|
, old-time
|
||||||
|
, parsec >= 3
|
||||||
|
, process
|
||||||
|
@@ -143,7 +142,6 @@
|
||||||
|
, haskeline >= 0.6 && <= 0.8
|
||||||
|
, HUnit
|
||||||
|
, mtl
|
||||||
|
- , mtl-compat
|
||||||
|
, old-time
|
||||||
|
, parsec >= 3
|
||||||
|
, process
|
||||||
|
@@ -196,7 +194,6 @@
|
||||||
|
, haskeline >= 0.6 && <= 0.8
|
||||||
|
, HUnit
|
||||||
|
, mtl
|
||||||
|
- , mtl-compat
|
||||||
|
, old-time
|
||||||
|
, parsec >= 3
|
||||||
|
, process
|
39
hledger.spec
39
hledger.spec
@ -1,3 +1,4 @@
|
|||||||
|
# generated by cabal-rpm-0.10.0
|
||||||
# https://fedoraproject.org/wiki/Packaging:Haskell
|
# https://fedoraproject.org/wiki/Packaging:Haskell
|
||||||
|
|
||||||
%global pkg_name hledger
|
%global pkg_name hledger
|
||||||
@ -5,23 +6,21 @@
|
|||||||
%bcond_with tests
|
%bcond_with tests
|
||||||
|
|
||||||
Name: %{pkg_name}
|
Name: %{pkg_name}
|
||||||
Version: 0.24
|
Version: 0.27.1
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The main command-line interface for the hledger accounting tool
|
Summary: The main command-line interface for the hledger accounting tool
|
||||||
|
|
||||||
License: GPLv3
|
License: GPLv3
|
||||||
Url: https://hackage.haskell.org/package/%{name}
|
Url: https://hackage.haskell.org/package/%{name}
|
||||||
Source0: https://hackage.haskell.org/package/%{name}-%{version}/%{name}-%{version}.tar.gz
|
Source0: https://hackage.haskell.org/package/%{name}-%{version}/%{name}-%{version}.tar.gz
|
||||||
# http://www.yesodweb.com/blog/2014/04/consolidation-progress
|
Patch0: hledger-mtl-compat.patch
|
||||||
Patch0: hledger-0.24-req-new-shakespeare.patch
|
|
||||||
# rhbz(974725)
|
|
||||||
Patch1: hledger-0.24-no-pretty-show.patch
|
|
||||||
|
|
||||||
BuildRequires: ghc-Cabal-devel
|
BuildRequires: ghc-Cabal-devel
|
||||||
BuildRequires: ghc-rpm-macros
|
BuildRequires: ghc-rpm-macros
|
||||||
# Begin cabal-rpm deps:
|
# Begin cabal-rpm deps:
|
||||||
BuildRequires: chrpath
|
BuildRequires: chrpath
|
||||||
BuildRequires: ghc-HUnit-devel
|
BuildRequires: ghc-HUnit-devel
|
||||||
|
BuildRequires: ghc-base-compat-devel
|
||||||
BuildRequires: ghc-cmdargs-devel
|
BuildRequires: ghc-cmdargs-devel
|
||||||
BuildRequires: ghc-containers-devel
|
BuildRequires: ghc-containers-devel
|
||||||
BuildRequires: ghc-csv-devel
|
BuildRequires: ghc-csv-devel
|
||||||
@ -29,33 +28,35 @@ BuildRequires: ghc-directory-devel
|
|||||||
BuildRequires: ghc-filepath-devel
|
BuildRequires: ghc-filepath-devel
|
||||||
BuildRequires: ghc-haskeline-devel
|
BuildRequires: ghc-haskeline-devel
|
||||||
BuildRequires: ghc-hledger-lib-devel
|
BuildRequires: ghc-hledger-lib-devel
|
||||||
|
#BuildRequires: ghc-mtl-compat-devel
|
||||||
BuildRequires: ghc-mtl-devel
|
BuildRequires: ghc-mtl-devel
|
||||||
BuildRequires: ghc-old-locale-devel
|
|
||||||
BuildRequires: ghc-old-time-devel
|
BuildRequires: ghc-old-time-devel
|
||||||
BuildRequires: ghc-parsec-devel
|
BuildRequires: ghc-parsec-devel
|
||||||
#BuildRequires: ghc-pretty-show-devel
|
BuildRequires: ghc-pretty-show-devel
|
||||||
BuildRequires: ghc-process-devel
|
BuildRequires: ghc-process-devel
|
||||||
BuildRequires: ghc-regex-tdfa-devel
|
BuildRequires: ghc-regex-tdfa-devel
|
||||||
BuildRequires: ghc-regexpr-devel
|
|
||||||
BuildRequires: ghc-safe-devel
|
BuildRequires: ghc-safe-devel
|
||||||
BuildRequires: ghc-shakespeare-devel
|
BuildRequires: ghc-shakespeare-devel
|
||||||
BuildRequires: ghc-split-devel
|
BuildRequires: ghc-split-devel
|
||||||
BuildRequires: ghc-tabular-devel
|
BuildRequires: ghc-tabular-devel
|
||||||
|
BuildRequires: ghc-terminfo-devel
|
||||||
BuildRequires: ghc-text-devel
|
BuildRequires: ghc-text-devel
|
||||||
BuildRequires: ghc-time-devel
|
BuildRequires: ghc-time-devel
|
||||||
|
BuildRequires: ghc-unordered-containers-devel
|
||||||
BuildRequires: ghc-utf8-string-devel
|
BuildRequires: ghc-utf8-string-devel
|
||||||
BuildRequires: ghc-wizards-devel
|
BuildRequires: ghc-wizards-devel
|
||||||
%if %{with tests}
|
%if %{with tests}
|
||||||
BuildRequires: ghc-test-framework-devel
|
BuildRequires: ghc-test-framework-devel
|
||||||
BuildRequires: ghc-test-framework-hunit-devel
|
BuildRequires: ghc-test-framework-hunit-devel
|
||||||
BuildRequires: ghc-transformers-devel
|
|
||||||
%endif
|
%endif
|
||||||
# End cabal-rpm deps
|
# End cabal-rpm deps
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Hledger is a library and set of user tools for working with financial data (or
|
This is hledger’s command-line interface. Its basic function is to read a plain
|
||||||
anything that can be tracked in a double-entry accounting ledger.) It is a
|
text file describing financial transactions and produce useful reports.
|
||||||
haskell port and friendly fork of John Wiegley's Ledger. hledger provides
|
hledger is a cross-platform program for tracking money, time, or any other
|
||||||
|
commodity, using double-entry accounting and a simple, editable file format.
|
||||||
|
It is inspired by and largely compatible with ledger(1). hledger provides
|
||||||
command-line, curses and web interfaces, and aims to be a reliable, practical
|
command-line, curses and web interfaces, and aims to be a reliable, practical
|
||||||
tool for daily use.
|
tool for daily use.
|
||||||
|
|
||||||
@ -81,8 +82,7 @@ This package provides the Haskell %{name} library development files.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .req-new-shakespeare
|
%patch0 -p1 -b .orig
|
||||||
%patch1 -p1 -b .no-pretty-show
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -98,9 +98,7 @@ rm %{buildroot}%{ghc_pkgdocdir}/LICENSE
|
|||||||
|
|
||||||
|
|
||||||
%check
|
%check
|
||||||
%if %{with tests}
|
%cabal_test
|
||||||
%cabal test
|
|
||||||
%endif
|
|
||||||
|
|
||||||
|
|
||||||
%post -n ghc-%{name}-devel
|
%post -n ghc-%{name}-devel
|
||||||
@ -121,9 +119,14 @@ rm %{buildroot}%{ghc_pkgdocdir}/LICENSE
|
|||||||
|
|
||||||
|
|
||||||
%files -n ghc-%{name}-devel -f ghc-%{name}-devel.files
|
%files -n ghc-%{name}-devel -f ghc-%{name}-devel.files
|
||||||
|
%doc CHANGES README.md
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Sep 5 2016 Jens Petersen <petersen@redhat.com> - 0.27.1-1
|
||||||
|
- update to 0.27.1
|
||||||
|
- build without mtl-compat
|
||||||
|
|
||||||
* Tue May 24 2016 Ben Boeckel <mathstuf@gmail.com> - 0.24-5
|
* Tue May 24 2016 Ben Boeckel <mathstuf@gmail.com> - 0.24-5
|
||||||
- Rebuild for ghc-cmdargs, ghc-regexpr, ghc-split
|
- Rebuild for ghc-cmdargs, ghc-regexpr, ghc-split
|
||||||
- doc -> license macro
|
- doc -> license macro
|
||||||
|
Loading…
x
Reference in New Issue
Block a user