New upstream version 1.3.17.
Fixes regression of RHBZ#1145056.
This commit is contained in:
parent
c35ed1aae8
commit
f9f7d3f4ad
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@
|
||||
/hivex-1.3.14.tar.gz.sig
|
||||
/hivex-1.3.15.tar.gz.sig
|
||||
/hivex-1.3.16.tar.gz.sig
|
||||
/hivex-1.3.17.tar.gz.sig
|
||||
|
@ -1,26 +0,0 @@
|
||||
From ea732cfc0b8a6966fc4c4a60a6a09f45e8a63d71 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Meyer <mmeyer@datto.com>
|
||||
Date: Tue, 22 Jan 2019 16:43:31 -0500
|
||||
Subject: [PATCH] lib: Reset errno to zero to avoid erroneously returning E2BIG
|
||||
|
||||
This line was accidentally removed in 77fe74fc, causing
|
||||
bug #1145056 (Bugzilla) to resurface.
|
||||
---
|
||||
lib/utf16.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/lib/utf16.c b/lib/utf16.c
|
||||
index e099548..67fa996 100644
|
||||
--- a/lib/utf16.c
|
||||
+++ b/lib/utf16.c
|
||||
@@ -58,6 +58,7 @@ _hivex_recode (hive_h *h, recode_type t,
|
||||
/* Reset errno here because we don't want to accidentally
|
||||
* return E2BIG to a library caller.
|
||||
*/
|
||||
+ errno = 0;
|
||||
size_t prev = outalloc;
|
||||
/* Try again with a larger output buffer. */
|
||||
free (out);
|
||||
--
|
||||
2.20.1
|
||||
|
12
hivex.spec
12
hivex.spec
@ -9,8 +9,8 @@
|
||||
%global verify_tarball_signature 1
|
||||
|
||||
Name: hivex
|
||||
Version: 1.3.16
|
||||
Release: 2%{?dist}
|
||||
Version: 1.3.17
|
||||
Release: 1%{?dist}
|
||||
Summary: Read and write Windows Registry binary hive files
|
||||
|
||||
License: LGPLv2
|
||||
@ -26,9 +26,6 @@ Source1: http://libguestfs.org/download/hivex/%{name}-%{version}.tar.gz.s
|
||||
Source2: libguestfs.keyring
|
||||
%endif
|
||||
|
||||
# Upstream patch to fix regression of RHBZ#1145056.
|
||||
Patch1: 0001-lib-Reset-errno-to-zero-to-avoid-erroneously-returni.patch
|
||||
|
||||
BuildRequires: perl-interpreter
|
||||
BuildRequires: perl-devel
|
||||
BuildRequires: perl-generators
|
||||
@ -280,8 +277,9 @@ make check
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jan 22 2019 Richard W.M. Jones <rjones@redhat.com> - 1.3.16-2
|
||||
- Add upstream patch to fix regression of RHBZ#1145056.
|
||||
* Tue Jan 22 2019 Richard W.M. Jones <rjones@redhat.com> - 1.3.17-1
|
||||
- New upstream version 1.3.17.
|
||||
- Fixes regression of RHBZ#1145056.
|
||||
|
||||
* Thu Jan 17 2019 Richard W.M. Jones <rjones@redhat.com> - 1.3.16-1
|
||||
- New upstream version 1.3.16.
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (hivex-1.3.16.tar.gz) = f7c09b256af8b7466124b681c2b6e1e0aacac763e3bd9057f617dad1ffb9e1f2298d58223539b872e8502316eaff123c27f81257341807f0086cc672ac85a788
|
||||
SHA512 (hivex-1.3.16.tar.gz.sig) = 1dc89e4fc5e51bbb705ff38d5cbbe99502b09f740263e4a1b6616328d9b62b29b181bace3a2952189374833cff6c1bb18a1894a4c002a8097a0450c80948a9a4
|
||||
SHA512 (hivex-1.3.17.tar.gz) = 901ab327656c0d93dba4d6a005bdd15ef41660b1edd173613b0960d817eb6b5697a590267b7b4f06f3898ba8fcda2b718792fd288559ce7900e8a10b078eba36
|
||||
SHA512 (hivex-1.3.17.tar.gz.sig) = 35f14c20f5c760e292bd05eeb5ea34bcc9e6a2f23d2ea79621c9d43af366cefcbc709a9bee437560fe5c486266b33f1eedde7432c2445822d4b07174b914addc
|
||||
|
Loading…
Reference in New Issue
Block a user