Update to 1.8.16
This commit is contained in:
parent
ed2be27293
commit
b7e31a4e33
2
.gitignore
vendored
2
.gitignore
vendored
@ -17,3 +17,5 @@ hdf5-1.8.5.tar.bz2
|
||||
/hdf5-1.8.15.tar.bz2
|
||||
/hdf5_1.8.14+docs-3.debian.tar.xz
|
||||
/hdf5-1.8.15-patch1.tar.bz2
|
||||
/hdf5-1.8.16.tar.bz2
|
||||
/hdf5_1.8.15-patch1+docs-5.debian.tar.xz
|
||||
|
@ -1,69 +1,39 @@
|
||||
diff -up hdf5-1.8.12/configure.ac.ldouble-ppc64le hdf5-1.8.12/configure.ac
|
||||
--- hdf5-1.8.12/configure.ac.ldouble-ppc64le 2014-03-19 08:58:07.933233530 -0600
|
||||
+++ hdf5-1.8.12/configure.ac 2014-03-19 09:01:48.651040050 -0600
|
||||
@@ -3766,6 +3766,13 @@ else
|
||||
unsigned char s2[8];
|
||||
int ret = 1;
|
||||
diff -up hdf5-1.8.16/configure.ac.ldouble-ppc64le hdf5-1.8.16/configure.ac
|
||||
--- hdf5-1.8.16/configure.ac.ldouble-ppc64le 2015-11-13 09:29:08.749125801 -0700
|
||||
+++ hdf5-1.8.16/configure.ac 2015-11-13 09:47:02.705174991 -0700
|
||||
@@ -2278,6 +2278,13 @@ else
|
||||
unsigned char s2[8];
|
||||
int ret = 1;
|
||||
|
||||
+#if defined __powerpc64__ && defined _LITTLE_ENDIAN
|
||||
+ /* Don't bother checking on ppc64le, we know it'll work, and
|
||||
+ * that what hdf5 calls 'special algorithm' simply is
|
||||
+ * IBM ldouble 128 (i.e. two seperately scaled doubles).
|
||||
+ * The check below assumes big endian. */
|
||||
+ ret = 0;
|
||||
+#endif
|
||||
if(sizeof(long double) == 16 && sizeof(long) == 8) {
|
||||
/*make sure the long double type has 16 bytes in size and
|
||||
* 11 bits of exponent. If it is,
|
||||
@@ -2355,6 +2362,13 @@ else
|
||||
unsigned char s[16];
|
||||
int flag=0, ret=1;
|
||||
|
||||
+#if defined __powerpc64__ && defined _LITTLE_ENDIAN
|
||||
+ /* Don't bother checking on ppc64le, we know it'll work, and
|
||||
+ * that what hdf5 calls 'special algorithm' simply is
|
||||
+ * IBM ldouble 128 (i.e. two seperately scaled doubles).
|
||||
+ * The check below assumes big endian. */
|
||||
+ ret = 0;
|
||||
+ /* Don't bother checking on ppc64le, we know it'll work, and
|
||||
+ * that what hdf5 calls 'special algorithm' simply is
|
||||
+ * IBM ldouble 128 (i.e. two seperately scaled doubles).
|
||||
+ * The check below assumes big endian. */
|
||||
+ ret = 0;
|
||||
+#endif
|
||||
if(sizeof(long double) == 16 && sizeof(long) == 8) {
|
||||
/*make sure the long double type has 16 bytes in size and
|
||||
* 11 bits of exponent. If it is,
|
||||
@@ -3844,6 +3851,13 @@ else
|
||||
unsigned char s[16];
|
||||
int flag=0, ret=1;
|
||||
|
||||
+#if defined __powerpc64__ && defined _LITTLE_ENDIAN
|
||||
+ /* Don't bother checking on ppc64le, we know it'll work, and
|
||||
+ * that what hdf5 calls 'special algorithm' simply is
|
||||
+ * IBM ldouble 128 (i.e. two seperately scaled doubles).
|
||||
+ * The check below assumes big endian. */
|
||||
+ ret = 0;
|
||||
+#endif
|
||||
/*Determine if long double has 16 byte in size, 11 bit exponent, and
|
||||
*the bias is 0x3ff */
|
||||
if(sizeof(long double) == 16) {
|
||||
diff -up hdf5-1.8.12/configure.ldouble-ppc64le hdf5-1.8.12/configure
|
||||
--- hdf5-1.8.12/configure.ldouble-ppc64le 2014-03-19 08:58:07.918233616 -0600
|
||||
+++ hdf5-1.8.12/configure 2014-03-19 08:58:07.932233536 -0600
|
||||
@@ -30362,6 +30362,13 @@ else
|
||||
unsigned char s2[8];
|
||||
int ret = 1;
|
||||
|
||||
+#if defined __powerpc64__ && defined _LITTLE_ENDIAN
|
||||
+ /* Don't bother checking on ppc64le, we know it'll work, and
|
||||
+ that what hdf5 calls 'special algorithm' simply is
|
||||
+ IBM ldouble 128 (i.e. two seperately scaled doubles).
|
||||
+ The check below assumes big endian. */
|
||||
+ ret = 0;
|
||||
+#endif
|
||||
if(sizeof(long double) == 16 && sizeof(long) == 8) {
|
||||
/*make sure the long double type has 16 bytes in size and
|
||||
* 11 bits of exponent. If it is,
|
||||
@@ -30466,6 +30473,13 @@ else
|
||||
unsigned char s[16];
|
||||
int flag=0, ret=1;
|
||||
|
||||
+#if defined __powerpc64__ && defined _LITTLE_ENDIAN
|
||||
+ /* Don't bother checking on ppc64le, we know it'll work, and
|
||||
+ that what hdf5 calls 'special algorithm' simply is
|
||||
+ IBM ldouble 128 (i.e. two seperately scaled doubles).
|
||||
+ The check below assumes big endian. */
|
||||
+ ret = 0;
|
||||
+#endif
|
||||
/*Determine if long double has 16 byte in size, 11 bit exponent, and
|
||||
*the bias is 0x3ff */
|
||||
if(sizeof(long double) == 16) {
|
||||
diff -up hdf5-1.8.12/test/dt_arith.c.ldouble-ppc64le hdf5-1.8.12/test/dt_arith.c
|
||||
--- hdf5-1.8.12/test/dt_arith.c.ldouble-ppc64le 2013-11-21 08:14:03.000000000 -0700
|
||||
+++ hdf5-1.8.12/test/dt_arith.c 2014-03-19 08:58:07.935233518 -0600
|
||||
@@ -3072,7 +3072,18 @@ test_conv_flt_1 (const char *name, int r
|
||||
/*Determine if long double has 16 byte in size, 11 bit exponent, and
|
||||
*the bias is 0x3ff */
|
||||
if(sizeof(long double) == 16) {
|
||||
diff -up hdf5-1.8.16/configure.ldouble-ppc64le hdf5-1.8.16/configure
|
||||
diff -up hdf5-1.8.16/test/dt_arith.c.ldouble-ppc64le hdf5-1.8.16/test/dt_arith.c
|
||||
--- hdf5-1.8.16/test/dt_arith.c.ldouble-ppc64le 2015-10-23 23:13:43.000000000 -0600
|
||||
+++ hdf5-1.8.16/test/dt_arith.c 2015-11-13 09:29:08.765125707 -0700
|
||||
@@ -3010,7 +3010,18 @@ test_conv_flt_1 (const char *name, int r
|
||||
buf, saved, nelmts);
|
||||
#if H5_SIZEOF_LONG_DOUBLE!=H5_SIZEOF_DOUBLE && H5_SIZEOF_LONG_DOUBLE!=0
|
||||
} else if(src_type == FLT_LDOUBLE) {
|
||||
@ -83,7 +53,7 @@ diff -up hdf5-1.8.12/test/dt_arith.c.ldouble-ppc64le hdf5-1.8.12/test/dt_arith.c
|
||||
buf, saved, nelmts);
|
||||
#endif
|
||||
} else
|
||||
@@ -3807,7 +3818,18 @@ test_conv_int_fp(const char *name, int r
|
||||
@@ -3663,7 +3674,18 @@ test_conv_int_fp(const char *name, int r
|
||||
INIT_FP_DENORM(long double, LDBL_MANT_DIG, src_size, src_nbits, sendian, dst_size,
|
||||
buf, saved, nelmts);
|
||||
} else {
|
||||
|
14
hdf5.spec
14
hdf5.spec
@ -1,13 +1,13 @@
|
||||
%global macrosdir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
|
||||
|
||||
# Patch version?
|
||||
%global snaprel -patch1
|
||||
%global snaprel %{nil}
|
||||
|
||||
# NOTE: Try not to release new versions to released versions of Fedora
|
||||
# You need to recompile all users of HDF5 for each version change
|
||||
Name: hdf5
|
||||
Version: 1.8.15
|
||||
Release: 9.patch1%{?dist}
|
||||
Version: 1.8.16
|
||||
Release: 1%{?dist}
|
||||
Summary: A general purpose library and file format for storing scientific data
|
||||
License: BSD
|
||||
Group: System Environment/Libraries
|
||||
@ -16,7 +16,7 @@ URL: http://www.hdfgroup.org/HDF5/
|
||||
Source0: http://www.hdfgroup.org/ftp/HDF5/releases/hdf5-%{version}%{?snaprel}/src/hdf5-%{version}%{?snaprel}.tar.bz2
|
||||
Source1: h5comp
|
||||
# For man pages
|
||||
Source2: http://ftp.us.debian.org/debian/pool/main/h/hdf5/hdf5_1.8.14+docs-3.debian.tar.xz
|
||||
Source2: http://ftp.us.debian.org/debian/pool/main/h/hdf5/hdf5_1.8.15-patch1+docs-5.debian.tar.xz
|
||||
Patch0: hdf5-LD_LIBRARY_PATH.patch
|
||||
# Fix -Werror=format-security errors
|
||||
Patch2: hdf5-format.patch
|
||||
@ -304,6 +304,7 @@ done
|
||||
%{_bindir}/h5stat
|
||||
%{_bindir}/h5unjam
|
||||
%{_libdir}/*.so.10*
|
||||
%{_libdir}/libhdf5_*cpp.so.11*
|
||||
%{_mandir}/man1/gif2h5.1*
|
||||
%{_mandir}/man1/h52gif.1*
|
||||
%{_mandir}/man1/h5copy.1*
|
||||
@ -369,6 +370,7 @@ done
|
||||
%{_libdir}/mpich/bin/h5pfc
|
||||
%{_libdir}/mpich/lib/lib*.so
|
||||
%{_libdir}/mpich/lib/lib*.settings
|
||||
%{_libdir}/mpich/share/hdf5_examples/
|
||||
%{_libdir}/mpich/share/man/man1/h5pcc.1*
|
||||
%{_libdir}/mpich/share/man/man1/h5pfc.1*
|
||||
|
||||
@ -406,6 +408,7 @@ done
|
||||
%{_libdir}/openmpi/bin/h5pfc
|
||||
%{_libdir}/openmpi/lib/lib*.so
|
||||
%{_libdir}/openmpi/lib/lib*.settings
|
||||
%{_libdir}/openmpi/share/hdf5_examples/
|
||||
%{_libdir}/openmpi/share/man/man1/h5pcc.1*
|
||||
%{_libdir}/openmpi/share/man/man1/h5pfc.1*
|
||||
|
||||
@ -415,6 +418,9 @@ done
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Nov 20 2015 Orion Poplawski <orion@cora.nwra.com> - 1.8.16
|
||||
- Update to 1.8.16
|
||||
|
||||
* Fri Nov 20 2015 Orion Poplawski <orion@cora.nwra.com> - 1.8.15-9.patch1
|
||||
- Use MPI_FORTRAN_MOD_DIR to locate MPI Fortran module
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user