Sync up from EL6 branch work
This commit is contained in:
parent
6278daf509
commit
b00e8bb85a
@ -1,5 +1,5 @@
|
||||
--- hdf5-1.8.0-snap6/test/dt_arith.c.longdouble 2008-05-05 16:13:15.000000000 -0600
|
||||
+++ hdf5-1.8.0-snap6/test/dt_arith.c 2008-05-13 09:47:36.000000000 -0600
|
||||
--- hdf5-1.8.5/test/dt_arith.c.longdouble 2010-06-04 08:24:13.000000000 -0600
|
||||
+++ hdf5-1.8.5/test/dt_arith.c 2010-06-23 14:43:49.143913473 -0600
|
||||
@@ -4929,10 +4929,12 @@
|
||||
nerrors += test_conv_int_fp(name, TEST_NORMAL, H5T_NATIVE_USHORT, H5T_NATIVE_LDOUBLE);
|
||||
nerrors += test_conv_int_fp(name, TEST_NORMAL, H5T_NATIVE_INT, H5T_NATIVE_LDOUBLE);
|
||||
@ -13,14 +13,14 @@
|
||||
#if H5_SIZEOF_LONG_LONG!=H5_SIZEOF_LONG
|
||||
#if H5_LLONG_TO_LDOUBLE_CORRECT
|
||||
nerrors += test_conv_int_fp(name, TEST_NORMAL, H5T_NATIVE_LLONG, H5T_NATIVE_LDOUBLE);
|
||||
@@ -5115,10 +5117,12 @@
|
||||
@@ -5094,10 +5096,12 @@
|
||||
#endif
|
||||
}
|
||||
}
|
||||
#endif /*H5_LDOUBLE_TO_UINT_ACCURATE*/
|
||||
+/* Fails on ppc64
|
||||
#if H5_SIZEOF_LONG!=H5_SIZEOF_INT && H5_SIZEOF_LONG_DOUBLE!=0
|
||||
nerrors += test_conv_int_fp(name, test_values, H5T_NATIVE_LDOUBLE, H5T_NATIVE_LONG);
|
||||
nerrors += test_conv_int_fp(name, test_values, H5T_NATIVE_LDOUBLE, H5T_NATIVE_ULONG);
|
||||
nerrors += test_conv_int_fp(name, test_values, H5T_NATIVE_LDOUBLE, H5T_NATIVE_LONG);
|
||||
nerrors += test_conv_int_fp(name, test_values, H5T_NATIVE_LDOUBLE, H5T_NATIVE_ULONG);
|
||||
#endif
|
||||
+*/
|
||||
|
11
hdf5-1.8.5-tstlite.patch
Normal file
11
hdf5-1.8.5-tstlite.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- hdf5-1.8.5/hl/fortran/test/Makefile.in.tstlite 2010-06-04 12:26:00.000000000 -0600
|
||||
+++ hdf5-1.8.5/hl/fortran/test/Makefile.in 2010-06-23 15:04:42.461913836 -0600
|
||||
@@ -367,7 +367,7 @@
|
||||
dsetf[1-4].h5 f1img.h5 f1tab.h5
|
||||
|
||||
# Our main target, the test programs
|
||||
-TEST_PROG = tstlite tstimage tsttable
|
||||
+TEST_PROG = tstimage tsttable
|
||||
LDADD = $(LIBH5F_HL) $(LIBH5F) $(LIBH5_HL) $(LIBHDF5)
|
||||
|
||||
# Source files for the programs
|
12
hdf5.spec
12
hdf5.spec
@ -1,7 +1,7 @@
|
||||
%define snaprel %{nil}
|
||||
Name: hdf5
|
||||
Version: 1.8.5
|
||||
Release: 2%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Summary: A general purpose library and file format for storing scientific data
|
||||
License: BSD
|
||||
Group: System Environment/Libraries
|
||||
@ -9,8 +9,9 @@ URL: http://www.hdfgroup.org/HDF5/
|
||||
#Source0: ftp://ftp.hdfgroup.org/HDF5/current/src/%{name}-%{version}.tar.gz
|
||||
Source0: http://www.hdfgroup.org/ftp/HDF5/current/src/hdf5-%{version}%{?snaprel}.tar.bz2
|
||||
Source1: h5comp
|
||||
Patch1: hdf5-1.8.0-longdouble.patch
|
||||
Patch1: hdf5-1.8.5-longdouble.patch
|
||||
Patch3: hdf5-1.8.0-multiarch.patch
|
||||
Patch4: hdf5-1.8.5-tstlite.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: krb5-devel, openssl-devel, zlib-devel, gcc-gfortran, time
|
||||
|
||||
@ -48,6 +49,7 @@ HDF5 static libraries.
|
||||
%patch1 -p1 -b .longdouble
|
||||
%endif
|
||||
%patch3 -p1 -b .multiarch
|
||||
%patch4 -p1 -b .tstlite
|
||||
find -name '*.[ch]' -o -name '*.f90' -exec chmod -x {} +
|
||||
|
||||
|
||||
@ -160,6 +162,12 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jun 23 2010 Orion Poplawski <orion@cora.nwra.com> 1.8.5-4
|
||||
- Re-add rebased tstlite patch - not fixed yet
|
||||
|
||||
* Wed Jun 23 2010 Orion Poplawski <orion@cora.nwra.com> 1.8.5-3
|
||||
- Update longdouble patch for 1.8.5
|
||||
|
||||
* Wed Jun 23 2010 Orion Poplawski <orion@cora.nwra.com> 1.8.5-2
|
||||
- Re-add longdouble patch on ppc64 for EPEL builds
|
||||
|
||||
|
@ -1 +1,2 @@
|
||||
hdf5-1_8_5-2_el6:HEAD:hdf5-1.8.5-2.el6.src.rpm:1277322248
|
||||
hdf5-1_8_5-4_el6:HEAD:hdf5-1.8.5-4.el6.src.rpm:1277333308
|
||||
|
Loading…
Reference in New Issue
Block a user