Update to 1.8.17
This commit is contained in:
parent
78ddcff82b
commit
ae2a07d22d
2
.gitignore
vendored
2
.gitignore
vendored
@ -19,3 +19,5 @@ hdf5-1.8.5.tar.bz2
|
||||
/hdf5-1.8.15-patch1.tar.bz2
|
||||
/hdf5-1.8.16.tar.bz2
|
||||
/hdf5_1.8.15-patch1+docs-5.debian.tar.xz
|
||||
/hdf5-1.8.17.tar.bz2
|
||||
/hdf5_1.8.16+docs-8.debian.tar.xz
|
||||
|
@ -1,21 +0,0 @@
|
||||
diff -up hdf5-1.8.15/test/error_test.c.format hdf5-1.8.15/test/error_test.c
|
||||
--- hdf5-1.8.15/test/error_test.c.format 2015-05-01 12:36:27.000000000 -0600
|
||||
+++ hdf5-1.8.15/test/error_test.c 2015-05-13 20:27:31.977056438 -0600
|
||||
@@ -498,7 +498,7 @@ test_create(void)
|
||||
if(err_num != 0) TEST_ERROR
|
||||
|
||||
/* Push an error with a long description */
|
||||
- if(H5Epush(estack_id, __FILE__, err_func, __LINE__, ERR_CLS, ERR_MAJ_TEST, ERR_MIN_SUBROUTINE, err_msg) < 0) TEST_ERROR;
|
||||
+ if(H5Epush(estack_id, __FILE__, err_func, __LINE__, ERR_CLS, ERR_MAJ_TEST, ERR_MIN_SUBROUTINE, "%s", err_msg) < 0) TEST_ERROR;
|
||||
|
||||
/* Check the number of errors on stack */
|
||||
err_num = H5Eget_num(estack_id);
|
||||
@@ -543,7 +543,7 @@ test_copy(void)
|
||||
herr_t ret; /* Generic return value */
|
||||
|
||||
/* Push an error with a long description */
|
||||
- if(H5Epush(H5E_DEFAULT, __FILE__, err_func, __LINE__, ERR_CLS, ERR_MAJ_TEST, ERR_MIN_SUBROUTINE, err_msg) < 0) TEST_ERROR;
|
||||
+ if(H5Epush(H5E_DEFAULT, __FILE__, err_func, __LINE__, ERR_CLS, ERR_MAJ_TEST, ERR_MIN_SUBROUTINE, "%s", err_msg) < 0) TEST_ERROR;
|
||||
|
||||
/* Check the number of errors on stack */
|
||||
err_num = H5Eget_num(H5E_DEFAULT);
|
17
hdf5.spec
17
hdf5.spec
@ -6,8 +6,8 @@
|
||||
# NOTE: Try not to release new versions to released versions of Fedora
|
||||
# You need to recompile all users of HDF5 for each version change
|
||||
Name: hdf5
|
||||
Version: 1.8.16
|
||||
Release: 4%{?dist}
|
||||
Version: 1.8.17
|
||||
Release: 1%{?dist}
|
||||
Summary: A general purpose library and file format for storing scientific data
|
||||
License: BSD
|
||||
Group: System Environment/Libraries
|
||||
@ -16,12 +16,10 @@ URL: http://www.hdfgroup.org/HDF5/
|
||||
Source0: http://www.hdfgroup.org/ftp/HDF5/releases/hdf5-%{version}%{?snaprel}/src/hdf5-%{version}%{?snaprel}.tar.bz2
|
||||
Source1: h5comp
|
||||
# For man pages
|
||||
Source2: http://ftp.us.debian.org/debian/pool/main/h/hdf5/hdf5_1.8.15-patch1+docs-5.debian.tar.xz
|
||||
Source2: http://ftp.us.debian.org/debian/pool/main/h/hdf5/hdf5_1.8.16+docs-8.debian.tar.xz
|
||||
Patch0: hdf5-LD_LIBRARY_PATH.patch
|
||||
# Properly run MPI_Finalize() in t_pflush1
|
||||
Patch1: hdf5-mpi.patch
|
||||
# Fix -Werror=format-security errors
|
||||
Patch2: hdf5-format.patch
|
||||
# Fix long double conversions on ppc64le
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1078173
|
||||
Patch3: hdf5-ldouble-ppc64le.patch
|
||||
@ -152,7 +150,6 @@ HDF5 parallel openmpi static libraries
|
||||
%setup -q -a 2 -n %{name}-%{version}%{?snaprel}
|
||||
%patch0 -p1 -b .LD_LIBRARY_PATH
|
||||
%patch1 -p1 -b .mpi
|
||||
%patch2 -p1 -b .format
|
||||
%patch3 -p1 -b .ldouble-ppc64le
|
||||
# Force shared by default for compiler wrappers (bug #1266645)
|
||||
sed -i -e '/^STATIC_AVAILABLE=/s/=.*/=no/' */*/h5[cf]*.in
|
||||
@ -201,6 +198,7 @@ do
|
||||
%{configure_opts} \
|
||||
FCFLAGS="$FCFLAGS -I$MPI_FORTRAN_MOD_DIR" \
|
||||
--enable-parallel \
|
||||
--exec-prefix=%{_libdir}/$mpi \
|
||||
--libdir=%{_libdir}/$mpi/lib \
|
||||
--bindir=%{_libdir}/$mpi/bin \
|
||||
--sbindir=%{_libdir}/$mpi/sbin \
|
||||
@ -308,7 +306,7 @@ done
|
||||
%{_bindir}/h5stat
|
||||
%{_bindir}/h5unjam
|
||||
%{_libdir}/*.so.10*
|
||||
%{_libdir}/libhdf5_*cpp.so.11*
|
||||
%{_libdir}/libhdf5_*cpp.so.12*
|
||||
%{_mandir}/man1/gif2h5.1*
|
||||
%{_mandir}/man1/h52gif.1*
|
||||
%{_mandir}/man1/h5copy.1*
|
||||
@ -422,6 +420,9 @@ done
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri May 13 2016 Orion Poplawski <orion@cora.nwra.com> - 1.8.17-1
|
||||
- Update to 1.8.17
|
||||
|
||||
* Sun Mar 20 2016 Orion Poplawski <orion@cora.nwra.com> - 1.8.16-4
|
||||
- Add patch to properly call MPI_Finalize() in t_pflush1
|
||||
|
||||
@ -431,7 +432,7 @@ done
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.16-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Fri Nov 20 2015 Orion Poplawski <orion@cora.nwra.com> - 1.8.16
|
||||
* Fri Nov 20 2015 Orion Poplawski <orion@cora.nwra.com> - 1.8.16-1
|
||||
- Update to 1.8.16
|
||||
|
||||
* Fri Nov 20 2015 Orion Poplawski <orion@cora.nwra.com> - 1.8.15-9.patch1
|
||||
|
Loading…
Reference in New Issue
Block a user