Update to 1.8.8
Drop tstlite patch Add patch to avoid setting LD_LIBRARY_PATH
This commit is contained in:
parent
2a78ffb146
commit
79166aab3d
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@ hdf5-1.8.5.tar.bz2
|
||||
/hdf5-1.8.5-patch1.tar.bz2
|
||||
/hdf5-1.8.6.tar.bz2
|
||||
/hdf5-1.8.7.tar.bz2
|
||||
/hdf5-1.8.8.tar.bz2
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up hdf5-1.8.6/hl/fortran/test/Makefile.in.tstlite hdf5-1.8.6/hl/fortran/test/Makefile.in
|
||||
--- hdf5-1.8.6/hl/fortran/test/Makefile.in.tstlite 2011-02-14 09:24:24.000000000 -0700
|
||||
+++ hdf5-1.8.6/hl/fortran/test/Makefile.in 2011-02-18 14:39:45.755110289 -0700
|
||||
@@ -377,7 +377,7 @@ CHECK_CLEANFILES = *.chkexe *.chklog *.c
|
||||
f1tab.h5
|
||||
|
||||
# Our main target, the test programs
|
||||
-TEST_PROG = tstlite tstimage tsttable
|
||||
+TEST_PROG = tstimage tsttable
|
||||
LDADD = $(LIBH5F_HL) $(LIBH5F) $(LIBH5_HL) $(LIBHDF5)
|
||||
|
||||
# Source files for the programs
|
33
hdf5-LD_LIBRARY_PATH.patch
Normal file
33
hdf5-LD_LIBRARY_PATH.patch
Normal file
@ -0,0 +1,33 @@
|
||||
diff -up hdf5-1.8.8/configure.LD_LIBRARY_PATH hdf5-1.8.8/configure
|
||||
--- hdf5-1.8.8/configure.LD_LIBRARY_PATH 2011-11-16 11:21:54.511269486 -0700
|
||||
+++ hdf5-1.8.8/configure 2011-11-16 11:28:18.673392600 -0700
|
||||
@@ -26746,8 +26746,6 @@ $as_echo_n "checking how to print long l
|
||||
if ${hdf5_cv_printf_ll+:} false; then :
|
||||
$as_echo_n "(cached) " >&6
|
||||
else
|
||||
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH`echo $AM_LDFLAGS $LDFLAGS | sed -e 's/-L/:/g' -e 's/ //g'`"
|
||||
-export LD_LIBRARY_PATH
|
||||
|
||||
for hdf5_cv_printf_ll in l ll L q unknown; do
|
||||
if test "$cross_compiling" = yes; then :
|
||||
diff -up hdf5-1.8.8/src/Makefile.in.LD_LIBRARY_PATH hdf5-1.8.8/src/Makefile.in
|
||||
--- hdf5-1.8.8/src/Makefile.in.LD_LIBRARY_PATH 2011-11-15 08:13:54.000000000 -0700
|
||||
+++ hdf5-1.8.8/src/Makefile.in 2011-11-16 11:43:42.938914069 -0700
|
||||
@@ -1267,8 +1267,6 @@ help:
|
||||
# Remove the generated .c file if errors occur unless HDF5_Make_Ignore
|
||||
# is set to ignore the error.
|
||||
H5Tinit.c: H5detect$(EXEEXT)
|
||||
- LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
|
||||
- sed -e 's/-L/:/g' -e 's/ //g'`" \
|
||||
$(RUNSERIAL) ./H5detect$(EXEEXT) > $@ || \
|
||||
(test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
|
||||
($(RM) $@ ; exit 1)
|
||||
@@ -1279,8 +1277,6 @@ H5Tinit.c: H5detect$(EXEEXT)
|
||||
# Remove the generated .c file if errors occur unless HDF5_Make_Ignore
|
||||
# is set to ignore the error.
|
||||
H5lib_settings.c: H5make_libsettings$(EXEEXT) libhdf5.settings
|
||||
- LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
|
||||
- sed -e 's/-L/:/g' -e 's/ //g'`" \
|
||||
$(RUNSERIAL) ./H5make_libsettings$(EXEEXT) > $@ || \
|
||||
(test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
|
||||
($(RM) $@ ; exit 1)
|
13
hdf5.spec
13
hdf5.spec
@ -3,15 +3,15 @@
|
||||
# NOTE: Try not to realease new versions to released versions of Fedora
|
||||
# You need to recompile all users of HDF5 for each version change
|
||||
Name: hdf5
|
||||
Version: 1.8.7
|
||||
Release: 2%{?dist}
|
||||
Version: 1.8.8
|
||||
Release: 1%{?dist}
|
||||
Summary: A general purpose library and file format for storing scientific data
|
||||
License: BSD
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.hdfgroup.org/HDF5/
|
||||
Source0: http://www.hdfgroup.org/ftp/HDF5/current/src/hdf5-%{version}%{?snaprel}.tar.bz2
|
||||
Source1: h5comp
|
||||
Patch4: hdf5-1.8.6-tstlite.patch
|
||||
Patch0: hdf5-LD_LIBRARY_PATH.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: krb5-devel, openssl-devel, zlib-devel, gcc-gfortran, time
|
||||
|
||||
@ -109,7 +109,7 @@ HDF5 parallel openmpi development files
|
||||
%prep
|
||||
#setup -q -n %{name}-%{version}%{?snaprel}
|
||||
%setup -q
|
||||
%patch4 -p1 -b .tstlite
|
||||
%patch0 -p1 -b .LD_LIBRARY_PATH
|
||||
#This should be fixed in 1.8.7
|
||||
find \( -name '*.[ch]*' -o -name '*.f90' -o -name '*.txt' \) -exec chmod -x {} +
|
||||
|
||||
@ -336,6 +336,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Nov 15 2011 Orion Poplawski <orion@cora.nwra.com> 1.8.8-1
|
||||
- Update to 1.8.8
|
||||
- Drop tstlite patch
|
||||
- Add patch to avoid setting LD_LIBRARY_PATH
|
||||
|
||||
* Wed Jun 01 2011 Karsten Hopp <karsten@redhat.com> 1.8.7-2
|
||||
- drop ppc64 longdouble patch, not required anymore
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user