Add upstream patch to fix 32-bit java tests
This commit is contained in:
parent
214dacd119
commit
7461ed3f0f
13
fix-HDFFV-10745.patch
Normal file
13
fix-HDFFV-10745.patch
Normal file
@ -0,0 +1,13 @@
|
||||
Index: hdf5/java/src/jni/h5pFCPLImp.c
|
||||
===================================================================
|
||||
--- hdf5.orig/java/src/jni/h5pFCPLImp.c
|
||||
+++ hdf5/java/src/jni/h5pFCPLImp.c
|
||||
@@ -240,7 +240,7 @@ Java_hdf_hdf5lib_H5_H5Pget_1sym_1k
|
||||
|
||||
done:
|
||||
if (theArray)
|
||||
- UNPIN_LONG_ARRAY(ENVONLY, size, theArray, (status < 0) ? JNI_ABORT : 0);
|
||||
+ UNPIN_INT_ARRAY(ENVONLY, size, theArray, (status < 0) ? JNI_ABORT : 0);
|
||||
|
||||
return (jint)status;
|
||||
} /* end Java_hdf_hdf5lib_H5_H5Pget_1sym_1k */
|
@ -120,24 +120,6 @@ diff -up hdf5-1.10.5/java/test/junit.sh.in.build hdf5-1.10.5/java/test/junit.sh.
|
||||
TESTJARFILE=jar@PACKAGE_TARNAME@test.jar
|
||||
test -d $BLDLIBDIR || mkdir -p $BLDLIBDIR
|
||||
|
||||
@@ -418,7 +418,7 @@ if diff JUnit-TestH5Fbasic.out JUnit-Tes
|
||||
else
|
||||
echo "**FAILED** JUnit-TestH5Fbasic"
|
||||
echo " Expected result differs from actual result"
|
||||
- nerrors="`expr $nerrors + 1`"
|
||||
+ #nerrors="`expr $nerrors + 1`"
|
||||
test yes = "$verbose" && $DIFF JUnit-TestH5Fbasic.txt JUnit-TestH5Fbasic.out |sed 's/^/ /'
|
||||
fi
|
||||
|
||||
@@ -775,7 +775,7 @@ if diff JUnit-TestH5P.out JUnit-TestH5P.
|
||||
else
|
||||
echo "**FAILED** JUnit-TestH5P"
|
||||
echo " Expected result differs from actual result"
|
||||
- nerrors="`expr $nerrors + 1`"
|
||||
+ #nerrors="`expr $nerrors + 1`"
|
||||
test yes = "$verbose" && $DIFF JUnit-TestH5P.txt JUnit-TestH5P.out |sed 's/^/ /'
|
||||
fi
|
||||
|
||||
diff -up hdf5-1.10.5/java/test/Makefile.am.build hdf5-1.10.5/java/test/Makefile.am
|
||||
--- hdf5-1.10.5/java/test/Makefile.am.build 2019-02-16 15:41:11.000000000 -0700
|
||||
+++ hdf5-1.10.5/java/test/Makefile.am 2019-04-07 15:29:56.309854683 -0600
|
||||
|
10
hdf5.spec
10
hdf5.spec
@ -7,7 +7,7 @@
|
||||
# You need to recompile all users of HDF5 for each version change
|
||||
Name: hdf5
|
||||
Version: 1.10.5
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Summary: A general purpose library and file format for storing scientific data
|
||||
License: BSD
|
||||
URL: https://portal.hdfgroup.org/display/HDF5/HDF5
|
||||
@ -22,9 +22,9 @@ Patch1: hdf5-mpi.patch
|
||||
# Fix some warnings
|
||||
Patch2: hdf5-warning.patch
|
||||
# Fix java build
|
||||
# JUnit-TestH5Fbasic test is failing
|
||||
# JUnit-TestH5P is failing on 32-bit
|
||||
Patch3: hdf5-build.patch
|
||||
# Upstream fix for Java tests
|
||||
Patch4: https://jira.hdfgroup.org/secure/attachment/26110/fix-HDFFV-10745.patch
|
||||
|
||||
BuildRequires: gcc-gfortran
|
||||
BuildRequires: java-devel
|
||||
@ -172,6 +172,7 @@ HDF5 parallel openmpi static libraries
|
||||
#patch1 -p1 -b .mpi
|
||||
%patch2 -p1 -b .warning
|
||||
%patch3 -p1 -b .build
|
||||
%patch4 -p1 -b .jira
|
||||
|
||||
# Replace jars with system versions
|
||||
find -name \*.jar -delete
|
||||
@ -489,6 +490,9 @@ done
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Nov 11 2019 Orion Poplawski <orion@nwra.com> - 1.10.5-4
|
||||
- Add upstream patch to fix 32-bit java tests
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.5-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user