Update to 1.6.5
This commit is contained in:
parent
3ea0e2f839
commit
6a5535bee9
@ -1 +1 @@
|
|||||||
hdf5-1.6.4.tar.gz
|
hdf5-1.6.5.tar.gz
|
||||||
|
@ -1,17 +1,17 @@
|
|||||||
--- hdf5-1.6.4/tools/lib/h5diff_attr.c.orig 2005-07-01 08:47:12.000000000 -0600
|
--- hdf5-1.6.5/tools/lib/h5diff_attr.c.orig 2005-12-21 12:08:45.000000000 -0700
|
||||||
+++ hdf5-1.6.4/tools/lib/h5diff_attr.c 2005-07-01 09:01:59.000000000 -0600
|
+++ hdf5-1.6.5/tools/lib/h5diff_attr.c 2005-12-21 12:11:17.000000000 -0700
|
||||||
@@ -61,8 +61,8 @@
|
@@ -61,8 +61,8 @@
|
||||||
int rank2; /* rank of dataset */
|
int rank2; /* rank of dataset */
|
||||||
hsize_t dims1[H5S_MAX_RANK];/* dimensions of dataset */
|
hsize_t dims1[H5S_MAX_RANK];/* dimensions of dataset */
|
||||||
hsize_t dims2[H5S_MAX_RANK];/* dimensions of dataset */
|
hsize_t dims2[H5S_MAX_RANK];/* dimensions of dataset */
|
||||||
- char name1[255];
|
- char name1[255];
|
||||||
- char name2[255];
|
- char name2[255];
|
||||||
+ char name1[255],np1[512];
|
+ char name1[255],np1[512];
|
||||||
+ char name2[255],np2[512];
|
+ char name2[255],np2[512];
|
||||||
int n1, n2, i, j;
|
int n1, n2, i, j;
|
||||||
int ret=0;
|
int ret=0;
|
||||||
hsize_t nfound;
|
hsize_t nfound;
|
||||||
@@ -191,21 +191,21 @@
|
@@ -196,21 +196,21 @@
|
||||||
* array compare
|
* array compare
|
||||||
*-------------------------------------------------------------------------
|
*-------------------------------------------------------------------------
|
||||||
*/
|
*/
|
||||||
@ -23,9 +23,9 @@
|
|||||||
/* always print name */
|
/* always print name */
|
||||||
if (options->m_verbose)
|
if (options->m_verbose)
|
||||||
{
|
{
|
||||||
- printf( "Attribute: <%s> and <%s>\n",name1,name2);
|
- printf( "Attribute: <%s> and <%s>\n",name1,name2);
|
||||||
+ printf( "Attribute: <%s> and <%s>\n",np1,np2);
|
+ printf( "Attribute: <%s> and <%s>\n",np1,np2);
|
||||||
nfound = diff_array(buf1,
|
nfound = diff_array(buf1,
|
||||||
buf2,
|
buf2,
|
||||||
nelmts1,
|
nelmts1,
|
||||||
rank1,
|
rank1,
|
||||||
@ -38,7 +38,7 @@
|
|||||||
mtype1_id,
|
mtype1_id,
|
||||||
attr1_id,
|
attr1_id,
|
||||||
attr2_id);
|
attr2_id);
|
||||||
@@ -225,8 +225,8 @@
|
@@ -230,8 +230,8 @@
|
||||||
rank1,
|
rank1,
|
||||||
dims1,
|
dims1,
|
||||||
options,
|
options,
|
||||||
@ -49,13 +49,13 @@
|
|||||||
mtype1_id,
|
mtype1_id,
|
||||||
attr1_id,
|
attr1_id,
|
||||||
attr2_id);
|
attr2_id);
|
||||||
@@ -234,15 +234,15 @@
|
@@ -239,15 +239,15 @@
|
||||||
options->m_quiet=0;
|
options->m_quiet=0;
|
||||||
if (nfound)
|
if (nfound)
|
||||||
{
|
{
|
||||||
- printf( "Attribute: <%s> and <%s>\n",name1,name2);
|
- printf( "Attribute: <%s> and <%s>\n",name1,name2);
|
||||||
+ printf( "Attribute: <%s> and <%s>\n",np1,np2);
|
+ printf( "Attribute: <%s> and <%s>\n",np1,np2);
|
||||||
nfound = diff_array(buf1,
|
nfound = diff_array(buf1,
|
||||||
buf2,
|
buf2,
|
||||||
nelmts1,
|
nelmts1,
|
||||||
rank1,
|
rank1,
|
||||||
@ -68,7 +68,7 @@
|
|||||||
mtype1_id,
|
mtype1_id,
|
||||||
attr1_id,
|
attr1_id,
|
||||||
attr2_id);
|
attr2_id);
|
||||||
@@ -258,8 +258,8 @@
|
@@ -263,8 +263,8 @@
|
||||||
rank1,
|
rank1,
|
||||||
dims1,
|
dims1,
|
||||||
options,
|
options,
|
12
hdf5.spec
12
hdf5.spec
@ -1,6 +1,6 @@
|
|||||||
Name: hdf5
|
Name: hdf5
|
||||||
Version: 1.6.4
|
Version: 1.6.5
|
||||||
Release: 9%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A general purpose library and file format for storing scientific data
|
Summary: A general purpose library and file format for storing scientific data
|
||||||
License: BSD-ish
|
License: BSD-ish
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -10,10 +10,10 @@ Patch0: hdf5-1.6.4-gcc4.patch
|
|||||||
Patch1: hdf5-1.6.4-destdir.patch
|
Patch1: hdf5-1.6.4-destdir.patch
|
||||||
Patch2: hdf5-1.6.4-norpath.patch
|
Patch2: hdf5-1.6.4-norpath.patch
|
||||||
Patch3: hdf5-1.6.4-testh5repack.patch
|
Patch3: hdf5-1.6.4-testh5repack.patch
|
||||||
Patch4: hdf5-1.6.4-h5diff_attr.patch
|
Patch4: hdf5-1.6.5-h5diff_attr.patch
|
||||||
Patch5: hdf5-1.6.4-ppc.patch
|
Patch5: hdf5-1.6.4-ppc.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: krb5-devel, openssl-devel, zlib-devel, gcc-gfortran
|
BuildRequires: krb5-devel, openssl-devel, zlib-devel, gcc-gfortran, time
|
||||||
|
|
||||||
%description
|
%description
|
||||||
HDF5 is a general purpose library and file format for storing scientific data.
|
HDF5 is a general purpose library and file format for storing scientific data.
|
||||||
@ -76,6 +76,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_bindir}/h5import
|
%{_bindir}/h5import
|
||||||
%{_bindir}/h5jam
|
%{_bindir}/h5jam
|
||||||
%{_bindir}/h5ls
|
%{_bindir}/h5ls
|
||||||
|
%{_bindir}/h5perf
|
||||||
%{_bindir}/h5repack
|
%{_bindir}/h5repack
|
||||||
%{_bindir}/h5repart
|
%{_bindir}/h5repart
|
||||||
%{_bindir}/h5unjam
|
%{_bindir}/h5unjam
|
||||||
@ -94,6 +95,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/*.mod
|
%{_libdir}/*.mod
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 21 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.5-1
|
||||||
|
- Update to 1.6.5
|
||||||
|
|
||||||
* Wed Dec 21 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-9
|
* Wed Dec 21 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-9
|
||||||
- Rebuild
|
- Rebuild
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user