Update to 1.8.15
This commit is contained in:
parent
9d4c19dc16
commit
2fd5a50783
2
.gitignore
vendored
2
.gitignore
vendored
@ -14,3 +14,5 @@ hdf5-1.8.5.tar.bz2
|
||||
/hdf5_1.8.12+docs-1.1.debian.tar.xz
|
||||
/hdf5-1.8.14.tar.bz2
|
||||
/hdf5_1.8.13+docs-15.debian.tar.xz
|
||||
/hdf5-1.8.15.tar.bz2
|
||||
/hdf5_1.8.14+docs-3.debian.tar.xz
|
||||
|
@ -19,52 +19,3 @@ diff -up hdf5-1.8.13/src/Makefile.am.LD_LIBRARY_PATH hdf5-1.8.13/src/Makefile.am
|
||||
$(RUNSERIAL) ./H5make_libsettings$(EXEEXT) > $@ || \
|
||||
(test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
|
||||
($(RM) $@ ; exit 1)
|
||||
diff -up hdf5-1.8.13/src/Makefile.in.LD_LIBRARY_PATH hdf5-1.8.13/src/Makefile.in
|
||||
--- hdf5-1.8.13/src/Makefile.in.LD_LIBRARY_PATH 2014-05-05 20:15:48.000000000 -0600
|
||||
+++ hdf5-1.8.13/src/Makefile.in 2014-05-15 09:44:15.622418784 -0600
|
||||
@@ -1,4 +1,4 @@
|
||||
-# Makefile.in generated by automake 1.14.1 from Makefile.am.
|
||||
+# Makefile.in generated by automake 1.13.4 from Makefile.am.
|
||||
# @configure_input@
|
||||
|
||||
# Copyright (C) 1994-2013 Free Software Foundation, Inc.
|
||||
@@ -109,7 +109,10 @@ noinst_PROGRAMS = H5detect$(EXEEXT) H5ma
|
||||
TESTS =
|
||||
subdir = src
|
||||
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
||||
-am__aclocal_m4_deps = $(top_srcdir)/configure.ac
|
||||
+am__aclocal_m4_deps = $(top_srcdir)/m4/libtool.m4 \
|
||||
+ $(top_srcdir)/m4/ltoptions.m4 $(top_srcdir)/m4/ltsugar.m4 \
|
||||
+ $(top_srcdir)/m4/ltversion.m4 $(top_srcdir)/m4/lt~obsolete.m4 \
|
||||
+ $(top_srcdir)/configure.ac
|
||||
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
|
||||
$(ACLOCAL_M4)
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/bin/mkinstalldirs
|
||||
@@ -883,8 +886,8 @@ $(ACLOCAL_M4): @MAINTAINER_MODE_TRUE@ $(
|
||||
$(am__aclocal_m4_deps):
|
||||
|
||||
H5config.h: stamp-h1
|
||||
- @test -f $@ || rm -f stamp-h1
|
||||
- @test -f $@ || $(MAKE) $(AM_MAKEFLAGS) stamp-h1
|
||||
+ @if test ! -f $@; then rm -f stamp-h1; else :; fi
|
||||
+ @if test ! -f $@; then $(MAKE) $(AM_MAKEFLAGS) stamp-h1; else :; fi
|
||||
|
||||
stamp-h1: $(srcdir)/H5config.h.in $(top_builddir)/config.status
|
||||
@rm -f stamp-h1
|
||||
@@ -1207,14 +1210,14 @@ distclean-compile:
|
||||
@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
|
||||
@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(AM_V_CC)source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
|
||||
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
||||
-@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(COMPILE) -c -o $@ $<
|
||||
+@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(COMPILE) -c $<
|
||||
|
||||
.c.obj:
|
||||
@am__fastdepCC_TRUE@ $(AM_V_CC)$(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ `$(CYGPATH_W) '$<'`
|
||||
@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
|
||||
@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(AM_V_CC)source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
|
||||
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
||||
-@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(COMPILE) -c -o $@ `$(CYGPATH_W) '$<'`
|
||||
+@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(COMPILE) -c `$(CYGPATH_W) '$<'`
|
||||
|
||||
.c.lo:
|
||||
@am__fastdepCC_TRUE@ $(AM_V_CC)$(LTCOMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
|
||||
|
21
hdf5-format.patch
Normal file
21
hdf5-format.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -up hdf5-1.8.15/test/error_test.c.format hdf5-1.8.15/test/error_test.c
|
||||
--- hdf5-1.8.15/test/error_test.c.format 2015-05-01 12:36:27.000000000 -0600
|
||||
+++ hdf5-1.8.15/test/error_test.c 2015-05-13 20:27:31.977056438 -0600
|
||||
@@ -498,7 +498,7 @@ test_create(void)
|
||||
if(err_num != 0) TEST_ERROR
|
||||
|
||||
/* Push an error with a long description */
|
||||
- if(H5Epush(estack_id, __FILE__, err_func, __LINE__, ERR_CLS, ERR_MAJ_TEST, ERR_MIN_SUBROUTINE, err_msg) < 0) TEST_ERROR;
|
||||
+ if(H5Epush(estack_id, __FILE__, err_func, __LINE__, ERR_CLS, ERR_MAJ_TEST, ERR_MIN_SUBROUTINE, "%s", err_msg) < 0) TEST_ERROR;
|
||||
|
||||
/* Check the number of errors on stack */
|
||||
err_num = H5Eget_num(estack_id);
|
||||
@@ -543,7 +543,7 @@ test_copy(void)
|
||||
herr_t ret; /* Generic return value */
|
||||
|
||||
/* Push an error with a long description */
|
||||
- if(H5Epush(H5E_DEFAULT, __FILE__, err_func, __LINE__, ERR_CLS, ERR_MAJ_TEST, ERR_MIN_SUBROUTINE, err_msg) < 0) TEST_ERROR;
|
||||
+ if(H5Epush(H5E_DEFAULT, __FILE__, err_func, __LINE__, ERR_CLS, ERR_MAJ_TEST, ERR_MIN_SUBROUTINE, "%s", err_msg) < 0) TEST_ERROR;
|
||||
|
||||
/* Check the number of errors on stack */
|
||||
err_num = H5Eget_num(H5E_DEFAULT);
|
18
hdf5.spec
18
hdf5.spec
@ -6,8 +6,8 @@
|
||||
# NOTE: Try not to release new versions to released versions of Fedora
|
||||
# You need to recompile all users of HDF5 for each version change
|
||||
Name: hdf5
|
||||
Version: 1.8.14
|
||||
Release: 4%{?dist}
|
||||
Version: 1.8.15
|
||||
Release: 1%{?dist}
|
||||
Summary: A general purpose library and file format for storing scientific data
|
||||
License: BSD
|
||||
Group: System Environment/Libraries
|
||||
@ -16,9 +16,11 @@ URL: http://www.hdfgroup.org/HDF5/
|
||||
Source0: http://www.hdfgroup.org/ftp/HDF5/releases/hdf5-%{version}%{?snaprel}/src/hdf5-%{version}%{?snaprel}.tar.bz2
|
||||
Source1: h5comp
|
||||
# For man pages
|
||||
Source2: http://ftp.us.debian.org/debian/pool/main/h/hdf5/hdf5_1.8.13+docs-15.debian.tar.xz
|
||||
Source2: http://ftp.us.debian.org/debian/pool/main/h/hdf5/hdf5_1.8.14+docs-3.debian.tar.xz
|
||||
Patch0: hdf5-LD_LIBRARY_PATH.patch
|
||||
Patch1: hdf5-1.8.8-tstlite.patch
|
||||
# Fix -Werror=format-security errors
|
||||
Patch2: hdf5-format.patch
|
||||
# Fix long double conversions on ppc64le
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1078173
|
||||
Patch3: hdf5-ldouble-ppc64le.patch
|
||||
@ -155,6 +157,7 @@ HDF5 parallel openmpi static libraries
|
||||
# the tstlite test fails with "stack smashing detected" on these arches
|
||||
%patch1 -p1 -b .tstlite
|
||||
%endif
|
||||
%patch2 -p1 -b .format
|
||||
%patch3 -p1 -b .ldouble-ppc64le
|
||||
#This should be fixed in 1.8.7
|
||||
find \( -name '*.[ch]*' -o -name '*.f90' -o -name '*.txt' \) -exec chmod -x {} +
|
||||
@ -308,7 +311,7 @@ done
|
||||
%{_bindir}/h5repart
|
||||
%{_bindir}/h5stat
|
||||
%{_bindir}/h5unjam
|
||||
%{_libdir}/*.so.*
|
||||
%{_libdir}/*.so.10*
|
||||
%{_mandir}/man1/gif2h5.1*
|
||||
%{_mandir}/man1/h52gif.1*
|
||||
%{_mandir}/man1/h5copy.1*
|
||||
@ -366,7 +369,7 @@ done
|
||||
%{_libdir}/mpich/bin/h5stat
|
||||
%{_libdir}/mpich/bin/h5unjam
|
||||
%{_libdir}/mpich/bin/ph5diff
|
||||
%{_libdir}/mpich/lib/*.so.*
|
||||
%{_libdir}/mpich/lib/*.so.10*
|
||||
|
||||
%files mpich-devel
|
||||
%{_includedir}/mpich-%{_arch}
|
||||
@ -403,7 +406,7 @@ done
|
||||
%{_libdir}/openmpi/bin/h5stat
|
||||
%{_libdir}/openmpi/bin/h5unjam
|
||||
%{_libdir}/openmpi/bin/ph5diff
|
||||
%{_libdir}/openmpi/lib/*.so.*
|
||||
%{_libdir}/openmpi/lib/*.so.10*
|
||||
|
||||
%files openmpi-devel
|
||||
%{_includedir}/openmpi-%{_arch}
|
||||
@ -420,6 +423,9 @@ done
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat May 16 2015 Orion Poplawski <orion@cora.nwra.com> - 1.8.15-1
|
||||
- Update to 1.8.15
|
||||
|
||||
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 1.8.14-4
|
||||
- Rebuilt for GCC 5 C++11 ABI change
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user