auto-import hdf-4.2r1-2 on branch devel from hdf-4.2r1-2.src.rpm

This commit is contained in:
Orion Poplawski 2005-07-25 18:07:39 +00:00
parent 18f96a2081
commit e82443665e
4 changed files with 173 additions and 0 deletions

View File

@ -0,0 +1,2 @@
4.2r1-hrepack-patch.tar
HDF4.2r1.tar.gz

92
hdf-4.2r1-configure.patch Normal file
View File

@ -0,0 +1,92 @@
--- HDF4.2r1/configure.ac.orig 2005-07-15 14:52:14.000000000 -0600
+++ HDF4.2r1/configure.ac 2005-07-15 14:53:35.000000000 -0600
@@ -528,7 +528,7 @@
dnl ======================================================================
AC_MSG_CHECKING([for math library support])
-AC_TRY_LINK([#include <math.h>], [sqrt(37.927)],
+AC_TRY_LINK([#include <math.h>], [sinh(37.927)],
[AC_MSG_RESULT([yes])],
[AC_MSG_RESULT([no]); LIBS="$LIBS -lm"])
--- HDF4.2r1/mfhdf/fortran/config/ftest-linux.f.orig 2005-02-08 20:04:07.000000000 -0700
+++ HDF4.2r1/mfhdf/fortran/config/ftest-linux.f 2005-07-15 15:37:22.000000000 -0600
@@ -138,13 +138,13 @@
integer*2 shval(2)
integer i, j, k
character*31 varnam, attname(2,7), gattnam(2)
- byte bytval(2)
+ integer*1 bytval(2)
common /atts/attname, gattnam
integer*2 svalidrg(2)
real rvalidrg(2)
integer lvalidrg(2)
double precision dvalidrg(2)
- byte bvalidrg(2)
+ integer*1 bvalidrg(2)
character*31 gavalue(2), cavalue(2)
real epsilon
@@ -337,7 +337,7 @@
real flval(2)
integer lngval(2)
integer*2 shval(2)
- byte bytval(2)
+ integer*1 bytval(2)
integer vartyp, nvdims, vdims(MAXVDIMS), nvatts
character*31 varnam, attname(2,7), gattnam(2)
@@ -346,7 +346,7 @@
real rvalidrg(2)
integer lvalidrg(2)
double precision dvalidrg(2)
- byte bvalidrg(2)
+ integer*1 bvalidrg(2)
character*31 gavalue(2), cavalue(2)
real epsilon
@@ -470,7 +470,7 @@
real rvalidrg(2)
integer lvalidrg(2)
double precision dvalidrg(2)
- byte bvalidrg(2)
+ integer*1 bvalidrg(2)
c variable ids
integer bid, sid, lid, fid, did, cid, chid
@@ -883,7 +883,7 @@
integer itime, ilev, ilat, ilon
c arrays of data values to be read
- byte barray(times), byval(times)
+ integer*1 barray(times), byval(times)
integer*2 sarray(times), shval(times)
integer larray(lats)
real farray(levels, lats, lons, times)
@@ -1009,7 +1009,7 @@
integer bid, sid, lid, fid, did, cid, chid
common /vars/bid, sid, lid, fid, did, cid, chid
- byte bvalue
+ integer*1 bvalue
integer*2 svalue
integer lvalue
real fvalue
@@ -1097,7 +1097,7 @@
integer count(MAXNCDIM)
c arrays of data values to be written
- byte barray(times)
+ integer*1 barray(times)
integer*2 sarray(times)
integer larray(lats)
real farray(levels, lats, lons, times)
@@ -1184,7 +1184,7 @@
integer lvalue
integer*2 svalue
- byte bvalue
+ integer*1 bvalue
double precision onethird
integer bid, sid, lid, fid, did, cid, chid
common /vars/bid, sid, lid, fid, did, cid, chid

77
hdf.spec Normal file
View File

@ -0,0 +1,77 @@
Name: hdf
Version: 4.2r1
Release: 2%{?dist}
Summary: A general purpose library and file format for storing scientific data
License: BSD-ish
Group: System Environment/Libraries
URL: http://hdf.ncsa.uiuc.edu/HDF/
Source0: ftp://ftp.ncsa.uiuc.edu/HDF/HDF/HDF_Current/src/HDF%{version}.tar.gz
Source1: ftp://ftp.ncsa.uiuc.edu/HDF/HDF/HDF_Current/src/patches/4.2r1-hrepack-patch.tar
Patch0: hdf-4.2r1-configure.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: autoconf flex byacc libjpeg-devel zlib-devel
BuildRequires: gcc-gfortran
%description
HDF is a general purpose library and file format for storing scientific data.
HDF can store two primary objects: datasets and groups. A dataset is
essentially a multidimensional array of data elements, and a group is a
structure for organizing objects in an HDF file. Using these two basic
objects, one can create and store almost any kind of scientific data
structure, such as images, arrays of vectors, and structured and unstructured
grids. You can also mix and match them in HDF files according to your needs.
%package devel
Summary: HDF development files
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
%description devel
HDF development headers and libraries.
%prep
%setup -q -n HDF%{version}
tar xf %{SOURCE1} --directory mfhdf/hrepack
mv mfhdf/hrepack/4.2r1-hrepack-patch/*.[ch] mfhdf/hrepack
rm -r mfhdf/hrepack/4.2r1-hrepack-patch
%patch0 -p1 -b .orig
%build
autoconf
%configure F77=gfortran FFLAGS=-ffixed-line-length-none
make
%install
rm -rf $RPM_BUILD_ROOT
%makeinstall includedir=${RPM_BUILD_ROOT}%{_includedir}/%{name} \
libdir=$RPM_BUILD_ROOT%{_libdir}/%{name}
#Don't conflict with netcdf
rm $RPM_BUILD_ROOT%{_bindir}/nc* $RPM_BUILD_ROOT%{_mandir}/man1/nc*
%check
make check
%clean
rm -rf $RPM_BUILD_ROOT
%post
%postun
%files
%defattr(-,root,root,0755)
%doc COPYING MANIFEST README release_notes/*.txt
%{_bindir}/*
%{_mandir}/man1/*.gz
%files devel
%defattr(-,root,root,0755)
%{_includedir}/%{name}/
%{_libdir}/%{name}/
%changelog
* Wed Jul 20 2005 Orion Poplawski <orion@cora.nwra.com> 4.2r1-2
- Fix BuildRequires to have autoconf
* Fri Jul 15 2005 Orion Poplawski <orion@cora.nwra.com> 4.2r1-1
- inital package for Fedora Extras

View File

@ -0,0 +1,2 @@
d172631b6e6f32c4f93f647a09862011 4.2r1-hrepack-patch.tar
9082c6fa913b9188452fa6c5217e1573 HDF4.2r1.tar.gz