Update to 4.2r4 synced from devel

This commit is contained in:
Orion Poplawski 2009-09-18 17:23:18 +00:00
parent 59a2f49aeb
commit 970fab88e4
8 changed files with 60 additions and 52 deletions

View File

@ -1 +1 @@
HDF4.2r3.tar.gz
HDF4.2r4.tar.gz

View File

@ -1,11 +0,0 @@
--- 4.2r1-hrepack-p4/mfhdf/libsrc/file.c.maxavailfiles 2007-04-20 12:21:12.000000000 -0600
+++ 4.2r1-hrepack-p4/mfhdf/libsrc/file.c 2007-04-20 12:21:50.000000000 -0600
@@ -31,7 +31,7 @@
/* Maximum number of files can be opened at one time; subtract 3 from
the system allowed to account for stdin, stdout, and stderr */
-#define MAX_AVAIL_OPENFILES (MAX_SYS_OPENFILES - 3)
+#define MAX_AVAIL_OPENFILES (MAX_SYS_OPENFILES - 10)
static int _ncdf = 0 ; /* high water mark on open cdf's */
static NC **_cdfs;

View File

@ -1,22 +0,0 @@
--- HDF4.2r2/mfhdf/hdiff/Makefile.in.libm 2008-02-05 14:36:29.000000000 -0700
+++ HDF4.2r2/mfhdf/hdiff/Makefile.in 2008-02-05 14:36:52.000000000 -0700
@@ -196,7 +196,7 @@
hdiff_mattbl.c hdiff_gattr.c hdiff_misc.c hdiff_sds.c \
hdiff_table.c hdiff_vs.c hdiff_dim.c
-hdiff_LDADD = ../libsrc/libmfhdf.a $(top_builddir)/hdf/src/libdf.a @LIBS@
+hdiff_LDADD = ../libsrc/libmfhdf.a $(top_builddir)/hdf/src/libdf.a -lm
hdiff_DEPENDENCIES = $(top_builddir)/hdf/src/libdf.a ../libsrc/libmfhdf.a
#############################################################################
--- HDF4.2r2/mfhdf/hrepack/Makefile.in.libm 2007-09-18 09:12:00.000000000 -0600
+++ HDF4.2r2/mfhdf/hrepack/Makefile.in 2008-02-05 14:58:41.000000000 -0700
@@ -232,7 +232,7 @@
../hdiff/hdiff_sds.c ../hdiff/hdiff_table.c \
../hdiff/hdiff_vs.c ../hdiff/hdiff_dim.c
-test_hrepack_LDADD = ../libsrc/libmfhdf.a $(top_builddir)/hdf/src/libdf.a
+test_hrepack_LDADD = ../libsrc/libmfhdf.a $(top_builddir)/hdf/src/libdf.a -lm
test_hrepack_DEPENDENCIES = $(top_builddir)/hdf/src/libdf.a ../libsrc/libmfhdf.a
hrepack_check_SOURCES = hrepack_check.c
hrepack_check_LDADD = ../libsrc/libmfhdf.a $(top_builddir)/hdf/src/libdf.a

View File

@ -0,0 +1,11 @@
--- HDF4.2r3/mfhdf/libsrc/file.c.maxavailfiles 2008-01-27 09:47:11.000000000 -0700
+++ HDF4.2r3/mfhdf/libsrc/file.c 2008-10-01 11:48:53.000000000 -0600
@@ -45,7 +45,7 @@
/* Maximum number of files can be opened at one time; subtract 3 from
the system allowed to account for stdin, stdout, and stderr */
-#define MAX_AVAIL_OPENFILES (MAX_SYS_OPENFILES - 3)
+#define MAX_AVAIL_OPENFILES (MAX_SYS_OPENFILES - 10)
static int _curr_opened = 0 ; /* the number of files currently opened */
/* NOTE: _ncdf might have been the number of files currently opened, yet it

11
hdf-4.2r4-buffer.patch Normal file
View File

@ -0,0 +1,11 @@
--- HDF4.2r4/mfhdf/libsrc/tncunlim.c.buffer 2009-01-10 19:34:26.000000000 -0700
+++ HDF4.2r4/mfhdf/libsrc/tncunlim.c 2009-02-25 11:08:46.000000000 -0700
@@ -646,7 +646,7 @@
long dimsize = 0, /* unlimited dimension size */
dimsize1 = 0, dimsize2 = 0; /* other dimension sizes */
short outdata[DIM0][DIM1][DIM2]; /* data read back */
- char varname[10]; /* variable name */
+ char varname[12]; /* variable name */
nc_type rh_type; /* variable type */
int rh_ndims; /* number of dims */
int rh_dims[H4_MAX_VAR_DIMS]; /* variable shape */

View File

@ -1,16 +1,17 @@
Name: hdf
Version: 4.2r3
Release: 4%{?dist}
Version: 4.2r4
Release: 5%{?dist}
Summary: A general purpose library and file format for storing scientific data
License: BSD
Group: System Environment/Libraries
URL: http://hdf.ncsa.uiuc.edu/hdf4.html
URL: http://hdfgroup.org/products/hdf4/index.html
Source0: ftp://ftp.hdfgroup.org/HDF/HDF_Current/src/HDF%{version}.tar.gz
Patch0: hdf-4.2r1p4-maxavailfiles.patch
Patch0: hdf-4.2r3-maxavailfiles.patch
Patch1: hdf-4.2r3-ppc.patch
Patch2: hdf-4.2r2-sparc.patch
Patch3: hdf-4.2r2-s390.patch
Patch4: hdf-4.2r2-libm.patch
# Reported upstream to help@hdfgroup.org
Patch4: hdf-4.2r4-buffer.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: flex byacc libjpeg-devel zlib-devel
%if "%{?dist}" != ".el4"
@ -19,6 +20,7 @@ BuildRequires: gcc-gfortran
BuildRequires: gcc-g77
%endif
%description
HDF is a general purpose library and file format for storing scientific data.
HDF can store two primary objects: datasets and groups. A dataset is
@ -32,6 +34,7 @@ grids. You can also mix and match them in HDF files according to your needs.
%package devel
Summary: HDF development files
Group: Development/Libraries
Provides: %{name}-static = %{version}-%{release}
Requires: %{name} = %{version}-%{release}
Requires: libjpeg-devel zlib-devel
@ -41,11 +44,11 @@ HDF development headers and libraries.
%prep
%setup -q -n HDF%{version}
%patch -p1 -b .maxavailfiles
%patch0 -p1 -b .maxavailfiles
%patch1 -p1 -b .ppc
%patch2 -p1 -b .sparc
%patch3 -p1 -b .s390
%patch4 -p1 -b .libm
%patch4 -p1 -b .buffer
chmod a-x *hdf/*/*.c hdf/*/*.h
# restore include file timestamps modified by patching
@ -57,13 +60,8 @@ touch -c -r ./mfhdf/libsrc/config/netcdf-linux.h.ppc ./mfhdf/libsrc/config/netcd
# avoid upstream compiler flags settings
rm config/*linux-gnu
export CFLAGS="$RPM_OPT_FLAGS -fPIC"
export FFLAGS="$RPM_OPT_FLAGS -ffixed-line-length-none"
export FFLAGS="$RPM_OPT_FLAGS -fPIC -ffixed-line-length-none"
%configure --disable-production --disable-netcdf \
%if "%{?dist}" != ".el4"
F77=gfortran \
%else
F77=g77 \
%endif
--includedir=%{_includedir}/%{name} --libdir=%{_libdir}/%{name}
make
@ -117,11 +115,31 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Wed May 28 2008 Balint Cristian <rezso@rdsor.ro> 4.2r3-4
- further fix a typo for RHEL5
* Fri Sep 18 2009 Orion Poplawski <orion@cora.nwra.com> 4.2r4-5
- Add EL4 build conditionals
* Wed May 28 2008 Balint Cristian <rezso@rdsor.ro> 4.2r3-3
- require gcc-g77 for fortran on RHEL4
* Thu Aug 13 2009 Orion Poplawski <orion@cora.nwra.com> 4.2r4-4
- Add -fPIC to FFLAGS
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2r4-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Tue Apr 7 2009 Orion Poplawski <orion@cora.nwra.com> 4.2r4-2
- Add Provides hdf-static to hdf-devel (bug #494529)
* Wed Feb 25 2009 Orion Poplawski <orion@cora.nwra.com> 4.2r4-1
- Update to 4.2r4
- Add patch to increase buffer size in test
- Drop upstreamed libm patch
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2r3-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
* Wed Oct 1 2008 Orion Poplawski <orion@cora.nwra.com> 4.2r3-4
- Rebase maxavailfiles patch
* Sun Sep 21 2008 Ville Skyttä <ville.skytta at iki.fi> - 4.2r3-3
- Fix Patch0:/%%patch mismatch.
* Sun Mar 2 2008 Patrice Dumas <pertusus@free.fr> 4.2r3-2
- don't ship an empty netcdf.h file. The related definitions are now

1
import.log Normal file
View File

@ -0,0 +1 @@
hdf-4_2r4-5_fc12:EL-4:hdf-4.2r4-5.fc12.src.rpm:1253294536

View File

@ -1 +1 @@
767382a31470e795f4c4217e33a689e8 HDF4.2r3.tar.gz
cbcfcdb65f27b743c6001c17619704a8 HDF4.2r4.tar.gz