Move libraries into %{_libdir}

This commit is contained in:
Orion Poplawski 2019-04-10 20:53:19 -06:00
parent 48393863d3
commit 26c3da695e
2 changed files with 29 additions and 12 deletions

View File

@ -1,6 +1,6 @@
diff -up hdf-4.2.14/java/examples/Makefile.am.build hdf-4.2.14/java/examples/Makefile.am
--- hdf-4.2.14/java/examples/Makefile.am.build 2018-06-26 22:42:58.000000000 -0600
+++ hdf-4.2.14/java/examples/Makefile.am 2019-04-09 20:51:31.031211605 -0600
+++ hdf-4.2.14/java/examples/Makefile.am 2019-04-10 20:01:42.336828053 -0600
@@ -12,8 +12,8 @@ classes:
test -d $(@D)/$(JAVAROOT) || $(MKDIR_P) $(@D)/$(JAVAROOT)
@ -12,9 +12,24 @@ diff -up hdf-4.2.14/java/examples/Makefile.am.build hdf-4.2.14/java/examples/Mak
CLASSPATH_ENV=CLASSPATH=.:$(JAVAROOT):$(top_builddir)/java/src/$(hdfjarfile):$(top_srcdir)/java/lib/slf4j-api-1.7.5.jar:$(top_srcdir)/java/lib/ext/slf4j-simple-1.7.5.jar:$$CLASSPATH
AM_JAVACFLAGS = $(H4_JAVACFLAGS) -deprecation
diff -up hdf-4.2.14/java/src/jni/Makefile.am.build hdf-4.2.14/java/src/jni/Makefile.am
--- hdf-4.2.14/java/src/jni/Makefile.am.build 2018-06-26 22:42:58.000000000 -0600
+++ hdf-4.2.14/java/src/jni/Makefile.am 2019-04-10 20:47:55.397873538 -0600
@@ -14,7 +14,10 @@ AM_CPPFLAGS=-I$(top_srcdir)/hdf/src
-I$(top_builddir)/mfhdf/libsrc -I$(top_srcdir)/java/src/jni $(JNIFLAGS)
# This is our main target
-lib_LTLIBRARIES=libhdf_java.la
+pkglib_LTLIBRARIES=libhdf_java.la
+
+# No soname for JNI library
+libhdf_java_la_LDFLAGS = -avoid-version
# Source files for the library
libhdf_java_la_SOURCES=hdfanImp.c hdfdfpalImp.c \
diff -up hdf-4.2.14/java/src/Makefile.am.build hdf-4.2.14/java/src/Makefile.am
--- hdf-4.2.14/java/src/Makefile.am.build 2018-06-26 22:42:58.000000000 -0600
+++ hdf-4.2.14/java/src/Makefile.am 2019-04-09 21:20:56.625579495 -0600
+++ hdf-4.2.14/java/src/Makefile.am 2019-04-10 20:01:42.336828053 -0600
@@ -13,8 +13,8 @@ JAVAROOT = .classes
classes:
test -d $(@D)/$(JAVAROOT) || $(MKDIR_P) $(@D)/$(JAVAROOT)
@ -28,7 +43,7 @@ diff -up hdf-4.2.14/java/src/Makefile.am.build hdf-4.2.14/java/src/Makefile.am
CLASSPATH_ENV=CLASSPATH=.:$(top_srcdir)/java/lib/slf4j-api-1.7.5.jar:$$CLASSPATH
diff -up hdf-4.2.14/java/test/junit.sh.in.build hdf-4.2.14/java/test/junit.sh.in
--- hdf-4.2.14/java/test/junit.sh.in.build 2018-06-26 22:42:58.000000000 -0600
+++ hdf-4.2.14/java/test/junit.sh.in 2019-04-09 20:51:31.032211610 -0600
+++ hdf-4.2.14/java/test/junit.sh.in 2019-04-10 20:01:42.337828056 -0600
@@ -40,7 +40,7 @@ HDFLIB_HOME="$top_srcdir/java/lib"
BLDLIBDIR="$top_builddir/java/lib"
BLDDIR="."
@ -40,7 +55,7 @@ diff -up hdf-4.2.14/java/test/junit.sh.in.build hdf-4.2.14/java/test/junit.sh.in
diff -up hdf-4.2.14/java/test/Makefile.am.build hdf-4.2.14/java/test/Makefile.am
--- hdf-4.2.14/java/test/Makefile.am.build 2018-06-26 22:42:58.000000000 -0600
+++ hdf-4.2.14/java/test/Makefile.am 2019-04-09 20:51:31.033211614 -0600
+++ hdf-4.2.14/java/test/Makefile.am 2019-04-10 20:01:42.337828056 -0600
@@ -12,7 +12,7 @@ classes:
test -d $(@D)/$(JAVAROOT) || $(MKDIR_P) $(@D)/$(JAVAROOT)

View File

@ -4,7 +4,7 @@
Name: hdf
Version: 4.2.14
Release: 3%{?dist}
Release: 4%{?dist}
Summary: A general purpose library and file format for storing scientific data
License: BSD
URL: https://portal.hdfgroup.org/
@ -139,7 +139,7 @@ cd build-shared
# Java requires shared libraries, fortran requires static
%configure --disable-production --enable-java --disable-netcdf \
--enable-shared=yes --enable-static=no --disable-fortran %{!?el6:--with-szlib} \
--includedir=%{_includedir}/%{name} --libdir=%{_libdir}/%{name}
--includedir=%{_includedir}/%{name}
%make_build
cd -
mkdir build-static
@ -147,7 +147,7 @@ cd build-static
# Java requires shared libraries, fortran requires static
%configure --disable-production --disable-java --disable-netcdf \
--enable-shared=no --enable-static=yes --enable-fortran %{!?el6:--with-szlib} \
--includedir=%{_includedir}/%{name} --libdir=%{_libdir}/%{name}
--includedir=%{_includedir}/%{name}
%make_build
cd -
@ -197,18 +197,17 @@ make -j1 -C build-static check
%{_pkgdocdir}/
%exclude %{_pkgdocdir}/examples
%{_bindir}/*
%dir %{_libdir}/%{name}
%{_libdir}/%{name}/*.so.0*
%{_libdir}/*.so.0*
%{_mandir}/man1/*.gz
%files devel
%{_includedir}/%{name}/
%{_libdir}/%{name}/*.so
%{_libdir}/%{name}/*.settings
%{_libdir}/*.so
%{_libdir}/*.settings
%{_pkgdocdir}/examples/
%files static
%{_libdir}/%{name}/*.a
%{_libdir}/*.a
%files -n java-hdf
%{_jnidir}/hdf.jar
@ -216,6 +215,9 @@ make -j1 -C build-static check
%changelog
* Wed Apr 10 2019 Orion Poplawski <orion@nwra.com> - 4.2.14-4
- Move libraries into %%{_libdir}
* Tue Apr 9 2019 Orion Poplawski <orion@nwra.com> - 4.2.14-3
- Build shared libraries
- Enable java