Fixed s390x build, enabled test on ppc
This commit is contained in:
parent
18b70bd0d4
commit
18459c8167
@ -334,3 +334,15 @@ diff -up hdf-4.2.10/mfhdf/ncgen/ncgen.l.s390 hdf-4.2.10/mfhdf/ncgen/ncgen.l
|
||||
if (dd < INT_MIN || dd > INT_MAX)
|
||||
#else
|
||||
if (dd < LONG_MIN || dd > LONG_MAX)
|
||||
diff -up hdf-4.2.10/mfhdf/ncgen/ncgenyy.c.s390 hdf-4.2.10/mfhdf/ncgen/ncgenyy.c
|
||||
--- hdf-4.2.10/mfhdf/ncgen/ncgenyy.c.s390 2014-05-22 08:33:21.700132543 -0400
|
||||
+++ hdf-4.2.10/mfhdf/ncgen/ncgenyy.c 2014-05-22 08:33:50.990132543 -0400
|
||||
@@ -989,7 +989,7 @@ YY_RULE_SETUP
|
||||
yyerror(errstr);
|
||||
}
|
||||
|
||||
-#if defined __alpha || (_MIPS_SZLONG == 64) || defined __ia64 || (defined __sun && defined _LP64) || defined AIX5L64 || defined __x86_64__ || __powerpc64__
|
||||
+#if defined __alpha || (_MIPS_SZLONG == 64) || defined __ia64 || (defined __sun && defined _LP64) || defined AIX5L64 || defined __x86_64__ || __powerpc64__ || __s390x__
|
||||
if (dd < INT_MIN || dd > INT_MAX)
|
||||
#else
|
||||
if (dd < LONG_MIN || dd > LONG_MAX)
|
||||
|
9
hdf.spec
9
hdf.spec
@ -1,6 +1,6 @@
|
||||
Name: hdf
|
||||
Version: 4.2.10
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: A general purpose library and file format for storing scientific data
|
||||
License: BSD
|
||||
Group: System Environment/Libraries
|
||||
@ -108,10 +108,7 @@ popd
|
||||
|
||||
|
||||
%check
|
||||
# bugzilla #961007
|
||||
%ifnarch ppc %{power64}
|
||||
make check
|
||||
%endif
|
||||
|
||||
|
||||
%clean
|
||||
@ -133,6 +130,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu May 22 2014 Jakub Čajka <jcajka@redhat.com> 4.2.10-2
|
||||
- Fixed build/tests on s390x
|
||||
- Tests enabled on ppc
|
||||
|
||||
* Fri Feb 14 2014 Orion Poplawski <orion@cora.nwra.com> 4.2.10-1
|
||||
- Update to 4.2.10
|
||||
- Rebase arm, ppc, and s390 patches
|
||||
|
Loading…
Reference in New Issue
Block a user