new upstream release
This commit is contained in:
parent
afd2b3fccb
commit
2c02d855e0
@ -1,12 +0,0 @@
|
|||||||
diff -up ./configure.old ./configure
|
|
||||||
--- ./configure.old 2010-05-31 17:50:18.000000000 -0400
|
|
||||||
+++ ./configure 2010-07-31 00:42:13.430307466 -0400
|
|
||||||
@@ -19232,7 +19232,7 @@ if test "${am_cv_pathless_PYTHON+set}" =
|
|
||||||
$as_echo_n "(cached) " >&6
|
|
||||||
else
|
|
||||||
|
|
||||||
- for am_cv_pathless_PYTHON in python python2 python3 python3.0 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 none; do
|
|
||||||
+ for am_cv_pathless_PYTHON in python python2 python3 python3.0 python2.7 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 none; do
|
|
||||||
test "$am_cv_pathless_PYTHON" = none && break
|
|
||||||
prog="import sys
|
|
||||||
# split strings by '.' and convert to numeric. Append some zeros
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -Naur hamlib-1.2.13.1-mod/kit/usrp_impl.cc hamlib-1.2.13.1/kit/usrp_impl.cc
|
|
||||||
--- hamlib-1.2.13.1-mod/kit/usrp_impl.cc 2011-03-13 16:50:12.000000000 +0200
|
|
||||||
+++ hamlib-1.2.13.1/kit/usrp_impl.cc 2011-07-04 16:31:18.000000000 +0300
|
|
||||||
@@ -32,7 +32,7 @@
|
|
||||||
#include <stdlib.h>
|
|
||||||
#include <stdio.h>
|
|
||||||
#include <errno.h>
|
|
||||||
-#include <usrp_standard.h>
|
|
||||||
+#include <usrp/usrp_standard.h>
|
|
||||||
|
|
||||||
#include "usrp_impl.h"
|
|
||||||
#include "token.h"
|
|
49
hamlib-1.2.15-cpp.patch
Normal file
49
hamlib-1.2.15-cpp.patch
Normal file
@ -0,0 +1,49 @@
|
|||||||
|
diff -Naur hamlib-1.2.15/rpcrig/Makefile.am hamlib-1.2.15-mod/rpcrig/Makefile.am
|
||||||
|
--- hamlib-1.2.15/rpcrig/Makefile.am 2011-08-23 05:06:25.000000000 +0200
|
||||||
|
+++ hamlib-1.2.15-mod/rpcrig/Makefile.am 2012-02-06 10:21:06.922381977 +0100
|
||||||
|
@@ -30,7 +30,7 @@
|
||||||
|
|
||||||
|
EXTRA_DIST = rpcrig.x $(man_MANS)
|
||||||
|
|
||||||
|
-RPCGEN = rpcgen
|
||||||
|
+RPCGEN = rpcgen -Y $(bindir)
|
||||||
|
|
||||||
|
rpcrig.h: Makefile rpcrig.x
|
||||||
|
rm -f $@
|
||||||
|
diff -Naur hamlib-1.2.15/rpcrig/Makefile.in hamlib-1.2.15-mod/rpcrig/Makefile.in
|
||||||
|
--- hamlib-1.2.15/rpcrig/Makefile.in 2012-02-03 03:47:03.000000000 +0100
|
||||||
|
+++ hamlib-1.2.15-mod/rpcrig/Makefile.in 2012-02-06 10:57:36.241524111 +0100
|
||||||
|
@@ -353,7 +353,8 @@
|
||||||
|
rpc_rigd_LDFLAGS = @BACKENDLNK@
|
||||||
|
man_MANS = rpc.rigd.8
|
||||||
|
EXTRA_DIST = rpcrig.x $(man_MANS)
|
||||||
|
-RPCGEN = rpcgen
|
||||||
|
+RPCGEN = rpcgen -Y $(bindir)
|
||||||
|
+
|
||||||
|
all: $(BUILT_SOURCES)
|
||||||
|
$(MAKE) $(AM_MAKEFLAGS) all-am
|
||||||
|
|
||||||
|
diff -Naur hamlib-1.2.15/rpcrot/Makefile.am hamlib-1.2.15-mod/rpcrot/Makefile.am
|
||||||
|
--- hamlib-1.2.15/rpcrot/Makefile.am 2011-08-23 05:06:25.000000000 +0200
|
||||||
|
+++ hamlib-1.2.15-mod/rpcrot/Makefile.am 2012-02-06 12:04:23.821784290 +0100
|
||||||
|
@@ -31,7 +31,7 @@
|
||||||
|
|
||||||
|
EXTRA_DIST = rpcrot.x $(man_MANS)
|
||||||
|
|
||||||
|
-RPCGEN = rpcgen
|
||||||
|
+RPCGEN = rpcgen -Y $(bindir)
|
||||||
|
|
||||||
|
rpcrot.h: Makefile rpcrot.x
|
||||||
|
rm -f $@
|
||||||
|
diff -Naur hamlib-1.2.15/rpcrot/Makefile.in hamlib-1.2.15-mod/rpcrot/Makefile.in
|
||||||
|
--- hamlib-1.2.15/rpcrot/Makefile.in 2012-02-03 03:47:03.000000000 +0100
|
||||||
|
+++ hamlib-1.2.15-mod/rpcrot/Makefile.in 2012-02-06 12:04:14.690783695 +0100
|
||||||
|
@@ -353,7 +353,7 @@
|
||||||
|
rpc_rotd_LDFLAGS = @ROT_BACKENDLNK@
|
||||||
|
man_MANS = rpc.rotd.8
|
||||||
|
EXTRA_DIST = rpcrot.x $(man_MANS)
|
||||||
|
-RPCGEN = rpcgen
|
||||||
|
+RPCGEN = rpcgen -Y $(bindir)
|
||||||
|
all: $(BUILT_SOURCES)
|
||||||
|
$(MAKE) $(AM_MAKEFLAGS) all-am
|
||||||
|
|
19
hamlib.spec
19
hamlib.spec
@ -1,8 +1,8 @@
|
|||||||
%{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
%{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
||||||
|
|
||||||
Name: hamlib
|
Name: hamlib
|
||||||
Version: 1.2.14
|
Version: 1.2.15
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Run-time library to control radio transceivers and receivers
|
Summary: Run-time library to control radio transceivers and receivers
|
||||||
|
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -11,9 +11,8 @@ URL: http://hamlib.sourceforge.net
|
|||||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||||
#Install python and perl bindings into proper dirs
|
#Install python and perl bindings into proper dirs
|
||||||
Patch0: hamlib-1.2.13-bindings.patch
|
Patch0: hamlib-1.2.13-bindings.patch
|
||||||
Patch1: hamlib-1.2.13.1-usrp-includes.patch
|
#temporary patch to fix usrmove mess
|
||||||
# Build against Python 2.7
|
Patch1: hamlib-1.2.15-cpp.patch
|
||||||
Patch2: hamlib-1.2.11-python2.7.configure.patch
|
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
@ -99,9 +98,7 @@ Hamlib TCL Language bindings to allow radio control from TCL scripts.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .bindings
|
%patch0 -p1 -b .bindings
|
||||||
%patch1 -p1 -b .includes
|
%patch1 -p1 -b .cpp
|
||||||
# Build against Python 2.7
|
|
||||||
%patch2 -p1 -b .python-version
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
@ -220,6 +217,12 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/hamlibtcl*
|
%{_libdir}/hamlibtcl*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Feb 05 2012 Lucian Langa <cooly@gnome.eu.org> - 1.2.15-1
|
||||||
|
- add temporary patch to fix usrmove issues
|
||||||
|
- drop patch 1 - no longer building with usrp
|
||||||
|
- drop patch 2 - fixed upstream
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.14-5
|
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.14-5
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user