Update to 0.25.1
This commit is contained in:
parent
d08db010f8
commit
bc420bfb37
29
guitarix-0.25.1-lv2dir.patch
Normal file
29
guitarix-0.25.1-lv2dir.patch
Normal file
@ -0,0 +1,29 @@
|
||||
diff --git a/trunk/wscript b/trunk/wscript
|
||||
index a20a54a..8a016f3 100644
|
||||
--- a/trunk/wscript
|
||||
+++ b/trunk/wscript
|
||||
@@ -160,6 +160,12 @@ def set_options(opt):
|
||||
type='string',
|
||||
help='LADSPA plugin directory [Default: <prefix>/lib/ladspa]')
|
||||
|
||||
+ lv2 = opt.add_option_group("LV2 Options")
|
||||
+
|
||||
+ lv2.add_option('--lv2dir',
|
||||
+ type='string',
|
||||
+ help='LV2 plugin directory [Default: <prefix>/lib/lv2]')
|
||||
+
|
||||
opt.recurse('pygxw')
|
||||
opt.recurse('glade-gxw')
|
||||
|
||||
@@ -570,7 +576,10 @@ def configure(conf):
|
||||
|
||||
conf.env['LV2'] = opt.build_lv2
|
||||
if opt.build_lv2:
|
||||
- conf.define('LV2DIR', os.path.normpath(os.path.join(conf.env['LIBDIR'], 'lv2')) )
|
||||
+ if opt.lv2dir:
|
||||
+ conf.define('LV2DIR',opt.lv2dir)
|
||||
+ else:
|
||||
+ conf.define('LV2DIR', os.path.normpath(os.path.join(conf.env['LIBDIR'], 'lv2')) )
|
||||
|
||||
|
||||
conf.env['NEW_LADSPA'] = not opt.no_ladspa and not opt.no_new_ladspa
|
74
guitarix-0.25.1-pkgconfig.patch
Normal file
74
guitarix-0.25.1-pkgconfig.patch
Normal file
@ -0,0 +1,74 @@
|
||||
diff --git a/trunk/libgxw/gxw.pc.in b/trunk/libgxw/gxw.pc.in
|
||||
index 9c72568..510a411 100644
|
||||
--- a/trunk/libgxw/gxw.pc.in
|
||||
+++ b/trunk/libgxw/gxw.pc.in
|
||||
@@ -1,6 +1,6 @@
|
||||
prefix=/path
|
||||
exec_prefix=${prefix}
|
||||
-libdir=${exec_prefix}/lib
|
||||
+libdir=/path
|
||||
datarootdir=${prefix}/share
|
||||
datadir=${datarootdir}
|
||||
includedir=${prefix}/include
|
||||
diff --git a/trunk/libgxwmm/gxwmm.pc.in b/trunk/libgxwmm/gxwmm.pc.in
|
||||
index ffd1974..e26975d 100644
|
||||
--- a/trunk/libgxwmm/gxwmm.pc.in
|
||||
+++ b/trunk/libgxwmm/gxwmm.pc.in
|
||||
@@ -1,6 +1,6 @@
|
||||
prefix=/path
|
||||
exec_prefix=${prefix}
|
||||
-libdir=${exec_prefix}/lib
|
||||
+libdir=/path
|
||||
datarootdir=${prefix}/share
|
||||
datadir=${datarootdir}
|
||||
includedir=${prefix}/include
|
||||
diff --git a/trunk/wafadmin/Tools/libtool.py b/trunk/wafadmin/Tools/libtool.py
|
||||
index 50b28ce..b4074e6 100644
|
||||
--- a/trunk/wafadmin/Tools/libtool.py
|
||||
+++ b/trunk/wafadmin/Tools/libtool.py
|
||||
@@ -51,7 +51,7 @@ def apply_link_libtool(self):
|
||||
linktask=self.link_task
|
||||
self.latask=self.create_task('fakelibtool',linktask.outputs,linktask.outputs[0].change_ext('.la'))
|
||||
if self.bld.is_install:
|
||||
- self.bld.install_files('${PREFIX}/lib',linktask.outputs[0],self.env)
|
||||
+ self.bld.install_files('${LIBDIR}',linktask.outputs[0],self.env)
|
||||
def apply_libtool(self):
|
||||
self.env['vnum']=self.vnum
|
||||
paths=[]
|
||||
@@ -101,7 +101,7 @@ class libtool_la_file:
|
||||
self.shouldnotlink=None
|
||||
self.dlopen=None
|
||||
self.dlpreopen=None
|
||||
- self.libdir='/usr/lib'
|
||||
+ self.libdir='${LIBDIR}'
|
||||
if not self.__parse():
|
||||
raise ValueError("file %s not found!!"%(la_filename))
|
||||
def __parse(self):
|
||||
diff --git a/trunk/wscript b/trunk/wscript
|
||||
index 32950ad..c058f93 100644
|
||||
--- a/trunk/wscript
|
||||
+++ b/trunk/wscript
|
||||
@@ -644,7 +644,8 @@ def configure(conf):
|
||||
pa = conf.env['PREFIX']
|
||||
sub_file('./libgxw/gxw.pc.in', './libgxw/gxw.pc', (('prefix=/path', 'prefix=%s' % pa), ))
|
||||
sub_file('./libgxwmm/gxwmm.pc.in', './libgxwmm/gxwmm.pc', (('prefix=/path', 'prefix=%s' % pa), ))
|
||||
-
|
||||
+ sub_file('./libgxw/gxw.pc.in', './libgxw/gxw.pc', (('libdir=/path','libdir=%s' % conf.env['LIBDIR']), ))
|
||||
+ sub_file('./libgxwmm/gxwmm.pc.in', './libgxwmm/gxwmm.pc', (('libdir=/path','libdir=%s' % conf.env['LIBDIR']), ))
|
||||
|
||||
# some output
|
||||
print("")
|
||||
@@ -773,11 +774,11 @@ def build(bld):
|
||||
if bld.env["GX_LIB_DEV"]:
|
||||
bld.install_files('${PREFIX}/include/gxw','libgxw/gxw/*.h')
|
||||
bld.install_files('${PREFIX}/include','libgxw/gxw.h')
|
||||
- bld.install_files('${PREFIX}/lib/pkgconfig', './libgxw/gxw.pc')
|
||||
+ bld.install_files('${LIBDIR}/pkgconfig', './libgxw/gxw.pc')
|
||||
bld.install_files('${PREFIX}/include/gxwmm','libgxwmm/gxwmm-generated/*.h')
|
||||
bld.install_files('${PREFIX}/include/gxwmm','libgxwmm/gxwmm/*.h')
|
||||
bld.install_files('${PREFIX}/include','libgxwmm/gxwmm.h')
|
||||
- bld.install_files('${PREFIX}/lib/pkgconfig', './libgxwmm/gxwmm.pc')
|
||||
+ bld.install_files('${LIBDIR}/pkgconfig', './libgxwmm/gxwmm.pc')
|
||||
|
||||
################################################################
|
||||
# other commands
|
43
guitarix-0.25.1-shared-lib.patch
Normal file
43
guitarix-0.25.1-shared-lib.patch
Normal file
@ -0,0 +1,43 @@
|
||||
From b642b50320b6f6b42bcf0c9260058d3a905621dd Mon Sep 17 00:00:00 2001
|
||||
From: Brendan Jones <brendan.jones.it@gmail.com>
|
||||
Date: Sat, 5 Jan 2013 09:11:46 +0100
|
||||
Subject: [PATCH 2/2] Add shared library dir patch
|
||||
|
||||
---
|
||||
trunk/wscript | 12 +++++++++++-
|
||||
1 file changed, 11 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/trunk/wscript b/trunk/wscript
|
||||
index a0d4a57..9c0d8fb 100644
|
||||
--- a/trunk/wscript
|
||||
+++ b/trunk/wscript
|
||||
@@ -79,6 +79,12 @@ def set_options(opt):
|
||||
dest='cxxflags',
|
||||
help='C++ base compiler flags [Default: %default]')
|
||||
|
||||
+ comp.add_option('--libdir',
|
||||
+ type='string',
|
||||
+ default='',
|
||||
+ dest='libdir',
|
||||
+ help='Shared library directory')
|
||||
+
|
||||
comp.add_option('--ldflags',
|
||||
type='string',
|
||||
default='',
|
||||
@@ -562,8 +568,12 @@ def configure(conf):
|
||||
conf.define('OS_32_BIT', 1)
|
||||
# writing config.h
|
||||
conf.write_config_header('config.h')
|
||||
+
|
||||
+ if not opt.libdir:
|
||||
+ conf.define('LIBDIR', os.path.normpath(os.path.join(conf.env['PREFIX'], 'lib')))
|
||||
+ else:
|
||||
+ conf.define('LIBDIR', opt.libdir)
|
||||
|
||||
- conf.define('LIBDIR', os.path.normpath(os.path.join(conf.env['PREFIX'], 'lib')))
|
||||
conf.define('BINDIR', os.path.normpath(os.path.join(conf.env['PREFIX'], 'bin')))
|
||||
conf.define('DESKAPPS_DIR', os.path.normpath(os.path.join(conf.env['SHAREDIR'], 'applications')))
|
||||
conf.define('BIN_NAME', APPNAME)
|
||||
--
|
||||
1.8.0.2
|
||||
|
124
guitarix.spec
124
guitarix.spec
@ -4,13 +4,16 @@
|
||||
%global altname2 guitarix2
|
||||
|
||||
Name: guitarix
|
||||
Version: 0.24.2
|
||||
Version: 0.25.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Mono amplifier to JACK
|
||||
Group: Applications/Multimedia
|
||||
License: GPLv2+
|
||||
URL: http://guitarix.sourceforge.net/
|
||||
Source0: http://sourceforge.net/projects/%{name}/files/%{name}/%{altname2}-%{version}.tar.bz2
|
||||
Patch0: guitarix-0.25.1-lv2dir.patch
|
||||
Patch1: guitarix-0.25.1-shared-lib.patch
|
||||
Patch2: guitarix-0.25.1-pkgconfig.patch
|
||||
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: faust
|
||||
@ -53,6 +56,53 @@ program, the velocity and the sensitivity, which translates into how fast the
|
||||
note will read after the beat detector emits a signal. Values for the beat
|
||||
detector can be set for all channels.
|
||||
|
||||
%package -n libgxw
|
||||
Summary: Guitarix GTK library
|
||||
Group: Applications/Multimedia
|
||||
License: GPLv2+
|
||||
|
||||
%description -n libgxw
|
||||
This package contains the Guitarix GTK widget library
|
||||
|
||||
%package -n libgxwmm
|
||||
Summary: Guitarix GTK C++ library
|
||||
Group: Applications/Multimedia
|
||||
License: GPLv2+
|
||||
|
||||
%description -n libgxwmm
|
||||
This package contains the Guitarix GTK C++ widget library
|
||||
|
||||
%package -n libgxw-devel
|
||||
Summary: Development files for libgxw
|
||||
Group: Applications/Multimedia
|
||||
License: GPLv2+
|
||||
Requires: libgxw%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description -n libgxw-devel
|
||||
This package contains files required to use the libgxw Guitarix
|
||||
widget library
|
||||
|
||||
%package -n libgxwmm-devel
|
||||
Summary: Development files for libgxwmm
|
||||
Group: Applications/Multimedia
|
||||
License: GPLv2+
|
||||
Requires: libgxwmm%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description -n libgxwmm-devel
|
||||
This package contains files required to use the libgxwmm Guitarix widget
|
||||
library
|
||||
|
||||
%package -n gxw-glade
|
||||
Summary: Guitarix GTK library glade support
|
||||
Group: Applications/Multimedia
|
||||
License: GPLv2+
|
||||
Requires: glade
|
||||
Requires: libgxw-devel%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description -n gxw-glade
|
||||
This package contains support for using the Guitarix GTK widget library
|
||||
with glade
|
||||
|
||||
%package -n ladspa-%{name}-plugins
|
||||
Summary: Collection of Ladspa plug-ins
|
||||
Group: Applications/Multimedia
|
||||
@ -66,9 +116,24 @@ This package contains the crybaby, distortion, echo, impulseresponse, monoamp,
|
||||
and monocompressor ladspa plug-ins that come together with guitarix, but can
|
||||
also be used by any other ladspa host.
|
||||
|
||||
%package -n lv2-%{name}-plugins
|
||||
Summary: Collection of LV2 guitarix plug-ins
|
||||
Group: Applications/Multimedia
|
||||
# ladspa/distortion.cpp and ladspa/guitarix-ladspa.cpp are BSD
|
||||
# The rest of ladspa/* is GPLv+
|
||||
License: GPLv2+
|
||||
Requires: lv2
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description -n lv2-%{name}-plugins
|
||||
This package contains the guitarix amp plug-ins that come together with
|
||||
guitarix, but can also be used by any other ladspa host.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
#%patch0 -p1
|
||||
%patch0 -p2
|
||||
%patch1 -p2
|
||||
%patch2 -p2
|
||||
|
||||
# The build system does not use these bundled libraries by default. But
|
||||
# just to make sure:
|
||||
@ -76,19 +141,21 @@ rm -fr src/zita-convolver src/zita-resampler
|
||||
sed -i -e 's|-O3|%{optflags}|' wscript
|
||||
|
||||
%build
|
||||
./waf -vv configure --prefix=%{_prefix} \
|
||||
./waf -vv configure --prefix=%{_prefix} --libdir=%{_libdir} \
|
||||
--cxxflags="-std=c++0x -fomit-frame-pointer -ftree-loop-linear \
|
||||
-ffinite-math-only -fno-math-errno -fno-signed-zeros -fstrength-reduce \
|
||||
%ifarch %ix86 x86_64
|
||||
-msse \
|
||||
%endif
|
||||
%{optflags}" \
|
||||
--ladspadir=%{_libdir}/ladspa
|
||||
--shared-lib --lib-dev \
|
||||
--ladspadir=%{_libdir}/ladspa --build-lv2 --lv2dir=%{_libdir}/lv2 \
|
||||
--glade-support --glade-catalog-dir=%{_datadir}/glade/catalogs \
|
||||
--glade-modules-dir=%{_libdir}/glade/modules
|
||||
./waf -vv build %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
./waf -vv install --destdir="%{buildroot}"
|
||||
./waf -vv install --destdir="%{buildroot}" --libdir="%{_libdir}"
|
||||
|
||||
desktop-file-install \
|
||||
--add-category="X-DigitalProcessing" \
|
||||
@ -97,9 +164,23 @@ desktop-file-install \
|
||||
|
||||
chmod 644 %{buildroot}/%{_datadir}/%{altname}/sounds/*
|
||||
chmod 644 %{buildroot}/%{_datadir}/%{altname}/skins/*
|
||||
chmod 755 %{buildroot}%{_libdir}/libgxw*.so.0.1
|
||||
rm -rf %{buildroot}%{_libdir}/libgxw*.so
|
||||
ln -s %{_libdir}/libgxwmm.so.0.1 %{buildroot}%{_libdir}/libgxwmm.so
|
||||
ln -s %{_libdir}/libgxw.so.0.1 %{buildroot}%{_libdir}/libgxw.so
|
||||
chmod 755 %{buildroot}%{_libdir}/glade/modules/libgladegx.so
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
%post -n libgxw -p /sbin/ldconfig
|
||||
|
||||
%postun -n libgxw -p /sbin/ldconfig
|
||||
|
||||
%post -n libgxwmm -p /sbin/ldconfig
|
||||
|
||||
%postun -n libgxwmm -p /sbin/ldconfig
|
||||
|
||||
|
||||
%files -f %{name}.lang
|
||||
%doc changelog COPYING README
|
||||
%{_bindir}/%{name}
|
||||
@ -108,11 +189,42 @@ chmod 644 %{buildroot}/%{_datadir}/%{altname}/skins/*
|
||||
%{_datadir}/pixmaps/*
|
||||
%{_datadir}/applications/%{name}.desktop
|
||||
|
||||
%files -n libgxw
|
||||
%{_libdir}/libgxw.so.*
|
||||
|
||||
%files -n libgxwmm
|
||||
%{_libdir}/libgxwmm.so.*
|
||||
|
||||
%files -n libgxw-devel
|
||||
%{_libdir}/libgxw.so
|
||||
%{_includedir}/gxw
|
||||
%{_includedir}/gxw.h
|
||||
%{_libdir}/pkgconfig/gxw.pc
|
||||
|
||||
%files -n libgxwmm-devel
|
||||
%{_libdir}/libgxwmm.so
|
||||
%{_includedir}/gxwmm
|
||||
%{_includedir}/gxwmm.h
|
||||
%{_libdir}/pkgconfig/gxwmm.pc
|
||||
|
||||
%files -n gxw-glade
|
||||
%{_libdir}/glade/modules/libgladegx.so
|
||||
%{_datadir}/%{name}/icons
|
||||
%{_datadir}/glade/catalogs/*
|
||||
|
||||
%files -n ladspa-%{name}-plugins
|
||||
%{_libdir}/ladspa/*.so
|
||||
%{_datadir}/ladspa
|
||||
|
||||
%files -n lv2-%{name}-plugins
|
||||
%{_libdir}/lv2/*
|
||||
|
||||
%changelog
|
||||
* Sat Jan 05 2013 Brendan Jones <brendan.jones.it@gmail.com> 0.25.1-1
|
||||
- Update to 0.25.1
|
||||
- Add LV2 sub-package
|
||||
- Add libs
|
||||
|
||||
* Wed Oct 24 2012 Brendan Jones <brendan.jones.it@gmail.com> 0.24.2-1
|
||||
- New upstream release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user