Merge remote-tracking branch 'up/main' into main-riscv64

Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
David Abdurachmanov 2023-12-05 10:09:34 +02:00
commit 6a1aa521c2
Signed by: davidlt
GPG Key ID: 8B7F1DA0E2C9FDBB
3 changed files with 68 additions and 2 deletions

View File

@ -0,0 +1,24 @@
Avoid an implicit declaration of exit. Partial backport of this
upstream commit:
commit a91b95cca2d397c84f8b9bbd602d40209a7092ce
Author: Andy Wingo <wingo@pobox.com>
Date: Wed Jan 20 21:52:54 2021 +0100
Update Gnulib to v0.1-4379-g2ef5a9b4b
Also bump required autoconf version to 2.64, as required by Gnulib.
diff --git a/m4/round.m4 b/m4/round.m4
index 45b7df4591e83648..1561225a5355366d 100644
--- a/m4/round.m4
+++ b/m4/round.m4
@@ -57,7 +57,7 @@ int main()
* (double) (1U << ((DBL_MANT_DIG + 3) / 5))
* (double) (1U << ((DBL_MANT_DIG + 4) / 5));
volatile double x = 0.5 - 0.5 / TWO_MANT_DIG;
- exit (x < 0.5 && round (x) != 0.0);
+ return x < 0.5 && round (x) != 0.0;
}]])], [gl_cv_func_round_works=yes], [gl_cv_func_round_works=no],
[case "$host_os" in
netbsd* | aix*) gl_cv_func_round_works="guessing no";;

View File

@ -0,0 +1,31 @@
Avoid implicit ints in the guile_cv_localtime_cache check. It cause
the check to always fail with strict(er) C99 compilers that do not
support implicit int.
Submitted upstream:
<https://lists.gnu.org/archive/html/bug-guile/2022-12/msg00017.html>
<https://debbugs.gnu.org/cgi/bugreport.cgi?bug=60022>
diff --git a/configure.ac b/configure.ac
index 92966ce3432b11f4..ec542c1f58bd835e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1167,7 +1167,7 @@ AC_RUN_IFELSE([AC_LANG_SOURCE([[#include <time.h>
# include <stdlib.h>
#endif
extern char **environ;
-unset_TZ ()
+int unset_TZ ()
{
char **from, **to;
for (to = from = environ; (*to = *from); from++)
@@ -1176,7 +1176,7 @@ unset_TZ ()
}
char TZ_GMT0[] = "TZ=GMT0";
char TZ_PST8[] = "TZ=PST8";
-main()
+int main()
{
time_t now = time ((time_t *) 0);
int hour_GMT0, hour_unset;

View File

@ -6,7 +6,7 @@
Name: guile22
Version: 2.2.7
Release: 6.0.riscv64%{?dist}
Release: 9.0.riscv64%{?dist}
Summary: A GNU implementation of Scheme for application extensibility
Source: ftp://ftp.gnu.org/pub/gnu/guile/guile-%{version}.tar.xz
URL: http://www.gnu.org/software/guile/
@ -23,6 +23,8 @@ Patch1: guile-multilib.patch
Patch3: guile-threadstest.patch
Patch4: disable-out-of-memory-test.patch
Patch5: guile-configure.patch
Patch6: guile22-configure-tz-c99.patch
Patch7: guile22-configure-c99.patch
%description
GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
@ -157,9 +159,18 @@ fi
%changelog
* Thu Sep 22 2022 David Abdurachmanov <davidlt@rivosinc.com> - 2.2.7-6.0.riscv64
* Tue Dec 05 2023 David Abdurachmanov <davidlt@rivosinc.com> - 2.2.7-9.0.riscv64
- Switch to --disable-rpath
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.7-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Fri Mar 17 2023 Florian Weimer <fweimer@redhat.com> - 2.2.7-8
- Port configure script to C99
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.7-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.7-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild