guile/guile-1.8.7-testsuite2.patch

59 lines
2.1 KiB
Diff

commit a0aa1e5b69d6ef0311aeea8e4b9a94eae18a1aaf
Author: Ludovic Courtès <ludo@gnu.org>
Date: Mon Dec 14 10:59:25 2009 +0100
Fix test environment issue with ltdl from Libtool 2.2.6b.
Earlier versions of ltdl would look for extensions under $PWD; this
behavior changed in 2.2.6b.
* test-suite/standalone/Makefile.am (TESTS_ENVIRONMENT): Define
$builddir.
* test-suite/standalone/test-asmobs: Specify the full path to
`libtest-asmobs', using $builddir.
diff --git a/test-suite/standalone/Makefile.am b/test-suite/standalone/Makefile.am
index e7cfd82..058ce93 100644
--- a/test-suite/standalone/Makefile.am
+++ b/test-suite/standalone/Makefile.am
@@ -28,7 +28,9 @@ check_SCRIPTS =
BUILT_SOURCES =
EXTRA_DIST =
-TESTS_ENVIRONMENT = "${top_builddir}/pre-inst-guile-env"
+TESTS_ENVIRONMENT = \
+ builddir="$(builddir)" \
+ "${top_builddir}/pre-inst-guile-env"
test_cflags = \
-I$(top_srcdir)/test-suite/standalone \
diff --git a/test-suite/standalone/test-asmobs b/test-suite/standalone/test-asmobs
index 2ea75d9..9689ab9 100755
--- a/test-suite/standalone/test-asmobs
+++ b/test-suite/standalone/test-asmobs
@@ -2,7 +2,8 @@
exec guile -q -s "$0" "$@"
!#
-(load-extension "libtest-asmobs" "libtest_asmobs_init")
+(load-extension (string-append (getenv "builddir") "/libtest-asmobs")
+ "libtest_asmobs_init")
(define (test x v)
(if v
diff -up guile-1.8.7/test-suite/standalone/Makefile.in.ltdl guile-1.8.7/test-suite/standalone/Makefile.in
--- guile-1.8.7/test-suite/standalone/Makefile.in.ltdl 2010-01-15 14:40:52.000000000 +0100
+++ guile-1.8.7/test-suite/standalone/Makefile.in 2010-01-15 14:48:10.000000000 +0100
@@ -392,7 +392,9 @@ check_SCRIPTS = test-system-cmds test-re
test-use-srfi
BUILT_SOURCES = test-asmobs-lib.x
EXTRA_DIST = $(am__append_3) ${check_SCRIPTS}
-TESTS_ENVIRONMENT = "${top_builddir}/pre-inst-guile-env"
+TESTS_ENVIRONMENT = \
+ builddir="$(builddir)" \
+ "${top_builddir}/pre-inst-guile-env"
test_cflags = \
-I$(top_srcdir)/test-suite/standalone \
-I$(top_srcdir) -I$(top_builddir) \