- fix test suite to work with new libtool (#555479)

This commit is contained in:
Miroslav Lichvar 2010-01-15 14:01:01 +00:00
parent 8380272011
commit 01f4aebc3f
2 changed files with 64 additions and 1 deletions

View File

@ -0,0 +1,58 @@
commit a0aa1e5b69d6ef0311aeea8e4b9a94eae18a1aaf
Author: Ludovic Courtès <ludo@gnu.org>
Date: Mon Dec 14 10:59:25 2009 +0100
Fix test environment issue with ltdl from Libtool 2.2.6b.
Earlier versions of ltdl would look for extensions under $PWD; this
behavior changed in 2.2.6b.
* test-suite/standalone/Makefile.am (TESTS_ENVIRONMENT): Define
$builddir.
* test-suite/standalone/test-asmobs: Specify the full path to
`libtest-asmobs', using $builddir.
diff --git a/test-suite/standalone/Makefile.am b/test-suite/standalone/Makefile.am
index e7cfd82..058ce93 100644
--- a/test-suite/standalone/Makefile.am
+++ b/test-suite/standalone/Makefile.am
@@ -28,7 +28,9 @@ check_SCRIPTS =
BUILT_SOURCES =
EXTRA_DIST =
-TESTS_ENVIRONMENT = "${top_builddir}/pre-inst-guile-env"
+TESTS_ENVIRONMENT = \
+ builddir="$(builddir)" \
+ "${top_builddir}/pre-inst-guile-env"
test_cflags = \
-I$(top_srcdir)/test-suite/standalone \
diff --git a/test-suite/standalone/test-asmobs b/test-suite/standalone/test-asmobs
index 2ea75d9..9689ab9 100755
--- a/test-suite/standalone/test-asmobs
+++ b/test-suite/standalone/test-asmobs
@@ -2,7 +2,8 @@
exec guile -q -s "$0" "$@"
!#
-(load-extension "libtest-asmobs" "libtest_asmobs_init")
+(load-extension (string-append (getenv "builddir") "/libtest-asmobs")
+ "libtest_asmobs_init")
(define (test x v)
(if v
diff -up guile-1.8.7/test-suite/standalone/Makefile.in.ltdl guile-1.8.7/test-suite/standalone/Makefile.in
--- guile-1.8.7/test-suite/standalone/Makefile.in.ltdl 2010-01-15 14:40:52.000000000 +0100
+++ guile-1.8.7/test-suite/standalone/Makefile.in 2010-01-15 14:48:10.000000000 +0100
@@ -392,7 +392,9 @@ check_SCRIPTS = test-system-cmds test-re
test-use-srfi
BUILT_SOURCES = test-asmobs-lib.x
EXTRA_DIST = $(am__append_3) ${check_SCRIPTS}
-TESTS_ENVIRONMENT = "${top_builddir}/pre-inst-guile-env"
+TESTS_ENVIRONMENT = \
+ builddir="$(builddir)" \
+ "${top_builddir}/pre-inst-guile-env"
test_cflags = \
-I$(top_srcdir)/test-suite/standalone \
-I$(top_srcdir) -I$(top_builddir) \

View File

@ -4,7 +4,7 @@ Summary: A GNU implementation of Scheme for application extensibility
Name: guile
%define mver 1.8
Version: 1.8.7
Release: 4%{?dist}
Release: 5%{?dist}
Source: ftp://ftp.gnu.org/pub/gnu/guile/guile-%{version}.tar.gz
URL: http://www.gnu.org/software/guile/
Patch1: guile-1.8.7-multilib.patch
@ -12,6 +12,7 @@ Patch2: guile-1.8.7-testsuite.patch
Patch3: guile-1.8.7-ia64jmp.patch
Patch4: guile-1.8.6-deplibs.patch
Patch5: guile-1.8.7-linemarkers.patch
Patch6: guile-1.8.7-testsuite2.patch
License: GPLv2+ and LGPLv2+
Group: Development/Languages
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -55,6 +56,7 @@ install the guile package.
%patch3 -p1 -b .ia64jmp
%patch4 -p1 -b .deplibs
%patch5 -p1 -b .linemarkers
%patch6 -p1 -b .testsuite2
%build
@ -188,6 +190,9 @@ fi
%{_includedir}/libguile.h
%changelog
* Fri Jan 15 2010 Miroslav Lichvar <mlichvar@redhat.com> - 5:1.8.7-5
- fix test suite to work with new libtool (#555479)
* Thu Nov 19 2009 Miroslav Lichvar <mlichvar@redhat.com> - 5:1.8.7-4
- fix building with new cpp (#538707)