2.15.3
This commit is contained in:
parent
f385780fbd
commit
50dcefffe8
@ -1 +1 @@
|
|||||||
gtk+-2.15.2.tar.bz2
|
gtk+-2.15.3.tar.bz2
|
||||||
|
@ -1,14 +0,0 @@
|
|||||||
Index: gtk/gtkrange.c
|
|
||||||
===================================================================
|
|
||||||
--- gtk/gtkrange.c (revision 22222)
|
|
||||||
+++ gtk/gtkrange.c (working copy)
|
|
||||||
@@ -1225,7 +1225,9 @@
|
|
||||||
if (range->layout->n_marks)
|
|
||||||
{
|
|
||||||
g_free (range->layout->marks);
|
|
||||||
+ range->layout->marks = NULL;
|
|
||||||
g_free (range->layout->mark_pos);
|
|
||||||
+ range->layout->mark_pos = NULL;
|
|
||||||
range->layout->n_marks = 0;
|
|
||||||
}
|
|
||||||
|
|
10
gtk2.spec
10
gtk2.spec
@ -10,13 +10,13 @@
|
|||||||
%define cairo_version %{cairo_base_version}-1
|
%define cairo_version %{cairo_base_version}-1
|
||||||
%define libpng_version 2:1.2.2-16
|
%define libpng_version 2:1.2.2-16
|
||||||
|
|
||||||
%define base_version 2.15.2
|
%define base_version 2.15.3
|
||||||
%define bin_version 2.10.0
|
%define bin_version 2.10.0
|
||||||
|
|
||||||
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X
|
Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X
|
||||||
Name: gtk2
|
Name: gtk2
|
||||||
Version: %{base_version}
|
Version: %{base_version}
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: http://download.gnome.org/sources/gtk+/2.15/gtk+-%{version}.tar.bz2
|
Source: http://download.gnome.org/sources/gtk+/2.15/gtk+-%{version}.tar.bz2
|
||||||
@ -30,8 +30,6 @@ Patch0: gtk+-2.13.5-lib64.patch
|
|||||||
Patch2: workaround.patch
|
Patch2: workaround.patch
|
||||||
# http://bugzilla.redhat.com/show_bug.cgi?id=478400
|
# http://bugzilla.redhat.com/show_bug.cgi?id=478400
|
||||||
Patch3: default_printer.patch
|
Patch3: default_printer.patch
|
||||||
# fixed upstream
|
|
||||||
Patch4: togglebutton-crash.patch
|
|
||||||
|
|
||||||
BuildRequires: atk-devel >= %{atk_version}
|
BuildRequires: atk-devel >= %{atk_version}
|
||||||
BuildRequires: pango-devel >= %{pango_version}
|
BuildRequires: pango-devel >= %{pango_version}
|
||||||
@ -126,7 +124,6 @@ GTK+ widget toolkit.
|
|||||||
%patch0 -p1 -b .lib64
|
%patch0 -p1 -b .lib64
|
||||||
%patch2 -p1 -b .workaround
|
%patch2 -p1 -b .workaround
|
||||||
%patch3 -p0 -b .default-printer
|
%patch3 -p0 -b .default-printer
|
||||||
%patch4 -p0 -b .togglebutton-crash
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
libtoolize --force --copy
|
libtoolize --force --copy
|
||||||
@ -323,6 +320,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/gtk-2.0
|
%{_datadir}/gtk-2.0
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 2 2009 Matthias Clasen <mclasen@redhat.com> - 2.15.3-1
|
||||||
|
- Update to 2.15.3
|
||||||
|
|
||||||
* Thu Jan 29 2009 Matthias Clasen <mclasen@redhat.com> - 2.15.2-4
|
* Thu Jan 29 2009 Matthias Clasen <mclasen@redhat.com> - 2.15.2-4
|
||||||
- Split of an immodules subpackage (#444814)
|
- Split of an immodules subpackage (#444814)
|
||||||
- Disable ia64 hack thats not needed in Fedora
|
- Disable ia64 hack thats not needed in Fedora
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
1c230eeb1bf24b69b480d0a35da34794 gtk+-2.15.2.tar.bz2
|
e490d990f170e78555f84133f4aafdfe gtk+-2.15.3.tar.bz2
|
||||||
|
@ -1,14 +0,0 @@
|
|||||||
Index: gtk/gtktogglebutton.c
|
|
||||||
===================================================================
|
|
||||||
--- gtk/gtktogglebutton.c (revision 22218)
|
|
||||||
+++ gtk/gtktogglebutton.c (working copy)
|
|
||||||
@@ -502,7 +502,8 @@
|
|
||||||
|
|
||||||
g_object_notify (G_OBJECT (toggle_button), "active");
|
|
||||||
|
|
||||||
- GTK_BUTTON_CLASS (gtk_toggle_button_parent_class)->clicked (button);
|
|
||||||
+ if (GTK_BUTTON_CLASS (gtk_toggle_button_parent_class)->clicked)
|
|
||||||
+ GTK_BUTTON_CLASS (gtk_toggle_button_parent_class)->clicked (button);
|
|
||||||
}
|
|
||||||
|
|
||||||
static void
|
|
Loading…
Reference in New Issue
Block a user