Update patch
This commit is contained in:
parent
f1116bb7eb
commit
4b261c9dd6
@ -1,28 +1,6 @@
|
||||
From b457055e724ce9e8bec81cdbf9fbc3ceebbc97cd Mon Sep 17 00:00:00 2001
|
||||
From: Kalev Lember <kalevlember@gmail.com>
|
||||
Date: Mon, 25 Aug 2014 21:12:56 +0200
|
||||
Subject: [PATCH] Revert a series of gtk-update-icon-cache changes for F20
|
||||
|
||||
This reverts a series of commits that changed gtk-update-icon-cache to
|
||||
not include image data in the generated image cache. It is safer to keep
|
||||
this out of F20 to avoid introducing non-bugfix changes that might cause
|
||||
a fallout in other packages. In particular, the gtk3 version in F20 is
|
||||
not tested to work with this.
|
||||
|
||||
This reverts the following commits:
|
||||
72c472287bd2454f7c1837c54a4d9234df5a94cf,
|
||||
30f24286717a64dac3d0938ebb1d01a5b18254c2, and
|
||||
85fe78ed219487069a0ed7c7933bdd09c9bb5fc3.
|
||||
---
|
||||
docs/reference/gtk/gtk-update-icon-cache.xml | 13 ++-----------
|
||||
gtk/Makefile.am | 1 -
|
||||
gtk/updateiconcache.c | 3 +--
|
||||
3 files changed, 3 insertions(+), 14 deletions(-)
|
||||
|
||||
diff --git a/docs/reference/gtk/gtk-update-icon-cache.xml b/docs/reference/gtk/gtk-update-icon-cache.xml
|
||||
index 31ecd6d..4d3f4a8 100644
|
||||
--- a/docs/reference/gtk/gtk-update-icon-cache.xml
|
||||
+++ b/docs/reference/gtk/gtk-update-icon-cache.xml
|
||||
diff -up gtk+-2.24.26/docs/reference/gtk/gtk-update-icon-cache.xml.icon-cache gtk+-2.24.26/docs/reference/gtk/gtk-update-icon-cache.xml
|
||||
--- gtk+-2.24.26/docs/reference/gtk/gtk-update-icon-cache.xml.icon-cache 2014-09-29 16:02:16.000000000 -0400
|
||||
+++ gtk+-2.24.26/docs/reference/gtk/gtk-update-icon-cache.xml 2015-02-19 21:06:03.858297553 -0500
|
||||
@@ -19,11 +19,8 @@
|
||||
<command>gtk-update-icon-cache</command>
|
||||
<arg choice="opt">--force</arg>
|
||||
@ -37,35 +15,44 @@ index 31ecd6d..4d3f4a8 100644
|
||||
<arg choice="opt">--quiet</arg>
|
||||
<arg choice="opt">--validate</arg>
|
||||
<arg choice="req">iconpath</arg>
|
||||
@@ -75,12 +72,6 @@ multiple applications, the overall memory consumption is reduced as well.
|
||||
@@ -74,12 +71,6 @@ multiple applications, the overall memor
|
||||
</para></listitem>
|
||||
</varlistentry>
|
||||
|
||||
<varlistentry>
|
||||
- <varlistentry>
|
||||
- <term>--include-image-data</term>
|
||||
- <listitem><para>Include image data in the cache.
|
||||
- </para></listitem>
|
||||
- </varlistentry>
|
||||
-
|
||||
- <varlistentry>
|
||||
<varlistentry>
|
||||
<term>--source</term>
|
||||
<term>-c</term>
|
||||
<listitem><para>Output a C header file declaring a constant
|
||||
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
|
||||
index 785512f..7fbe429 100644
|
||||
--- a/gtk/Makefile.am
|
||||
+++ b/gtk/Makefile.am
|
||||
@@ -1394,7 +1394,6 @@ endif
|
||||
diff -up gtk+-2.24.26/gtk/Makefile.am.icon-cache gtk+-2.24.26/gtk/Makefile.am
|
||||
--- gtk+-2.24.26/gtk/Makefile.am.icon-cache 2015-02-19 21:06:03.859297565 -0500
|
||||
+++ gtk+-2.24.26/gtk/Makefile.am 2015-02-19 21:07:17.775156092 -0500
|
||||
@@ -1400,7 +1400,6 @@ endif
|
||||
gtkbuiltincache.h: @REBUILD@ stamp-icons
|
||||
$(MAKE) $(AM_MAKEFLAGS) gtk-update-icon-cache$(EXEEXT) $(GTK_UPDATE_ICON_CACHE_MANIFEST)
|
||||
$(MAKE) $(AM_MAKEFLAGS) gtk-update-icon-cache$(EXEEXT)
|
||||
$(gtk_update_icon_cache_program) --force --ignore-theme-index \
|
||||
- --include-image-data \
|
||||
--source builtin_icons stock-icons > gtkbuiltincache.h.tmp && \
|
||||
mv gtkbuiltincache.h.tmp gtkbuiltincache.h
|
||||
|
||||
diff --git a/gtk/updateiconcache.c b/gtk/updateiconcache.c
|
||||
index 3ed3253..cc6d5f1 100644
|
||||
--- a/gtk/updateiconcache.c
|
||||
+++ b/gtk/updateiconcache.c
|
||||
diff -up gtk+-2.24.26/gtk/Makefile.in.icon-cache gtk+-2.24.26/gtk/Makefile.in
|
||||
--- gtk+-2.24.26/gtk/Makefile.in.icon-cache 2015-02-19 21:06:03.861297588 -0500
|
||||
+++ gtk+-2.24.26/gtk/Makefile.in 2015-02-19 21:07:49.894529160 -0500
|
||||
@@ -5713,7 +5713,6 @@ stamp-icons: $(STOCK_ICONS)
|
||||
gtkbuiltincache.h: @REBUILD@ stamp-icons
|
||||
$(MAKE) $(AM_MAKEFLAGS) gtk-update-icon-cache$(EXEEXT)
|
||||
$(gtk_update_icon_cache_program) --force --ignore-theme-index \
|
||||
- --include-image-data \
|
||||
--source builtin_icons stock-icons > gtkbuiltincache.h.tmp && \
|
||||
mv gtkbuiltincache.h.tmp gtkbuiltincache.h
|
||||
|
||||
diff -up gtk+-2.24.26/gtk/updateiconcache.c.icon-cache gtk+-2.24.26/gtk/updateiconcache.c
|
||||
--- gtk+-2.24.26/gtk/updateiconcache.c.icon-cache 2014-09-29 16:02:17.000000000 -0400
|
||||
+++ gtk+-2.24.26/gtk/updateiconcache.c 2015-02-19 21:06:03.859297565 -0500
|
||||
@@ -46,7 +46,7 @@
|
||||
static gboolean force_update = FALSE;
|
||||
static gboolean ignore_theme_index = FALSE;
|
||||
@ -83,16 +70,3 @@ index 3ed3253..cc6d5f1 100644
|
||||
{ "source", 'c', 0, G_OPTION_ARG_STRING, &var_name, N_("Output a C header file"), "NAME" },
|
||||
{ "quiet", 'q', 0, G_OPTION_ARG_NONE, &quiet, N_("Turn off verbose output"), NULL },
|
||||
{ "validate", 'v', 0, G_OPTION_ARG_NONE, &validate, N_("Validate existing icon cache"), NULL },
|
||||
--
|
||||
2.1.0
|
||||
|
||||
--- gtk+-2.24.24.orig/gtk/Makefile.in 2014-08-26 00:59:03.000000000 +0200
|
||||
+++ gtk+-2.24.24/gtk/Makefile.in 2014-08-26 01:08:34.000000000 +0200
|
||||
@@ -5697,7 +5697,6 @@
|
||||
gtkbuiltincache.h: @REBUILD@ stamp-icons
|
||||
$(MAKE) $(AM_MAKEFLAGS) gtk-update-icon-cache$(EXEEXT) $(GTK_UPDATE_ICON_CACHE_MANIFEST)
|
||||
$(gtk_update_icon_cache_program) --force --ignore-theme-index \
|
||||
- --include-image-data \
|
||||
--source builtin_icons stock-icons > gtkbuiltincache.h.tmp && \
|
||||
mv gtkbuiltincache.h.tmp gtkbuiltincache.h
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user