Add upstream patch to fix build on aarch64

This commit is contained in:
Peter Robinson 2014-01-13 11:44:14 +00:00
parent 6db158c2c4
commit bd24185256
2 changed files with 41 additions and 1 deletions

34
0001-aarch64-neon.patch Normal file
View File

@ -0,0 +1,34 @@
From ad090272c831b5c62f0b310c776e76e3b1ffc88d Mon Sep 17 00:00:00 2001
From: Iain Lane <iain.lane@canonical.com>
Date: Fri, 15 Nov 2013 14:17:03 +0000
Subject: [PATCH] Prevent the NEON check in configure from passing under
aarch64.
The test verifies that the NEON C intrinsics work, but the rest of the
codebase uses lots of direct ARMv7 NEON assembly. The same intrinsics
work in A64, but the assembly is slightly different.
Prevent the check from passing so that we don't use this where it won't
work.
Patch originally by William Grant <wgrant@ubuntu.com>
https://bugzilla.gnome.org/show_bug.cgi?id=712367
---
configure.ac | 1 +
1 file changed, 1 insertion(+)
diff --git a/configure.ac b/configure.ac
index e5c223f..0495371 100644
--- a/configure.ac
+++ b/configure.ac
@@ -190,6 +190,7 @@ AC_LINK_IFELSE([
AC_LANG_PROGRAM([[
#include <arm_neon.h>
int32x4_t testfunc(int16_t *a, int16_t *b) {
+ asm volatile ("vmull.s16 q0, d0, d0" : : : "q0");
return vmull_s16(vld1_s16(a), vld1_s16(b));
}
]])],
--
1.8.4.3

View File

@ -2,13 +2,15 @@
Name: gstreamer1-plugins-base
Version: 1.2.2
Release: 1%{?dist}
Release: 2%{?dist}
Summary: GStreamer streaming media framework base plugins
License: LGPLv2+
URL: http://gstreamer.freedesktop.org/
Source0: http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-%{version}.tar.xz
Patch0: 0001-missing-plugins-Remove-the-mpegaudioversion-field.patch
# https://bugzilla.gnome.org/show_bug.cgi?id=712367
Patch1: 0001-aarch64-neon.patch
BuildRequires: gstreamer1-devel >= %{version}
BuildRequires: gobject-introspection-devel >= 1.31.1
@ -87,6 +89,7 @@ for the GStreamer Base Plugins library.
%prep
%setup -q -n gst-plugins-base-%{version}
%patch0 -p1
%patch1 -p1 -b .aarch64
%build
@ -350,6 +353,9 @@ chrpath --delete $RPM_BUILD_ROOT%{_bindir}/gst-discoverer-1.0
%changelog
* Mon Jan 13 2014 Peter Robinson <pbrobinson@fedoraproject.org> 1.2.2-2
- Add upstream patch to fix build on aarch64
* Fri Dec 27 2013 Brian Pepple <bpepple@fedoraproject.org> - 1.2.2-1
- Update to 1.2.2.