- add pkgconfig dependency
- separate static libraries to -static subpackage - fix gsl-config script - thanks Patrice Dumas
This commit is contained in:
parent
4bd4b4e018
commit
473fca6970
@ -1,17 +0,0 @@
|
||||
--- gsl-1.1/gsl-config.in.nousr Thu Mar 21 18:47:56 2002
|
||||
+++ gsl-1.1/gsl-config.in Thu Mar 21 18:48:36 2002
|
||||
@@ -58,12 +58,12 @@
|
||||
;;
|
||||
|
||||
--cflags)
|
||||
- echo @GSL_CFLAGS@
|
||||
+ echo @GSL_CFLAGS@ | sed "s|-I/usr/include||g"
|
||||
;;
|
||||
|
||||
--libs)
|
||||
: ${GSL_CBLAS_LIB=-lgslcblas}
|
||||
- echo @GSL_LIBS@ $GSL_CBLAS_LIB -lm
|
||||
+ echo @GSL_LIBS@ $GSL_CBLAS_LIB -lm | sed "s|-L/usr/lib||g"
|
||||
;;
|
||||
|
||||
--libs-without-cblas)
|
@ -1,48 +1,23 @@
|
||||
--- gsl-1.10/configure.lib64 2007-09-13 17:41:52.000000000 +0200
|
||||
+++ gsl-1.10/configure 2007-09-19 09:35:14.000000000 +0200
|
||||
@@ -853,6 +853,7 @@ RANLIB
|
||||
LIBTOOL
|
||||
GSL_CFLAGS
|
||||
GSL_LIBS
|
||||
+GSL_LIB
|
||||
MINGW32_HOST_TRUE
|
||||
MINGW32_HOST_FALSE
|
||||
LIBOBJS
|
||||
@@ -10333,7 +10334,7 @@ fi
|
||||
diff -up gsl-1.10/gsl-config.in.pom gsl-1.10/gsl-config.in
|
||||
--- gsl-1.10/gsl-config.in.pom 2001-03-21 15:22:44.000000000 +0100
|
||||
+++ gsl-1.10/gsl-config.in 2007-10-24 12:55:20.000000000 +0200
|
||||
@@ -58,16 +58,16 @@ while test $# -gt 0; do
|
||||
;;
|
||||
|
||||
GSL_CFLAGS="-I$includedir"
|
||||
GSL_LIBS="-L$libdir -lgsl"
|
||||
-
|
||||
+GSL_LIB="-L$libdir"
|
||||
|
||||
|
||||
|
||||
@@ -13275,6 +13276,7 @@ RANLIB!$RANLIB$ac_delim
|
||||
LIBTOOL!$LIBTOOL$ac_delim
|
||||
GSL_CFLAGS!$GSL_CFLAGS$ac_delim
|
||||
GSL_LIBS!$GSL_LIBS$ac_delim
|
||||
+GSL_LIB!$GSL_LIB$ac_delim
|
||||
MINGW32_HOST_TRUE!$MINGW32_HOST_TRUE$ac_delim
|
||||
MINGW32_HOST_FALSE!$MINGW32_HOST_FALSE$ac_delim
|
||||
LIBOBJS!$LIBOBJS$ac_delim
|
||||
@@ -13283,8 +13285,7 @@ HAVE_GNUM68K_IEEE_INTERFACE!$HAVE_GNUM68
|
||||
HAVE_GNUPPC_IEEE_INTERFACE!$HAVE_GNUPPC_IEEE_INTERFACE$ac_delim
|
||||
HAVE_GNUX86_IEEE_INTERFACE!$HAVE_GNUX86_IEEE_INTERFACE$ac_delim
|
||||
_ACEOF
|
||||
-
|
||||
- if test `sed -n "s/.*$ac_delim\$/X/p" conf$$subs.sed | grep -c X` = 97; then
|
||||
+ if test `sed -n "s/.*$ac_delim\$/X/p" conf$$subs.sed | grep -c X` = 98; then
|
||||
break
|
||||
elif $ac_last_try; then
|
||||
{ { echo "$as_me:$LINENO: error: could not make $CONFIG_STATUS" >&5
|
||||
--- gsl-1.10/gsl-config.in.lib64 2007-09-19 09:21:20.000000000 +0200
|
||||
+++ gsl-1.10/gsl-config.in 2007-09-19 09:21:20.000000000 +0200
|
||||
@@ -63,7 +63,7 @@ while test $# -gt 0; do
|
||||
--cflags)
|
||||
- echo @GSL_CFLAGS@
|
||||
+ echo -I$includedir
|
||||
;;
|
||||
|
||||
--libs)
|
||||
: ${GSL_CBLAS_LIB=-lgslcblas}
|
||||
- echo @GSL_LIBS@ $GSL_CBLAS_LIB -lm | sed "s|-L/usr/lib||g"
|
||||
+ echo @GSL_LIBS@ $GSL_CBLAS_LIB -lm | sed "s|@GSL_LIB@||g"
|
||||
- echo @GSL_LIBS@ $GSL_CBLAS_LIB -lm
|
||||
+ echo -lgsl $GSL_CBLAS_LIB -lm
|
||||
;;
|
||||
|
||||
--libs-without-cblas)
|
||||
- echo @GSL_LIBS@ -lm
|
||||
+ echo -lgsl -lm
|
||||
;;
|
||||
*)
|
||||
usage
|
||||
|
57
gsl.spec
57
gsl.spec
@ -1,48 +1,55 @@
|
||||
Summary: The GNU Scientific Library for numerical analysis
|
||||
Name: gsl
|
||||
Version: 1.10
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
URL: http://www.gnu.org/software/gsl/
|
||||
Source: ftp://ftp.gnu.org/gnu/gsl/%{name}-%{version}.tar.gz
|
||||
Patch0: gsl-1.1-nousr.patch
|
||||
Patch1: gsl-1.10-lib64.patch
|
||||
Patch0: gsl-1.10-lib64.patch
|
||||
# info part of this package is under GFDL license
|
||||
# eigen/nonsymmv.c and eigen/schur.c
|
||||
# contains rutiens which are part of LAPACK - under BSD style license
|
||||
License: GPLv3 and GFDL and BSD license
|
||||
License: GPLv3 and GFDL and BSD
|
||||
Group: System Environment/Libraries
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: pkgconfig
|
||||
|
||||
%description
|
||||
The GNU Scientific Library (GSL) is a collection of routines for
|
||||
numerical analysis, written in C.
|
||||
|
||||
%package devel
|
||||
Summary: Static libraries and header files for GSL development
|
||||
Summary: Libraries and the header files for GSL development
|
||||
Group: Development/Libraries
|
||||
Requires: gsl = %{version}-%{release}
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Requires(post): /sbin/install-info
|
||||
Requires(preun): /sbin/install-info
|
||||
|
||||
%description devel
|
||||
|
||||
The gsl-devel package contains the header files and static libraries
|
||||
necessary for developing programs using the GSL (GNU Scientific
|
||||
Library).
|
||||
|
||||
%package static
|
||||
Summary: Static libraries of the GSL package
|
||||
Group: Development/Libraries
|
||||
Requires: %{name}-devel = %{versions}
|
||||
|
||||
%description static
|
||||
The gsl-static package includes static libraries of GSL.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .nousr
|
||||
%patch1 -p1 -b .lib64
|
||||
%patch0 -p1 -b .lib64
|
||||
iconv -f windows-1252 -t utf-8 THANKS > THANKS.aux
|
||||
mv THANKS.aux THANKS
|
||||
|
||||
%build
|
||||
%configure
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
make install DESTDIR=$RPM_BUILD_ROOT install='install -p'
|
||||
|
||||
# remove unpackaged files from the buildroot
|
||||
rm -f $RPM_BUILD_ROOT%{_infodir}/dir
|
||||
@ -50,23 +57,6 @@ rm -rf $RPM_BUILD_ROOT%{_mandir}
|
||||
rm -rf $RPM_BUILD_ROOT%{_sysconfdir}
|
||||
rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||
|
||||
gslcsuffix=`echo "%{_lib}" `
|
||||
mv $RPM_BUILD_ROOT%{_bindir}/gsl-config $RPM_BUILD_ROOT%{_bindir}/gsl-config-$gslcsuffix
|
||||
cat > $RPM_BUILD_ROOT%{_bindir}/gsl-config << EOF
|
||||
#!/bin/sh
|
||||
# this construction is necessary to avoid a multilib problem
|
||||
# if a 64 bit version of gsl is installed, it will be used,
|
||||
# otherwise a 32 bit version will be linked
|
||||
if [ -e %{_bindir}/gsl-config-lib64 ]; then
|
||||
exec %{_bindir}/gsl-config-lib64 "\$@"
|
||||
elif [ -e %{_bindir}/gsl-config-* ]; then
|
||||
gslcfile="\`ls %{_bindir}/gsl-config-* | head -n1\`"
|
||||
exec \$gslcfile "\$@"
|
||||
fi
|
||||
EOF
|
||||
chmod 755 $RPM_BUILD_ROOT%{_bindir}/gsl-config
|
||||
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
@ -96,11 +86,20 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/aclocal/*
|
||||
%{_includedir}/*
|
||||
%{_infodir}/*info*
|
||||
%{_libdir}/*.a
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/pkgconfig/gsl.pc
|
||||
|
||||
%files static
|
||||
%defattr(-,root,root,-)
|
||||
%doc AUTHORS COPYING
|
||||
%{_libdir}/*.a
|
||||
|
||||
%changelog
|
||||
* Wed Oct 24 2007 Ivana Varekova <varekova@redhat.com> - 1.10-4
|
||||
- add pkgconfig dependency
|
||||
- separate static libraries to -static subpackage
|
||||
- fix gsl-config script - thanks Patrice Dumas
|
||||
|
||||
* Tue Sep 23 2007 Ivana Varekova <varekova@redhat.com> - 1.10-3
|
||||
- remove *.la files
|
||||
- add pkgconfig configure file
|
||||
|
Loading…
Reference in New Issue
Block a user