448fa56b6a
- Make the release be 37 since 36 is the last one we actually built - Squash down the changelog for that as well - Fix some TPM errors on 32-bit (hdegoede) - More fixups to avoid compiler changes (pjones) - Put lsmmap into the EFI builds (pjones) Related: rhbz#1572126 Signed-off-by: Peter Jones <pjones@redhat.com>
94 lines
3.0 KiB
Diff
94 lines
3.0 KiB
Diff
From 8c9465fac901caac6802d6872a1374518b001517 Mon Sep 17 00:00:00 2001
|
|
From: Leif Lindholm <leif.lindholm@linaro.org>
|
|
Date: Thu, 3 Aug 2017 11:04:24 +0100
|
|
Subject: [PATCH 058/246] efi: move fdt helper library
|
|
|
|
There is nothing ARM64 (or even ARM) specific about the efi fdt helper
|
|
library, which is used for locating or overriding a firmware-provided
|
|
devicetree in a UEFI system - so move it to loader/efi for reuse.
|
|
|
|
Move the fdtload.h include file to grub/efi and update path to
|
|
efi/fdtload.h in source code referring to it.
|
|
|
|
Signed-off-by: Leif Lindholm <leif.lindholm@linaro.org>
|
|
---
|
|
grub-core/Makefile.core.def | 2 +-
|
|
grub-core/loader/arm64/linux.c | 2 +-
|
|
grub-core/loader/arm64/xen_boot.c | 2 +-
|
|
grub-core/loader/{arm64 => efi}/fdt.c | 2 +-
|
|
include/grub/{arm64 => efi}/fdtload.h | 0
|
|
5 files changed, 4 insertions(+), 4 deletions(-)
|
|
rename grub-core/loader/{arm64 => efi}/fdt.c (99%)
|
|
rename include/grub/{arm64 => efi}/fdtload.h (100%)
|
|
|
|
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
|
index 1d86bd22e04..a65c27f7ff2 100644
|
|
--- a/grub-core/Makefile.core.def
|
|
+++ b/grub-core/Makefile.core.def
|
|
@@ -1707,7 +1707,7 @@ module = {
|
|
|
|
module = {
|
|
name = fdt;
|
|
- arm64 = loader/arm64/fdt.c;
|
|
+ arm64 = loader/efi/fdt.c;
|
|
common = lib/fdt.c;
|
|
enable = fdt;
|
|
};
|
|
diff --git a/grub-core/loader/arm64/linux.c b/grub-core/loader/arm64/linux.c
|
|
index ee3fcaa86ae..3e2f9b74296 100644
|
|
--- a/grub-core/loader/arm64/linux.c
|
|
+++ b/grub-core/loader/arm64/linux.c
|
|
@@ -26,8 +26,8 @@
|
|
#include <grub/mm.h>
|
|
#include <grub/types.h>
|
|
#include <grub/cpu/linux.h>
|
|
-#include <grub/cpu/fdtload.h>
|
|
#include <grub/efi/efi.h>
|
|
+#include <grub/efi/fdtload.h>
|
|
#include <grub/efi/pe32.h>
|
|
#include <grub/i18n.h>
|
|
#include <grub/lib/cmdline.h>
|
|
diff --git a/grub-core/loader/arm64/xen_boot.c b/grub-core/loader/arm64/xen_boot.c
|
|
index 6c145a771ee..c95d6c5a868 100644
|
|
--- a/grub-core/loader/arm64/xen_boot.c
|
|
+++ b/grub-core/loader/arm64/xen_boot.c
|
|
@@ -27,9 +27,9 @@
|
|
#include <grub/misc.h>
|
|
#include <grub/mm.h>
|
|
#include <grub/types.h>
|
|
-#include <grub/cpu/fdtload.h>
|
|
#include <grub/cpu/linux.h>
|
|
#include <grub/efi/efi.h>
|
|
+#include <grub/efi/fdtload.h>
|
|
#include <grub/efi/pe32.h> /* required by struct xen_hypervisor_header */
|
|
#include <grub/i18n.h>
|
|
#include <grub/lib/cmdline.h>
|
|
diff --git a/grub-core/loader/arm64/fdt.c b/grub-core/loader/efi/fdt.c
|
|
similarity index 99%
|
|
rename from grub-core/loader/arm64/fdt.c
|
|
rename to grub-core/loader/efi/fdt.c
|
|
index 368001696ee..091e9ddf43d 100644
|
|
--- a/grub-core/loader/arm64/fdt.c
|
|
+++ b/grub-core/loader/efi/fdt.c
|
|
@@ -18,12 +18,12 @@
|
|
|
|
#include <grub/fdt.h>
|
|
#include <grub/mm.h>
|
|
-#include <grub/cpu/fdtload.h>
|
|
#include <grub/err.h>
|
|
#include <grub/dl.h>
|
|
#include <grub/command.h>
|
|
#include <grub/file.h>
|
|
#include <grub/efi/efi.h>
|
|
+#include <grub/efi/fdtload.h>
|
|
|
|
static void *loaded_fdt;
|
|
static void *fdt;
|
|
diff --git a/include/grub/arm64/fdtload.h b/include/grub/efi/fdtload.h
|
|
similarity index 100%
|
|
rename from include/grub/arm64/fdtload.h
|
|
rename to include/grub/efi/fdtload.h
|
|
--
|
|
2.17.1
|
|
|