e1531466e1
This change updates grub to the 2.04 release. The new release changed how grub is built, so the bootstrap and bootstrap.conf files have to be added to the dist-git. Also, the gitignore file changed so it has to be updated. Since the patches have been forward ported to 2.04, there's no need for a logic to maintain a patch with the delta between the release and the grub master branch. So the release-to-master.patch is dropped and no longer is updated by the do-rebase script. Also since gnulib isn't part of the grub repository anymore and cloned by the boostrap tool, a gnulib tarball is included as other source file and copied before calling the bootstrap tool. That way grub can be built even in builders that only have access to the sources lookaside cache. Resolves: rhbz#1727279 Signed-off-by: Javier Martinez Canillas <javierm@redhat.com>
42 lines
1.4 KiB
Diff
42 lines
1.4 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Peter Jones <pjones@redhat.com>
|
|
Date: Thu, 2 Aug 2018 10:56:38 -0400
|
|
Subject: [PATCH] Disable non-wordsize allocations on arm
|
|
|
|
Signed-off-by: Peter Jones <pjones@redhat.com>
|
|
---
|
|
configure.ac | 20 ++++++++++++++++++++
|
|
1 file changed, 20 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index cf327482e8a..9b0946c27bf 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1262,6 +1262,26 @@ if test "x$target_cpu" = xarm; then
|
|
done
|
|
])
|
|
|
|
+ AC_CACHE_CHECK([for options to disable movt and movw relocations],
|
|
+ grub_cv_target_cc_mword_relocations,
|
|
+ [grub_cv_target_cc_mword_relocations=no
|
|
+ for cand in "-mword-relocations" ; do
|
|
+ if test x"$grub_cv_target_cc_mword_relocations" != xno ; then
|
|
+ break
|
|
+ fi
|
|
+ CFLAGS="$TARGET_CFLAGS $cand -Werror"
|
|
+ CPPFLAGS="$TARGET_CPPFLAGS"
|
|
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[]])],
|
|
+ [grub_cv_target_cc_mword_relocations="$cand"],
|
|
+ [])
|
|
+ done
|
|
+ ])
|
|
+ if test x"$grub_cv_target_cc_mword_relocations" = xno ; then
|
|
+ AC_MSG_ERROR(["your compiler doesn't support disabling movw/movt relocations"])
|
|
+ else
|
|
+ TARGET_CFLAGS="$TARGET_CFLAGS $grub_cv_target_cc_mword_relocations"
|
|
+ fi
|
|
+
|
|
if test x"$grub_cv_target_cc_mno_movt" != xno ; then
|
|
# A trick so that clang doesn't see it on link stage
|
|
TARGET_CPPFLAGS="$TARGET_CPPFLAGS $grub_cv_target_cc_mno_movt"
|