grub2/0465-configure.ac-Don-t-disable-extended-registers-on-emu.patch
Peter Jones f74b50e380 Rebase to upstream, fix a pile of bugs. The usual.
Signed-off-by: Peter Jones <pjones@redhat.com>
2013-06-12 15:37:08 -04:00

40 lines
1.2 KiB
Diff

From 69c5d972c80f796e61cdc3f6cdd88c227070872e Mon Sep 17 00:00:00 2001
From: Vladimir 'phcoder' Serbinenko <phcoder@gmail.com>
Date: Wed, 8 May 2013 11:01:11 +0200
Subject: [PATCH 465/482] * configure.ac: Don't disable extended
registers on emu.
---
ChangeLog | 4 ++++
configure.ac | 2 +-
2 files changed, 5 insertions(+), 1 deletion(-)
diff --git a/ChangeLog b/ChangeLog
index db874e5..39dc051 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2013-05-08 Vladimir Serbinenko <phcoder@gmail.com>
+
+ * configure.ac: Don't disable extended registers on emu.
+
2013-05-07 Vladimir Serbinenko <phcoder@gmail.com>
* configure.ac: Don't use extended registers on x86_64.
diff --git a/configure.ac b/configure.ac
index 80549b0..fa0e00a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -466,7 +466,7 @@ if test "x$target_cpu" = xi386; then
fi
fi
-if test "x$target_cpu" = xi386 || test "x$target_cpu" = xx86_64; then
+if ( test "x$target_cpu" = xi386 || test "x$target_cpu" = xx86_64 ) && test "x$platform" != xemu; then
# Some toolchains enable these features by default, but they need
# registers that aren't set up properly in GRUB.
TARGET_CFLAGS="$TARGET_CFLAGS -mno-mmx -mno-sse -mno-sse2 -mno-3dnow"
--
1.8.2.1