grub2/0464-configure.ac-Don-t-use-extended-registers-on-x86_64.patch
Peter Jones f74b50e380 Rebase to upstream, fix a pile of bugs. The usual.
Signed-off-by: Peter Jones <pjones@redhat.com>
2013-06-12 15:37:08 -04:00

44 lines
1.3 KiB
Diff

From 71cc19c0677fb7fb073d930dd0bdbbadf1c5ff66 Mon Sep 17 00:00:00 2001
From: Vladimir 'phcoder' Serbinenko <phcoder@gmail.com>
Date: Tue, 7 May 2013 20:42:05 +0200
Subject: [PATCH 464/482] * configure.ac: Don't use extended registers
on x86_64. Reported by: Peter Jones.
---
ChangeLog | 5 +++++
configure.ac | 2 ++
2 files changed, 7 insertions(+)
diff --git a/ChangeLog b/ChangeLog
index 5b0b357..db874e5 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,10 @@
2013-05-07 Vladimir Serbinenko <phcoder@gmail.com>
+ * configure.ac: Don't use extended registers on x86_64.
+ Reported by: Peter Jones.
+
+2013-05-07 Vladimir Serbinenko <phcoder@gmail.com>
+
* grub-core/term/efi/console.c: Fix compile error.
2013-05-07 Vladimir Serbinenko <phcoder@gmail.com>
diff --git a/configure.ac b/configure.ac
index 6c310f7..80549b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -464,7 +464,9 @@ if test "x$target_cpu" = xi386; then
else
TARGET_CFLAGS="$TARGET_CFLAGS -malign-jumps=1 -malign-loops=1 -malign-functions=1"
fi
+fi
+if test "x$target_cpu" = xi386 || test "x$target_cpu" = xx86_64; then
# Some toolchains enable these features by default, but they need
# registers that aren't set up properly in GRUB.
TARGET_CFLAGS="$TARGET_CFLAGS -mno-mmx -mno-sse -mno-sse2 -mno-3dnow"
--
1.8.2.1