grub2/0395-configure.ac-Use-mcmodel-large-on-x86_64-emu-as-well.patch
Peter Jones f74b50e380 Rebase to upstream, fix a pile of bugs. The usual.
Signed-off-by: Peter Jones <pjones@redhat.com>
2013-06-12 15:37:08 -04:00

51 lines
1.6 KiB
Diff

From 0ac44e6aa6e42da168eac6595cdb439b343a8a22 Mon Sep 17 00:00:00 2001
From: Vladimir 'phcoder' Serbinenko <phcoder@gmail.com>
Date: Mon, 29 Apr 2013 19:14:46 +0200
Subject: [PATCH 395/482] * configure.ac: Use -mcmodel=large on
x86_64-emu as well. Reported by: qwertial.
---
ChangeLog | 5 +++++
configure.ac | 4 +++-
2 files changed, 8 insertions(+), 1 deletion(-)
diff --git a/ChangeLog b/ChangeLog
index 0e6d38a..0485a01 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
+2013-04-29 Vladimir Serbinenko <phcoder@gmail.com>
+
+ * configure.ac: Use -mcmodel=large on x86_64-emu as well.
+ Reported by: qwertial.
+
2013-04-29 Vladimir Testov <vladimir.testov@rosalab.ru>
* grub-core/gfxmenu/circular_progress.c: Set start_angle in degrees
diff --git a/configure.ac b/configure.ac
index 5ff7f25..00540e6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -605,7 +605,7 @@ if test "x$target_m64" = x1; then
TARGET_MODULE_FORMAT="elf64"
fi
-if test "$target_cpu"-"$platform" = x86_64-efi; then
+if test "$target_cpu" = x86_64; then
# Use large model to support 4G memory
AC_CACHE_CHECK([whether option -mcmodel=large works], grub_cv_cc_mcmodel, [
SAVED_CFLAGS=$CFLAGS
@@ -619,7 +619,9 @@ if test "$target_cpu"-"$platform" = x86_64-efi; then
else
TARGET_CFLAGS="$TARGET_CFLAGS -mcmodel=large"
fi
+fi
+if test "$target_cpu"-"$platform" = x86_64-efi; then
# EFI writes to stack below %rsp, we must not use the red zone
AC_CACHE_CHECK([whether option -mno-red-zone works], grub_cv_cc_no_red_zone, [
CFLAGS="$CFLAGS -m64 -mno-red-zone"
--
1.8.2.1