grub2/0026-grub-core-fs-xfs.c-grub_xfs_read_block-Make-keys-a-c.patch
Peter Jones f74b50e380 Rebase to upstream, fix a pile of bugs. The usual.
Signed-off-by: Peter Jones <pjones@redhat.com>
2013-06-12 15:37:08 -04:00

40 lines
1.1 KiB
Diff

From 981361e1db432371d895ac1339cc4a940cd6830e Mon Sep 17 00:00:00 2001
From: Vladimir 'phcoder' Serbinenko <phcoder@gmail.com>
Date: Wed, 5 Sep 2012 08:45:07 +0200
Subject: [PATCH 026/482] * grub-core/fs/xfs.c (grub_xfs_read_block):
Make keys a const pointer.
---
ChangeLog | 4 ++++
grub-core/fs/xfs.c | 2 +-
2 files changed, 5 insertions(+), 1 deletion(-)
diff --git a/ChangeLog b/ChangeLog
index fbef0c3..0cf6bea 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2012-09-05 Vladimir Serbinenko <phcoder@gmail.com>
+
+ * grub-core/fs/xfs.c (grub_xfs_read_block): Make keys a const pointer.
+
2012-09-04 Colin Watson <cjwatson@ubuntu.com>
* Makefile.am (EXTRA_DIST): Add linguas.sh. It's only strictly
diff --git a/grub-core/fs/xfs.c b/grub-core/fs/xfs.c
index 2c6b00c..1ed048f 100644
--- a/grub-core/fs/xfs.c
+++ b/grub-core/fs/xfs.c
@@ -285,7 +285,7 @@ grub_xfs_read_block (grub_fshelp_node_t node, grub_disk_addr_t fileblock)
if (node->inode.format == XFS_INODE_FORMAT_BTREE)
{
- grub_uint64_t *keys;
+ const grub_uint64_t *keys;
int recoffset;
leaf = grub_malloc (node->data->bsize);
--
1.8.2.1