grub2/0004-conf-Makefile.common-Poison-float-and-double-on-non-.patch
Peter Jones 379acc0587 Fix release to -18 as that's the build we're doing...
This build:
- Moves starfield to a subpackage
- Doesn't allow SSE or MMX on UEFI builds (#949761)

Signed-off-by: Peter Jones <pjones@redhat.com>
2013-05-16 16:46:35 -04:00

49 lines
1.3 KiB
Diff

From 5c6c289a6a6c939e7fb3f4a7ba8a737794875a44 Mon Sep 17 00:00:00 2001
From: Vladimir 'phcoder' Serbinenko <phcoder@gmail.com>
Date: Wed, 8 May 2013 11:05:37 +0200
Subject: [PATCH 4/5] * conf/Makefile.common: Poison float and double on
non-emu.
---
ChangeLog | 4 ++++
conf/Makefile.common | 5 +++++
util/import_gcry.py | 6 ++++++
3 files changed, 15 insertions(+)
diff --git a/conf/Makefile.common b/conf/Makefile.common
index c185a55..ca1cb17 100644
--- a/conf/Makefile.common
+++ b/conf/Makefile.common
@@ -40,6 +40,11 @@ endif
# Other options
+if ! COND_emu
+CFLAGS_PLATFORM += -Dfloat=__grub_poision
+CFLAGS_PLATFORM += -Ddouble=__grub_poision
+endif
+
CPPFLAGS_DEFAULT = -DGRUB_FILE=\"$(subst $(srcdir)/,,$<)\"
CPPFLAGS_DEFAULT += -I$(builddir)
CPPFLAGS_DEFAULT += -I$(srcdir)
diff --git a/util/import_gcry.py b/util/import_gcry.py
index 18f5253..afa8e69 100644
--- a/util/import_gcry.py
+++ b/util/import_gcry.py
@@ -488,6 +488,12 @@ for src in sorted (os.listdir (os.path.join (indir, "src"))):
fw.close ()
continue
f = codecs.open (infile, "r", "utf-8")
+ if src == "types.h":
+ fw.write (f.read ().replace ("float f;", "").replace ("double g;", ""))
+ f.close ()
+ fw.close ()
+ continue
+
fw.write (f.read ())
f.close ()
fw.close ()
--
1.8.2.1