grub2/0002-configure.ac-Don-t-use-extended-registers-on-x86_64.patch
Peter Jones 379acc0587 Fix release to -18 as that's the build we're doing...
This build:
- Moves starfield to a subpackage
- Doesn't allow SSE or MMX on UEFI builds (#949761)

Signed-off-by: Peter Jones <pjones@redhat.com>
2013-05-16 16:46:35 -04:00

29 lines
907 B
Diff

From ebef39797bef17e7a28678f4b8370e6b63e10cc4 Mon Sep 17 00:00:00 2001
From: Vladimir 'phcoder' Serbinenko <phcoder@gmail.com>
Date: Tue, 7 May 2013 20:42:05 +0200
Subject: [PATCH 2/5] * configure.ac: Don't use extended registers on
x86_64. Reported by: Peter Jones.
---
ChangeLog | 5 +++++
configure.ac | 2 ++
2 files changed, 7 insertions(+)
diff --git a/configure.ac b/configure.ac
index 6c310f7..80549b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -464,7 +464,9 @@ if test "x$target_cpu" = xi386; then
else
TARGET_CFLAGS="$TARGET_CFLAGS -malign-jumps=1 -malign-loops=1 -malign-functions=1"
fi
+fi
+if test "x$target_cpu" = xi386 || test "x$target_cpu" = xx86_64; then
# Some toolchains enable these features by default, but they need
# registers that aren't set up properly in GRUB.
TARGET_CFLAGS="$TARGET_CFLAGS -mno-mmx -mno-sse -mno-sse2 -mno-3dnow"
--
1.8.2.1