6b2dd0f731
Signed-off-by: Peter Jones <pjones@redhat.com>
24 lines
1.0 KiB
Diff
24 lines
1.0 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Vladimir Serbinenko <phcoder@gmail.com>
|
|
Date: Mon, 23 Jan 2017 00:55:30 +0300
|
|
Subject: [PATCH] Use $(SHELL) rather than /bin/sh.
|
|
|
|
/bin/sh doesn't exist under termux.
|
|
---
|
|
grub-core/Makefile.am | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/grub-core/Makefile.am b/grub-core/Makefile.am
|
|
index 04e9395fd94..809a8aa26bf 100644
|
|
--- a/grub-core/Makefile.am
|
|
+++ b/grub-core/Makefile.am
|
|
@@ -278,7 +278,7 @@ BUILT_SOURCES += symlist.h
|
|
|
|
symlist.c: symlist.h gensymlist.sh
|
|
$(TARGET_CPP) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS_KERNEL) $(CPPFLAGS) -DGRUB_SYMBOL_GENERATOR=1 symlist.h > symlist.p || (rm -f symlist.p; exit 1)
|
|
- cat symlist.p | /bin/sh $(srcdir)/gensymlist.sh $(top_builddir)/config.h $(KERNEL_HEADER_FILES) >$@ || (rm -f $@; exit 1)
|
|
+ cat symlist.p | $(SHELL) $(srcdir)/gensymlist.sh $(top_builddir)/config.h $(KERNEL_HEADER_FILES) >$@ || (rm -f $@; exit 1)
|
|
rm -f symlist.p
|
|
CLEANFILES += symlist.c
|
|
BUILT_SOURCES += symlist.c
|