e1531466e1
This change updates grub to the 2.04 release. The new release changed how grub is built, so the bootstrap and bootstrap.conf files have to be added to the dist-git. Also, the gitignore file changed so it has to be updated. Since the patches have been forward ported to 2.04, there's no need for a logic to maintain a patch with the delta between the release and the grub master branch. So the release-to-master.patch is dropped and no longer is updated by the do-rebase script. Also since gnulib isn't part of the grub repository anymore and cloned by the boostrap tool, a gnulib tarball is included as other source file and copied before calling the bootstrap tool. That way grub can be built even in builders that only have access to the sources lookaside cache. Resolves: rhbz#1727279 Signed-off-by: Javier Martinez Canillas <javierm@redhat.com>
53 lines
1.8 KiB
Diff
53 lines
1.8 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Peter Jones <pjones@redhat.com>
|
|
Date: Wed, 3 Apr 2013 14:35:34 -0400
|
|
Subject: [PATCH] Move bash completion script (#922997)
|
|
|
|
Apparently these go in a new place now.
|
|
---
|
|
configure.ac | 11 +++++++++++
|
|
util/bash-completion.d/Makefile.am | 1 -
|
|
2 files changed, 11 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 7656f2434e5..d283af64c8c 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -305,6 +305,14 @@ AC_SUBST(grubdirname)
|
|
AC_DEFINE_UNQUOTED(GRUB_DIR_NAME, "$grubdirname",
|
|
[Default grub directory name])
|
|
|
|
+PKG_PROG_PKG_CONFIG
|
|
+AS_IF([$($PKG_CONFIG --exists bash-completion)], [
|
|
+ bashcompletiondir=$($PKG_CONFIG --variable=completionsdir bash-completion)
|
|
+] , [
|
|
+ bashcompletiondir=${datadir}/bash-completion/completions
|
|
+])
|
|
+AC_SUBST(bashcompletiondir)
|
|
+
|
|
#
|
|
# Checks for build programs.
|
|
#
|
|
@@ -516,6 +524,9 @@ HOST_CFLAGS="$HOST_CFLAGS $grub_cv_cc_w_extra_flags"
|
|
# Check for target programs.
|
|
#
|
|
|
|
+# This makes sure pkg.m4 is available.
|
|
+m4_pattern_forbid([^_?PKG_[A-Z_]+$],[*** pkg.m4 missing, please install pkg-config])
|
|
+
|
|
# Find tools for the target.
|
|
if test "x$target_alias" != x && test "x$host_alias" != "x$target_alias"; then
|
|
tmp_ac_tool_prefix="$ac_tool_prefix"
|
|
diff --git a/util/bash-completion.d/Makefile.am b/util/bash-completion.d/Makefile.am
|
|
index 136287cf1bf..61108f05429 100644
|
|
--- a/util/bash-completion.d/Makefile.am
|
|
+++ b/util/bash-completion.d/Makefile.am
|
|
@@ -6,7 +6,6 @@ EXTRA_DIST = $(bash_completion_source)
|
|
|
|
CLEANFILES = $(bash_completion_script) config.log
|
|
|
|
-bashcompletiondir = $(sysconfdir)/bash_completion.d
|
|
bashcompletion_DATA = $(bash_completion_script)
|
|
|
|
$(bash_completion_script): $(bash_completion_source) $(top_builddir)/config.status
|