e1531466e1
This change updates grub to the 2.04 release. The new release changed how grub is built, so the bootstrap and bootstrap.conf files have to be added to the dist-git. Also, the gitignore file changed so it has to be updated. Since the patches have been forward ported to 2.04, there's no need for a logic to maintain a patch with the delta between the release and the grub master branch. So the release-to-master.patch is dropped and no longer is updated by the do-rebase script. Also since gnulib isn't part of the grub repository anymore and cloned by the boostrap tool, a gnulib tarball is included as other source file and copied before calling the bootstrap tool. That way grub can be built even in builders that only have access to the sources lookaside cache. Resolves: rhbz#1727279 Signed-off-by: Javier Martinez Canillas <javierm@redhat.com>
471 lines
8.6 KiB
Diff
471 lines
8.6 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Peter Jones <pjones@redhat.com>
|
|
Date: Mon, 8 Jul 2019 12:55:29 +0200
|
|
Subject: [PATCH] re-write .gitignore
|
|
|
|
---
|
|
.gitignore | 366 +++++++++++++++-----------------------
|
|
docs/.gitignore | 5 +
|
|
grub-core/.gitignore | 16 ++
|
|
grub-core/lib/.gitignore | 1 +
|
|
include/grub/gcrypt/.gitignore | 2 +
|
|
po/.gitignore | 5 +
|
|
util/bash-completion.d/.gitignore | 2 +
|
|
7 files changed, 171 insertions(+), 226 deletions(-)
|
|
create mode 100644 docs/.gitignore
|
|
create mode 100644 grub-core/.gitignore
|
|
create mode 100644 grub-core/lib/.gitignore
|
|
create mode 100644 include/grub/gcrypt/.gitignore
|
|
create mode 100644 po/.gitignore
|
|
create mode 100644 util/bash-completion.d/.gitignore
|
|
|
|
diff --git a/.gitignore b/.gitignore
|
|
index 819cd185d44..b45a633f3d1 100644
|
|
--- a/.gitignore
|
|
+++ b/.gitignore
|
|
@@ -1,237 +1,151 @@
|
|
+# things ./autogen.sh will create
|
|
+/Makefile.utilgcry.def
|
|
+/ABOUT-NLS
|
|
+/aclocal.m4
|
|
+/autom4te.cache
|
|
+/build-aux
|
|
+/configure
|
|
+/gnulib
|
|
+/grub-core/lib/gnulib/
|
|
+/Makefile
|
|
+
|
|
+# things very common editors create that we never want
|
|
*~
|
|
-00_header
|
|
-10_*
|
|
-20_linux_xen
|
|
-30_os-prober
|
|
-40_custom
|
|
-41_custom
|
|
-*.1
|
|
-*.8
|
|
-ABOUT-NLS
|
|
-aclocal.m4
|
|
-ahci_test
|
|
-ascii.bitmaps
|
|
-ascii.h
|
|
-autom4te.cache
|
|
-build-aux
|
|
-build-grub-gen-asciih
|
|
-build-grub-gen-widthspec
|
|
-build-grub-mkfont
|
|
-cdboot_test
|
|
-cmp_test
|
|
-config.cache
|
|
-config.guess
|
|
-config.h
|
|
-config-util.h
|
|
-config-util.h.in
|
|
-config.log
|
|
-config.status
|
|
-config.sub
|
|
-configure
|
|
-core_compress_test
|
|
-DISTLIST
|
|
-docs/*.info
|
|
-docs/stamp-vti
|
|
-docs/version.texi
|
|
-ehci_test
|
|
-example_grub_script_test
|
|
-example_scripted_test
|
|
-example_unit_test
|
|
+.*.sw?
|
|
+*.patch
|
|
+
|
|
+# stuff you're likely to make while building test trees
|
|
+grub.cfg
|
|
+/build*/
|
|
+
|
|
+# built objects across the whole tree
|
|
+Makefile.in
|
|
+*.a
|
|
+*.am
|
|
+*.efi
|
|
*.exec
|
|
-*.exec.exe
|
|
-fddboot_test
|
|
-genkernsyms.sh
|
|
-gensymlist.sh
|
|
-gentrigtables
|
|
-gentrigtables.exe
|
|
-gettext_strings_test
|
|
-/gnulib
|
|
-grub-bin2h
|
|
-/grub-bios-setup
|
|
-/grub-bios-setup.exe
|
|
-grub_cmd_date
|
|
-grub_cmd_echo
|
|
-grub_cmd_regexp
|
|
-grub_cmd_set_date
|
|
-grub_cmd_sleep
|
|
-/grub-editenv
|
|
-/grub-editenv.exe
|
|
-grub-emu
|
|
-grub-emu-lite
|
|
-grub-emu.exe
|
|
-grub-emu-lite.exe
|
|
-grub_emu_init.c
|
|
-grub_emu_init.h
|
|
-/grub-file
|
|
-/grub-file.exe
|
|
-grub-fstest
|
|
-grub-fstest.exe
|
|
-grub_fstest_init.c
|
|
-grub_fstest_init.h
|
|
-grub_func_test
|
|
-grub-install
|
|
-grub-install.exe
|
|
-grub-kbdcomp
|
|
-/grub-macbless
|
|
-/grub-macbless.exe
|
|
-grub-macho2img
|
|
-/grub-menulst2cfg
|
|
-/grub-menulst2cfg.exe
|
|
-/grub-mk*
|
|
-grub-mount
|
|
-/grub-ofpathname
|
|
-/grub-ofpathname.exe
|
|
-grub-core/build-grub-pe2elf.exe
|
|
-/grub-probe
|
|
-/grub-probe.exe
|
|
-grub_probe_init.c
|
|
-grub_probe_init.h
|
|
-/grub-reboot
|
|
-grub_script_blanklines
|
|
-grub_script_blockarg
|
|
-grub_script_break
|
|
-grub-script-check
|
|
-grub-script-check.exe
|
|
-grub_script_check_init.c
|
|
-grub_script_check_init.h
|
|
-grub_script_comments
|
|
-grub_script_continue
|
|
-grub_script_dollar
|
|
-grub_script_echo1
|
|
-grub_script_echo_keywords
|
|
-grub_script_escape_comma
|
|
-grub_script_eval
|
|
-grub_script_expansion
|
|
-grub_script_final_semicolon
|
|
-grub_script_for1
|
|
-grub_script_functions
|
|
-grub_script_gettext
|
|
-grub_script_if
|
|
-grub_script_leading_whitespace
|
|
-grub_script_no_commands
|
|
-grub_script_not
|
|
-grub_script_return
|
|
-grub_script_setparams
|
|
-grub_script_shift
|
|
-grub_script_strcmp
|
|
-grub_script_test
|
|
-grub_script_vars1
|
|
-grub_script_while1
|
|
-grub_script.tab.c
|
|
-grub_script.tab.h
|
|
-grub_script.yy.c
|
|
-grub_script.yy.h
|
|
-grub-set-default
|
|
-grub_setup_init.c
|
|
-grub_setup_init.h
|
|
-grub-shell
|
|
-grub-shell-tester
|
|
-grub-sparc64-setup
|
|
-grub-sparc64-setup.exe
|
|
-/grub-syslinux2cfg
|
|
-/grub-syslinux2cfg.exe
|
|
-gzcompress_test
|
|
-hddboot_test
|
|
-help_test
|
|
-*.img
|
|
*.image
|
|
-*.image.exe
|
|
-include/grub/cpu
|
|
-include/grub/machine
|
|
-INSTALL.grub
|
|
-install-sh
|
|
-lib/libgcrypt-grub
|
|
-libgrub_a_init.c
|
|
-*.log
|
|
+*.img
|
|
+*.info
|
|
*.lst
|
|
-lzocompress_test
|
|
*.marker
|
|
-Makefile
|
|
/m4
|
|
*.mod
|
|
-mod-*.c
|
|
-missing
|
|
-netboot_test
|
|
+*.module
|
|
*.o
|
|
-*.a
|
|
-ohci_test
|
|
-partmap_test
|
|
-pata_test
|
|
*.pf2
|
|
-*.pp
|
|
-po/*.mo
|
|
-po/grub.pot
|
|
-po/Makefile.in.in
|
|
-po/Makevars
|
|
-po/Makevars.template
|
|
-po/POTFILES
|
|
-po/Rules-quot
|
|
-po/stamp-po
|
|
-printf_test
|
|
-priority_queue_unit_test
|
|
-pseries_test
|
|
-stamp-h
|
|
-stamp-h1
|
|
-stamp-h.in
|
|
-symlist.c
|
|
-symlist.h
|
|
-trigtables.c
|
|
-*.trs
|
|
-uhci_test
|
|
-update-grub_lib
|
|
-unidata.c
|
|
-xzcompress_test
|
|
-Makefile.in
|
|
-GPATH
|
|
-GRTAGS
|
|
-GSYMS
|
|
-GTAGS
|
|
-compile
|
|
-depcomp
|
|
-mdate-sh
|
|
-texinfo.tex
|
|
-grub-core/lib/libgcrypt-grub
|
|
-.deps
|
|
-.deps-util
|
|
-.deps-core
|
|
+*.yy.[ch]
|
|
+.deps/
|
|
+.deps-core/
|
|
+.deps-util/
|
|
.dirstamp
|
|
-Makefile.util.am
|
|
-contrib
|
|
-grub-core/bootinfo.txt
|
|
-grub-core/Makefile.core.am
|
|
-grub-core/Makefile.gcry.def
|
|
-grub-core/contrib
|
|
-grub-core/gdb_grub
|
|
-grub-core/genmod.sh
|
|
-grub-core/gensyminfo.sh
|
|
-grub-core/gmodule.pl
|
|
-grub-core/grub.chrp
|
|
-grub-core/modinfo.sh
|
|
-grub-core/*.module
|
|
-grub-core/*.module.exe
|
|
-grub-core/*.pp
|
|
-grub-core/kernel.img.bin
|
|
-util/bash-completion.d/grub
|
|
-grub-core/lib/gnulib
|
|
-grub-core/rs_decoder.h
|
|
-widthspec.bin
|
|
-widthspec.h
|
|
-docs/stamp-1
|
|
-docs/version-dev.texi
|
|
-Makefile.utilgcry.def
|
|
-po/*.po
|
|
-po/*.gmo
|
|
-po/LINGUAS
|
|
-po/remove-potcdate.sed
|
|
-include/grub/gcrypt/gcrypt.h
|
|
-include/grub/gcrypt/g10lib.h
|
|
-po/POTFILES.in
|
|
-po/POTFILES-shell.in
|
|
-/grub-glue-efi
|
|
-/grub-render-label
|
|
-/grub-glue-efi.exe
|
|
-/grub-render-label.exe
|
|
+
|
|
+# next are things you get if you do ./configure in the topdir (for e.g.
|
|
+# "make dist" invocation.
|
|
+/config-util.h
|
|
+/config.h
|
|
+/include/grub/cpu
|
|
+/include/grub/machine
|
|
+/INSTALL
|
|
+/INSTALL.grub
|
|
+/po/Makefile.in.in
|
|
+/po/Makevars
|
|
+/po/Makevars.template
|
|
+/po/POTFILES
|
|
+/po/Rules-quot
|
|
+/stamp-h
|
|
+/stamp-h1
|
|
+bootstrap.log
|
|
+config.log
|
|
+config.status
|
|
+
|
|
+# stuff "make dist" creates
|
|
+ChangeLog
|
|
+grub-*.tar
|
|
+grub-*.tar.*
|
|
+
|
|
+# stuff "make" creates
|
|
+/[[:digit:]][[:digit:]]_?*
|
|
+/ascii.h
|
|
+/build-grub-gen-asciih
|
|
+/build-grub-gen-widthspec
|
|
+/build-grub-mkfont
|
|
+/config-util.h.in
|
|
/garbage-gen
|
|
-/garbage-gen.exe
|
|
-/grub-fs-tester
|
|
-grub-core/build-grub-module-verifier
|
|
+/grub*-bios-setup
|
|
+/grub*-bios-setup.8
|
|
+/grub*-editenv
|
|
+/grub*-editenv.1
|
|
+/grub*-file
|
|
+/grub*-file.1
|
|
+/grub*-fs-tester
|
|
+/grub*-fstest
|
|
+/grub*-fstest.1
|
|
+/grub*-get-kernel-settings
|
|
+/grub*-get-kernel-settings.3
|
|
+/grub*-glue-efi
|
|
+/grub*-glue-efi.1
|
|
+/grub*-install
|
|
+/grub*-install.8
|
|
+/grub*-kbdcomp
|
|
+/grub*-kbdcomp.1
|
|
+/grub*-macbless
|
|
+/grub*-macbless.8
|
|
+/grub*-menulst2cfg
|
|
+/grub*-menulst2cfg.1
|
|
+/grub*-mount
|
|
+/grub*-mount.1
|
|
+/grub*-mkconfig
|
|
+/grub*-mkconfig.8
|
|
+/grub*-mkconfig_lib
|
|
+/grub*-mkfont
|
|
+/grub*-mkfont.1
|
|
+/grub*-mkimage
|
|
+/grub*-mkimage.1
|
|
+/grub*-mklayout
|
|
+/grub*-mklayout.1
|
|
+/grub*-mknetdir
|
|
+/grub*-mknetdir.1
|
|
+/grub*-mkpasswd-pbkdf2
|
|
+/grub*-mkpasswd-pbkdf2.1
|
|
+/grub*-mkrelpath
|
|
+/grub*-mkrelpath.1
|
|
+/grub*-mkrescue
|
|
+/grub*-mkrescue.1
|
|
+/grub*-mkstandalone
|
|
+/grub*-mkstandalone.1
|
|
+/grub*-ofpathname
|
|
+/grub*-ofpathname.8
|
|
+/grub*-probe
|
|
+/grub*-probe.8
|
|
+/grub*-reboot
|
|
+/grub*-reboot.8
|
|
+/grub*-render-label
|
|
+/grub*-render-label.1
|
|
+/grub*-rpm-sort
|
|
+/grub*-rpm-sort.8
|
|
+/grub*-script-check
|
|
+/grub*-script-check.1
|
|
+/grub*-set-bootflag
|
|
+/grub*-set-bootflag.1
|
|
+/grub*-set-default
|
|
+/grub*-set-default.8
|
|
+/grub*-set-password
|
|
+/grub*-set-password.8
|
|
+/grub*-shell
|
|
+/grub*-shell-tester
|
|
+/grub*-sparc64-setup
|
|
+/grub*-sparc64-setup.8
|
|
+/grub*-syslinux2cfg
|
|
+/grub*-syslinux2cfg.1
|
|
+/grub*-switch-to-blscfg
|
|
+/grub*-switch-to-blscfg.8
|
|
+/grub_fstest.pp
|
|
+/grub_fstest_init.c
|
|
+/grub_fstest_init.lst
|
|
+/grub_script.tab.[ch]
|
|
+/libgrub.pp
|
|
+/libgrub_a_init.c
|
|
+/libgrub_a_init.lst
|
|
+/stamp-h.in
|
|
+/widthspec.h
|
|
diff --git a/docs/.gitignore b/docs/.gitignore
|
|
new file mode 100644
|
|
index 00000000000..e1d849ef95b
|
|
--- /dev/null
|
|
+++ b/docs/.gitignore
|
|
@@ -0,0 +1,5 @@
|
|
+/*.in
|
|
+/Makefile
|
|
+/stamp-1
|
|
+/stamp-vti
|
|
+/version*.texi
|
|
diff --git a/grub-core/.gitignore b/grub-core/.gitignore
|
|
new file mode 100644
|
|
index 00000000000..2acce281159
|
|
--- /dev/null
|
|
+++ b/grub-core/.gitignore
|
|
@@ -0,0 +1,16 @@
|
|
+/*.lst
|
|
+/Makefile
|
|
+/Makefile.gcry.def
|
|
+/unidata.c
|
|
+/build-grub-module-verifier
|
|
+/gdb_grub
|
|
+/genmod.sh
|
|
+/gensyminfo.sh
|
|
+/gentrigtables
|
|
+/gmodule.pl
|
|
+/grub_script.tab.[ch]
|
|
+/modinfo.sh
|
|
+/rs_decoder.h
|
|
+/symlist.c
|
|
+/symlist.h
|
|
+/trigtables.c
|
|
diff --git a/grub-core/lib/.gitignore b/grub-core/lib/.gitignore
|
|
new file mode 100644
|
|
index 00000000000..68154591404
|
|
--- /dev/null
|
|
+++ b/grub-core/lib/.gitignore
|
|
@@ -0,0 +1 @@
|
|
+/libgcrypt-grub/
|
|
diff --git a/include/grub/gcrypt/.gitignore b/include/grub/gcrypt/.gitignore
|
|
new file mode 100644
|
|
index 00000000000..8fbf5646246
|
|
--- /dev/null
|
|
+++ b/include/grub/gcrypt/.gitignore
|
|
@@ -0,0 +1,2 @@
|
|
+g10lib.h
|
|
+gcrypt.h
|
|
diff --git a/po/.gitignore b/po/.gitignore
|
|
new file mode 100644
|
|
index 00000000000..f507e7741e3
|
|
--- /dev/null
|
|
+++ b/po/.gitignore
|
|
@@ -0,0 +1,5 @@
|
|
+/Makefile
|
|
+/POTFILES*.in
|
|
+/grub.pot
|
|
+/remove-potcdate.sed
|
|
+/stamp-po
|
|
diff --git a/util/bash-completion.d/.gitignore b/util/bash-completion.d/.gitignore
|
|
new file mode 100644
|
|
index 00000000000..6813a527ad3
|
|
--- /dev/null
|
|
+++ b/util/bash-completion.d/.gitignore
|
|
@@ -0,0 +1,2 @@
|
|
+Makefile
|
|
+grub
|