81987f4958
- Try to fix things for new compiler madness. I really don't know why gcc decided __attribute__((packed)) on a "typedef struct" should imply __attribute__((align (1))) and that it should have a warning that it does so. The obvious behavior would be to keep the alignment of the first element unless it's used in another object or type that /also/ hask the packed attribute. Why should it change the default alignment at all? - Merge in the BLS patches Javier and I wrote. - Attempt to fix pmtimer initialization failures to not be super duper slow. Signed-off-by: Peter Jones <pjones@redhat.com>
39 lines
1.2 KiB
Diff
39 lines
1.2 KiB
Diff
From c6eaa982d12e3cfc5465dda5ea372774188b6b81 Mon Sep 17 00:00:00 2001
|
|
From: Vladimir Serbinenko <phcoder@gmail.com>
|
|
Date: Tue, 9 May 2017 09:02:15 +0200
|
|
Subject: [PATCH 034/206] Missing parts of previous commit
|
|
|
|
---
|
|
grub-core/Makefile.core.def | 2 ++
|
|
grub-core/kern/arm/coreboot/init.c | 1 +
|
|
2 files changed, 3 insertions(+)
|
|
|
|
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
|
index d2239f1718d..1d86bd22e04 100644
|
|
--- a/grub-core/Makefile.core.def
|
|
+++ b/grub-core/Makefile.core.def
|
|
@@ -162,6 +162,8 @@ kernel = {
|
|
arm_coreboot = bus/fdt.c;
|
|
arm_coreboot = term/ps2.c;
|
|
arm_coreboot = term/arm/pl050.c;
|
|
+ arm_coreboot = term/arm/cros.c;
|
|
+ arm_coreboot = term/arm/cros_ec.c;
|
|
arm_coreboot = bus/spi/rk3288_spi.c;
|
|
arm_coreboot = commands/keylayouts.c;
|
|
arm_coreboot = kern/arm/coreboot/dma.c;
|
|
diff --git a/grub-core/kern/arm/coreboot/init.c b/grub-core/kern/arm/coreboot/init.c
|
|
index 0126ff6381a..8d8c5b8291e 100644
|
|
--- a/grub-core/kern/arm/coreboot/init.c
|
|
+++ b/grub-core/kern/arm/coreboot/init.c
|
|
@@ -135,6 +135,7 @@ grub_machine_init (void)
|
|
grub_rk3288_spi_init ();
|
|
|
|
grub_machine_timer_init ();
|
|
+ grub_cros_init ();
|
|
grub_pl050_init ();
|
|
}
|
|
|
|
--
|
|
2.15.0
|
|
|