81987f4958
- Try to fix things for new compiler madness. I really don't know why gcc decided __attribute__((packed)) on a "typedef struct" should imply __attribute__((align (1))) and that it should have a warning that it does so. The obvious behavior would be to keep the alignment of the first element unless it's used in another object or type that /also/ hask the packed attribute. Why should it change the default alignment at all? - Merge in the BLS patches Javier and I wrote. - Attempt to fix pmtimer initialization failures to not be super duper slow. Signed-off-by: Peter Jones <pjones@redhat.com>
33 lines
1002 B
Diff
33 lines
1002 B
Diff
From 1daa716c7017f1858de117a20a31da66815435c5 Mon Sep 17 00:00:00 2001
|
|
From: Vladimir Serbinenko <phcoder@gmail.com>
|
|
Date: Mon, 8 May 2017 19:31:55 +0200
|
|
Subject: [PATCH 017/206] Rename uboot/halt.c to dummy/halt.c.
|
|
|
|
It's not U-Boot specific and it's a stub.
|
|
---
|
|
grub-core/Makefile.core.def | 2 +-
|
|
grub-core/lib/{uboot => dummy}/halt.c | 0
|
|
2 files changed, 1 insertion(+), 1 deletion(-)
|
|
rename grub-core/lib/{uboot => dummy}/halt.c (100%)
|
|
|
|
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
|
index 45ed0fa6b1c..2a38bd4bc8a 100644
|
|
--- a/grub-core/Makefile.core.def
|
|
+++ b/grub-core/Makefile.core.def
|
|
@@ -841,7 +841,7 @@ module = {
|
|
efi = lib/efi/halt.c;
|
|
ieee1275 = lib/ieee1275/halt.c;
|
|
emu = lib/emu/halt.c;
|
|
- uboot = lib/uboot/halt.c;
|
|
+ uboot = lib/dummy/halt.c;
|
|
};
|
|
|
|
module = {
|
|
diff --git a/grub-core/lib/uboot/halt.c b/grub-core/lib/dummy/halt.c
|
|
similarity index 100%
|
|
rename from grub-core/lib/uboot/halt.c
|
|
rename to grub-core/lib/dummy/halt.c
|
|
--
|
|
2.15.0
|
|
|