81987f4958
- Try to fix things for new compiler madness. I really don't know why gcc decided __attribute__((packed)) on a "typedef struct" should imply __attribute__((align (1))) and that it should have a warning that it does so. The obvious behavior would be to keep the alignment of the first element unless it's used in another object or type that /also/ hask the packed attribute. Why should it change the default alignment at all? - Merge in the BLS patches Javier and I wrote. - Attempt to fix pmtimer initialization failures to not be super duper slow. Signed-off-by: Peter Jones <pjones@redhat.com>
29 lines
696 B
Diff
29 lines
696 B
Diff
From ede6c9689395499f98a4c14d76b97151b4de5f54 Mon Sep 17 00:00:00 2001
|
|
From: Vladimir Serbinenko <phcoder@gmail.com>
|
|
Date: Wed, 3 May 2017 12:58:15 +0200
|
|
Subject: [PATCH 011/206] Add strtoull test.
|
|
|
|
---
|
|
grub-core/Makefile.core.def | 5 +++++
|
|
1 file changed, 5 insertions(+)
|
|
|
|
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
|
|
index 2dfa22a9271..8dcd0e5a998 100644
|
|
--- a/grub-core/Makefile.core.def
|
|
+++ b/grub-core/Makefile.core.def
|
|
@@ -1961,6 +1961,11 @@ module = {
|
|
common = tests/example_functional_test.c;
|
|
};
|
|
|
|
+module = {
|
|
+ name = strtoull_test;
|
|
+ common = tests/strtoull_test.c;
|
|
+};
|
|
+
|
|
module = {
|
|
name = setjmp_test;
|
|
common = tests/setjmp_test.c;
|
|
--
|
|
2.15.0
|
|
|