7e98da058f
This change reorganizes and cleanups our patches to reduce the patch number from 314 patches to 187. That's achieved by dropping patches that are later reverted and squashing fixes for earlier patches that introduced features. There are no code changes and the diff with upstream is the same before and after the cleanup. Having fewer patches makes easier to manage the patchset and also will ease to rebase them on top of the latest grub-2.04 release. Signed-off-by: Javier Martinez Canillas <javierm@redhat.com>
62 lines
1.9 KiB
Diff
62 lines
1.9 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Peter Jones <pjones@redhat.com>
|
|
Date: Thu, 25 Jun 2015 15:41:06 -0400
|
|
Subject: [PATCH] Make it possible to enabled --build-id=sha1
|
|
|
|
Signed-off-by: Peter Jones <pjones@redhat.com>
|
|
---
|
|
configure.ac | 8 ++++++++
|
|
acinclude.m4 | 19 +++++++++++++++++++
|
|
2 files changed, 27 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 9318c281108..5f47a9265f3 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1386,7 +1386,15 @@ grub_PROG_TARGET_CC
|
|
if test "x$TARGET_APPLE_LINKER" != x1 ; then
|
|
grub_PROG_OBJCOPY_ABSOLUTE
|
|
fi
|
|
+
|
|
+AC_ARG_ENABLE([build-id],
|
|
+ [AS_HELP_STRING([--enable-build-id],
|
|
+ [ask the linker to supply build-id notes (default=no)])])
|
|
+if test x$enable_build_id = xyes; then
|
|
+grub_PROG_LD_BUILD_ID_SHA1
|
|
+else
|
|
grub_PROG_LD_BUILD_ID_NONE
|
|
+fi
|
|
if test "x$target_cpu" = xi386; then
|
|
if test "$platform" != emu && test "x$TARGET_APPLE_LINKER" != x1 ; then
|
|
if test ! -z "$TARGET_IMG_LDSCRIPT"; then
|
|
diff --git a/acinclude.m4 b/acinclude.m4
|
|
index 78cdf6e1d01..242e829ff23 100644
|
|
--- a/acinclude.m4
|
|
+++ b/acinclude.m4
|
|
@@ -136,6 +136,25 @@ if test "x$grub_cv_prog_ld_build_id_none" = xyes; then
|
|
fi
|
|
])
|
|
|
|
+dnl Supply --build-id=sha1 to ld if building modules.
|
|
+dnl This suppresses warnings from ld on some systems
|
|
+AC_DEFUN([grub_PROG_LD_BUILD_ID_SHA1],
|
|
+[AC_MSG_CHECKING([whether linker accepts --build-id=sha1])
|
|
+AC_CACHE_VAL(grub_cv_prog_ld_build_id_sha1,
|
|
+[save_LDFLAGS="$LDFLAGS"
|
|
+LDFLAGS="$LDFLAGS -Wl,--build-id=sha1"
|
|
+AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[]])],
|
|
+ [grub_cv_prog_ld_build_id_sha1=yes],
|
|
+ [grub_cv_prog_ld_build_id_sha1=no])
|
|
+LDFLAGS="$save_LDFLAGS"
|
|
+])
|
|
+AC_MSG_RESULT([$grub_cv_prog_ld_build_id_sha1])
|
|
+
|
|
+if test "x$grub_cv_prog_ld_build_id_sha1" = xyes; then
|
|
+ TARGET_LDFLAGS="$TARGET_LDFLAGS -Wl,--build-id=sha1"
|
|
+fi
|
|
+])
|
|
+
|
|
dnl Check nm
|
|
AC_DEFUN([grub_PROG_NM_WORKS],
|
|
[AC_MSG_CHECKING([whether nm works])
|