e1531466e1
This change updates grub to the 2.04 release. The new release changed how grub is built, so the bootstrap and bootstrap.conf files have to be added to the dist-git. Also, the gitignore file changed so it has to be updated. Since the patches have been forward ported to 2.04, there's no need for a logic to maintain a patch with the delta between the release and the grub master branch. So the release-to-master.patch is dropped and no longer is updated by the do-rebase script. Also since gnulib isn't part of the grub repository anymore and cloned by the boostrap tool, a gnulib tarball is included as other source file and copied before calling the bootstrap tool. That way grub can be built even in builders that only have access to the sources lookaside cache. Resolves: rhbz#1727279 Signed-off-by: Javier Martinez Canillas <javierm@redhat.com>
62 lines
1.9 KiB
Diff
62 lines
1.9 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Peter Jones <pjones@redhat.com>
|
|
Date: Thu, 25 Jun 2015 15:41:06 -0400
|
|
Subject: [PATCH] Make it possible to enabled --build-id=sha1
|
|
|
|
Signed-off-by: Peter Jones <pjones@redhat.com>
|
|
---
|
|
configure.ac | 8 ++++++++
|
|
acinclude.m4 | 19 +++++++++++++++++++
|
|
2 files changed, 27 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index eb851b8d722..8ee18ba159a 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1414,7 +1414,15 @@ grub_PROG_TARGET_CC
|
|
if test "x$TARGET_APPLE_LINKER" != x1 ; then
|
|
grub_PROG_OBJCOPY_ABSOLUTE
|
|
fi
|
|
+
|
|
+AC_ARG_ENABLE([build-id],
|
|
+ [AS_HELP_STRING([--enable-build-id],
|
|
+ [ask the linker to supply build-id notes (default=no)])])
|
|
+if test x$enable_build_id = xyes; then
|
|
+grub_PROG_LD_BUILD_ID_SHA1
|
|
+else
|
|
grub_PROG_LD_BUILD_ID_NONE
|
|
+fi
|
|
if test "x$target_cpu" = xi386; then
|
|
if test "$platform" != emu && test "x$TARGET_APPLE_LINKER" != x1 ; then
|
|
if test ! -z "$TARGET_IMG_LDSCRIPT"; then
|
|
diff --git a/acinclude.m4 b/acinclude.m4
|
|
index 78cdf6e1d01..242e829ff23 100644
|
|
--- a/acinclude.m4
|
|
+++ b/acinclude.m4
|
|
@@ -136,6 +136,25 @@ if test "x$grub_cv_prog_ld_build_id_none" = xyes; then
|
|
fi
|
|
])
|
|
|
|
+dnl Supply --build-id=sha1 to ld if building modules.
|
|
+dnl This suppresses warnings from ld on some systems
|
|
+AC_DEFUN([grub_PROG_LD_BUILD_ID_SHA1],
|
|
+[AC_MSG_CHECKING([whether linker accepts --build-id=sha1])
|
|
+AC_CACHE_VAL(grub_cv_prog_ld_build_id_sha1,
|
|
+[save_LDFLAGS="$LDFLAGS"
|
|
+LDFLAGS="$LDFLAGS -Wl,--build-id=sha1"
|
|
+AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[]])],
|
|
+ [grub_cv_prog_ld_build_id_sha1=yes],
|
|
+ [grub_cv_prog_ld_build_id_sha1=no])
|
|
+LDFLAGS="$save_LDFLAGS"
|
|
+])
|
|
+AC_MSG_RESULT([$grub_cv_prog_ld_build_id_sha1])
|
|
+
|
|
+if test "x$grub_cv_prog_ld_build_id_sha1" = xyes; then
|
|
+ TARGET_LDFLAGS="$TARGET_LDFLAGS -Wl,--build-id=sha1"
|
|
+fi
|
|
+])
|
|
+
|
|
dnl Check nm
|
|
AC_DEFUN([grub_PROG_NM_WORKS],
|
|
[AC_MSG_CHECKING([whether nm works])
|