81987f4958
- Try to fix things for new compiler madness. I really don't know why gcc decided __attribute__((packed)) on a "typedef struct" should imply __attribute__((align (1))) and that it should have a warning that it does so. The obvious behavior would be to keep the alignment of the first element unless it's used in another object or type that /also/ hask the packed attribute. Why should it change the default alignment at all? - Merge in the BLS patches Javier and I wrote. - Attempt to fix pmtimer initialization failures to not be super duper slow. Signed-off-by: Peter Jones <pjones@redhat.com>
31 lines
989 B
Diff
31 lines
989 B
Diff
From 7b698517977e63271f2692e623263de3fe57a8c8 Mon Sep 17 00:00:00 2001
|
|
From: Peter Jones <pjones@redhat.com>
|
|
Date: Fri, 4 Mar 2016 16:29:13 -0500
|
|
Subject: [PATCH 157/206] Make grub-editenv build again.
|
|
|
|
36212460d3565b18439a3a8130b28e6c97702c6a split how some of the mkimage
|
|
utility functions are defined, and they wind up being linked into
|
|
grub-editenv. Most utilities got fixed, but this one was missed.
|
|
|
|
Signed-off-by: Peter Jones <pjones@redhat.com>
|
|
---
|
|
Makefile.util.def | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
diff --git a/Makefile.util.def b/Makefile.util.def
|
|
index ed27351eb47..38cdf4ccc09 100644
|
|
--- a/Makefile.util.def
|
|
+++ b/Makefile.util.def
|
|
@@ -236,6 +236,8 @@ program = {
|
|
extra_dist = grub-core/osdep/unix/compress.c;
|
|
extra_dist = grub-core/osdep/basic/compress.c;
|
|
common = util/mkimage.c;
|
|
+ common = util/grub-mkimage32.c;
|
|
+ common = util/grub-mkimage64.c;
|
|
common = grub-core/osdep/config.c;
|
|
common = util/config.c;
|
|
common = util/resolve.c;
|
|
--
|
|
2.15.0
|
|
|