Revert broken moduledir fix *again*.
Signed-off-by: Peter Jones <pjones@redhat.com>
This commit is contained in:
parent
321567331b
commit
e08eb33a57
@ -1,98 +0,0 @@
|
||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Jones <pjones@redhat.com>
|
||||
Date: Thu, 25 May 2017 13:45:01 -0400
|
||||
Subject: [PATCH] Make module directory specifiable on the configure command
|
||||
line.
|
||||
|
||||
Currently ppc, ppc64, and ppc64le all wind up with modules in
|
||||
/usr/lib/grub/powerpc-ieee1275, because powerpc is the target cpu in
|
||||
grub's eyes. This causes file conflicts between "noarch" module
|
||||
packages.
|
||||
|
||||
This patch allows --with-moduledir=%{arch} to be specified on the
|
||||
configure command line to override the directory name for a specific
|
||||
build, to disambiguate the various ppc directories.
|
||||
|
||||
Resolves: rhbz#1455243
|
||||
|
||||
Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||
---
|
||||
configure.ac | 9 +++++++++
|
||||
grub-core/osdep/aros/config.c | 2 +-
|
||||
grub-core/osdep/unix/config.c | 2 +-
|
||||
conf/Makefile.common | 2 +-
|
||||
config.h.in | 2 ++
|
||||
5 files changed, 14 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 359cac3c26b..aef90611168 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -327,6 +327,15 @@ AS_IF([$($PKG_CONFIG --exists bash-completion)], [
|
||||
])
|
||||
AC_SUBST(bashcompletiondir)
|
||||
|
||||
+AC_ARG_WITH([moduledir],
|
||||
+ AS_HELP_STRING([--with-moduledir=NAME],
|
||||
+ [set the name of the module directory [[guessed]]]),
|
||||
+ [moduledirname="$with_moduledir"],
|
||||
+ [moduledirname="$target_cpu-$platform"])
|
||||
+AC_SUBST(moduledirname)
|
||||
+AC_DEFINE_UNQUOTED(MODULE_DIR_NAME, "$moduledirname",
|
||||
+ [Default module directory name])
|
||||
+
|
||||
#
|
||||
# Checks for build programs.
|
||||
#
|
||||
diff --git a/grub-core/osdep/aros/config.c b/grub-core/osdep/aros/config.c
|
||||
index c82d0ea8e76..bf3593d9743 100644
|
||||
--- a/grub-core/osdep/aros/config.c
|
||||
+++ b/grub-core/osdep/aros/config.c
|
||||
@@ -52,7 +52,7 @@ grub_util_get_pkgdatadir (void)
|
||||
const char *
|
||||
grub_util_get_pkglibdir (void)
|
||||
{
|
||||
- return GRUB_LIBDIR "/" PACKAGE;
|
||||
+ return GRUB_LIBDIR "/" MODULE_DIR_NAME;
|
||||
}
|
||||
|
||||
const char *
|
||||
diff --git a/grub-core/osdep/unix/config.c b/grub-core/osdep/unix/config.c
|
||||
index b637c58efb7..403eee565cd 100644
|
||||
--- a/grub-core/osdep/unix/config.c
|
||||
+++ b/grub-core/osdep/unix/config.c
|
||||
@@ -52,7 +52,7 @@ grub_util_get_pkgdatadir (void)
|
||||
const char *
|
||||
grub_util_get_pkglibdir (void)
|
||||
{
|
||||
- return GRUB_LIBDIR "/" PACKAGE;
|
||||
+ return GRUB_LIBDIR "/" MODULE_DIR_NAME;
|
||||
}
|
||||
|
||||
const char *
|
||||
diff --git a/conf/Makefile.common b/conf/Makefile.common
|
||||
index c75848f5c06..d2fedeaa3a5 100644
|
||||
--- a/conf/Makefile.common
|
||||
+++ b/conf/Makefile.common
|
||||
@@ -62,7 +62,7 @@ CCASFLAGS_LIBRARY =
|
||||
# Other variables
|
||||
|
||||
grubconfdir = $(sysconfdir)/grub.d
|
||||
-platformdir = $(pkglibdir)/$(target_cpu)-$(platform)
|
||||
+platformdir = $(pkglibdir)/$(moduledirname)
|
||||
starfielddir = $(pkgdatadir)/themes/starfield
|
||||
|
||||
CFLAGS_GNULIB = -Wno-undef -Wno-sign-compare -Wno-unused -Wno-unused-parameter -Wno-redundant-decls -Wno-unreachable-code -Wno-conversion
|
||||
diff --git a/config.h.in b/config.h.in
|
||||
index 9e8f9911b18..c7fc6efa1fa 100644
|
||||
--- a/config.h.in
|
||||
+++ b/config.h.in
|
||||
@@ -46,6 +46,8 @@
|
||||
#define END_SYMBOL @END_SYMBOL@
|
||||
/* Name of package. */
|
||||
#define PACKAGE "@PACKAGE@"
|
||||
+/* Name of the default module directory. */
|
||||
+#define MODULE_DIR_NAME "@MODULE_DIR_NAME@"
|
||||
/* Version number of package. */
|
||||
#define VERSION "@VERSION@"
|
||||
/* Define to the full name and version of this package. */
|
@ -16,7 +16,7 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||
rename util/{grub-setpassword.in => grub-set-password.in} (100%)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index aef90611168..aa7632b56c3 100644
|
||||
index 359cac3c26b..5f47a9265f3 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -66,7 +66,7 @@ grub_TRANSFORM([grub-mkrelpath])
|
@ -16,10 +16,10 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||
3 files changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index aa7632b56c3..997ac051449 100644
|
||||
index 5f47a9265f3..b3af931e958 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -863,7 +863,7 @@ fi
|
||||
@@ -854,7 +854,7 @@ fi
|
||||
# that floats are a good fit to run instead of what's written in the code.
|
||||
# Given that floating point unit is disabled (if present to begin with)
|
||||
# when GRUB is running which may result in various hard crashes.
|
@ -1,4 +1,4 @@
|
||||
From 23dbe2faf748d828fb847769c16cf97895dc31bb Mon Sep 17 00:00:00 2001
|
||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Jones <pjones@redhat.com>
|
||||
Date: Thu, 12 Jul 2018 19:39:51 -0400
|
||||
Subject: [PATCH] Fix our linuxefi/linux command reunion.
|
75
grub.patches
75
grub.patches
@ -349,41 +349,40 @@ Patch0348: 0348-bootp-Add-processing-DHCPACK-packet-from-HTTP-Boot.patch
|
||||
Patch0349: 0349-efinet-Setting-network-from-UEFI-device-path.patch
|
||||
Patch0350: 0350-efinet-Setting-DNS-server-from-UEFI-protocol.patch
|
||||
Patch0351: 0351-Fix-one-more-coverity-complaint.patch
|
||||
Patch0352: 0352-Make-module-directory-specifiable-on-the-configure-c.patch
|
||||
Patch0353: 0353-Fix-grub_net_hwaddr_to_str.patch
|
||||
Patch0354: 0354-Support-UEFI-networking-protocols.patch
|
||||
Patch0355: 0355-AUDIT-0-http-boot-tracker-bug.patch
|
||||
Patch0356: 0356-grub-core-video-efi_gop.c-Add-support-for-BLT_ONLY-a.patch
|
||||
Patch0357: 0357-efi-uga-use-64-bit-for-fb_base.patch
|
||||
Patch0358: 0358-EFI-console-Do-not-set-text-mode-until-we-actually-n.patch
|
||||
Patch0359: 0359-EFI-console-Add-grub_console_read_key_stroke-helper-.patch
|
||||
Patch0360: 0360-EFI-console-Implement-getkeystatus-support.patch
|
||||
Patch0361: 0361-Make-grub_getkeystatus-helper-funtion-available-ever.patch
|
||||
Patch0362: 0362-Accept-ESC-F8-and-holding-SHIFT-as-user-interrupt-ke.patch
|
||||
Patch0363: 0363-grub-editenv-Add-incr-command-to-increment-integer-v.patch
|
||||
Patch0364: 0364-Add-auto-hide-menu-support.patch
|
||||
Patch0365: 0365-Output-a-menu-entry-for-firmware-setup-on-UEFI-FastB.patch
|
||||
Patch0366: 0366-Add-grub-set-bootflag-utility.patch
|
||||
Patch0367: 0367-Fix-grub-setpassword-o-s-output-path.patch
|
||||
Patch0368: 0368-Make-grub-set-password-be-named-like-all-the-other-g.patch
|
||||
Patch0369: 0369-docs-Add-grub-boot-indeterminate.service-example.patch
|
||||
Patch0370: 0370-EFI-console-Fix-the-enter-key-not-working-on-X86-tab.patch
|
||||
Patch0371: 0371-00_menu_auto_hide-Use-a-timeout-of-60s-for-menu_show.patch
|
||||
Patch0372: 0372-00_menu_auto_hide-Reduce-number-of-save_env-calls.patch
|
||||
Patch0373: 0373-Minor-fixes-to-make-armv7hl-build-as-arm-efi.patch
|
||||
Patch0374: 0374-30_uefi-firmware-fix-use-with-sys-firmware-efi-efiva.patch
|
||||
Patch0375: 0375-gentpl-add-disable-support.patch
|
||||
Patch0376: 0376-gentpl-add-pc-firmware-type.patch
|
||||
Patch0377: 0377-Disable-the-reboot-module-on-EFI-builds-it-is-in-ker.patch
|
||||
Patch0378: 0378-Disable-multiboot-multiboot2-and-linux16-modules-on-.patch
|
||||
Patch0379: 0379-Make-the-linuxefi-module-just-be-the-x86-efi-version.patch
|
||||
Patch0380: 0380-Make-efi_netfs-not-duplicate-symbols-from-efinet.patch
|
||||
Patch0381: 0381-Don-t-build-the-fdt-command.patch
|
||||
Patch0382: 0382-blscfg-remove-unused-typedef.patch
|
||||
Patch0383: 0383-blscfg-don-t-dynamically-allocate-default_blsdir.patch
|
||||
Patch0384: 0384-blscfg-sort-BLS-entries-by-version-field.patch
|
||||
Patch0385: 0385-blscfg-remove-NULL-guards-around-grub_free.patch
|
||||
Patch0386: 0386-blscfg-fix-filename-in-no-linux-key-error.patch
|
||||
Patch0387: 0387-blscfg-don-t-leak-bls_entry.filename.patch
|
||||
Patch0388: 0388-blscfg-fix-compilation-on-EFI-and-EMU.patch
|
||||
Patch0389: 0389-Fix-our-linuxefi-linux-command-reunion.patch
|
||||
Patch0352: 0352-Fix-grub_net_hwaddr_to_str.patch
|
||||
Patch0353: 0353-Support-UEFI-networking-protocols.patch
|
||||
Patch0354: 0354-AUDIT-0-http-boot-tracker-bug.patch
|
||||
Patch0355: 0355-grub-core-video-efi_gop.c-Add-support-for-BLT_ONLY-a.patch
|
||||
Patch0356: 0356-efi-uga-use-64-bit-for-fb_base.patch
|
||||
Patch0357: 0357-EFI-console-Do-not-set-text-mode-until-we-actually-n.patch
|
||||
Patch0358: 0358-EFI-console-Add-grub_console_read_key_stroke-helper-.patch
|
||||
Patch0359: 0359-EFI-console-Implement-getkeystatus-support.patch
|
||||
Patch0360: 0360-Make-grub_getkeystatus-helper-funtion-available-ever.patch
|
||||
Patch0361: 0361-Accept-ESC-F8-and-holding-SHIFT-as-user-interrupt-ke.patch
|
||||
Patch0362: 0362-grub-editenv-Add-incr-command-to-increment-integer-v.patch
|
||||
Patch0363: 0363-Add-auto-hide-menu-support.patch
|
||||
Patch0364: 0364-Output-a-menu-entry-for-firmware-setup-on-UEFI-FastB.patch
|
||||
Patch0365: 0365-Add-grub-set-bootflag-utility.patch
|
||||
Patch0366: 0366-Fix-grub-setpassword-o-s-output-path.patch
|
||||
Patch0367: 0367-Make-grub-set-password-be-named-like-all-the-other-g.patch
|
||||
Patch0368: 0368-docs-Add-grub-boot-indeterminate.service-example.patch
|
||||
Patch0369: 0369-EFI-console-Fix-the-enter-key-not-working-on-X86-tab.patch
|
||||
Patch0370: 0370-00_menu_auto_hide-Use-a-timeout-of-60s-for-menu_show.patch
|
||||
Patch0371: 0371-00_menu_auto_hide-Reduce-number-of-save_env-calls.patch
|
||||
Patch0372: 0372-Minor-fixes-to-make-armv7hl-build-as-arm-efi.patch
|
||||
Patch0373: 0373-30_uefi-firmware-fix-use-with-sys-firmware-efi-efiva.patch
|
||||
Patch0374: 0374-gentpl-add-disable-support.patch
|
||||
Patch0375: 0375-gentpl-add-pc-firmware-type.patch
|
||||
Patch0376: 0376-Disable-the-reboot-module-on-EFI-builds-it-is-in-ker.patch
|
||||
Patch0377: 0377-Disable-multiboot-multiboot2-and-linux16-modules-on-.patch
|
||||
Patch0378: 0378-Make-the-linuxefi-module-just-be-the-x86-efi-version.patch
|
||||
Patch0379: 0379-Make-efi_netfs-not-duplicate-symbols-from-efinet.patch
|
||||
Patch0380: 0380-Don-t-build-the-fdt-command.patch
|
||||
Patch0381: 0381-blscfg-remove-unused-typedef.patch
|
||||
Patch0382: 0382-blscfg-don-t-dynamically-allocate-default_blsdir.patch
|
||||
Patch0383: 0383-blscfg-sort-BLS-entries-by-version-field.patch
|
||||
Patch0384: 0384-blscfg-remove-NULL-guards-around-grub_free.patch
|
||||
Patch0385: 0385-blscfg-fix-filename-in-no-linux-key-error.patch
|
||||
Patch0386: 0386-blscfg-don-t-leak-bls_entry.filename.patch
|
||||
Patch0387: 0387-blscfg-fix-compilation-on-EFI-and-EMU.patch
|
||||
Patch0388: 0388-Fix-our-linuxefi-linux-command-reunion.patch
|
||||
|
@ -7,7 +7,7 @@
|
||||
Name: grub2
|
||||
Epoch: 1
|
||||
Version: 2.02
|
||||
Release: 41%{?dist}
|
||||
Release: 42%{?dist}
|
||||
Summary: Bootloader with support for Linux, Multiboot and more
|
||||
Group: System Environment/Base
|
||||
License: GPLv3+
|
||||
@ -457,6 +457,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Jul 13 2018 Peter Jones <pjones@redhat.com> - 2.02-42
|
||||
- Revert broken moduledir fix *again*.
|
||||
|
||||
* Thu Jul 12 2018 Peter Jones <pjones@redhat.com> - 2.02-41
|
||||
- Fix our linuxefi/linux command reunion.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user