Fix autogen/autoconf invocation to actually re-make configure.

autogen.sh was running autoreconf, which *ran* configure but didn't actually
re-make it if it was there.  This means we effectively can't change our
configure invocation (for newer configure options), so that's bad.

Signed-off-by: Peter Jones <pjones@redhat.com>
This commit is contained in:
Peter Jones 2018-07-27 12:40:14 -04:00
parent 1f9267118f
commit da0e16c206
5 changed files with 33 additions and 8 deletions

View File

@ -0,0 +1,21 @@
0rom 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: Peter Jones <pjones@redhat.com>
Date: Thu, 26 Jul 2018 15:47:48 -0400
Subject: [PATCH] autogen: don't run autoreconf in the topdir
Signed-off-by: Peter Jones <pjones@redhat.com>
---
autogen.sh | 2 --
1 file changed, 2 deletions(-)
diff --git a/autogen.sh b/autogen.sh
index 7537561ad0d..f608b9467a0 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -82,6 +82,4 @@ done
echo "Saving timestamps..."
echo timestamp > stamp-h.in
-echo "Running autoreconf..."
-autoreconf -vi
exit 0

View File

@ -1,4 +1,4 @@
From b5c1a6068757af5b45297f7a981677681a534c2e Mon Sep 17 00:00:00 2001
0rom 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: Peter Jones <pjones@redhat.com>
Date: Tue, 10 Jul 2018 16:54:02 -0400
Subject: [PATCH] Force everything to use python3
@ -13,10 +13,10 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/conf/Makefile.common b/conf/Makefile.common
index d2fedeaa3a5..3d21ed54031 100644
index c4d72cd96e1..657253d5e46 100644
--- a/conf/Makefile.common
+++ b/conf/Makefile.common
@@ -128,11 +128,11 @@ BUILT_SOURCES =
@@ -129,11 +129,11 @@ BUILT_SOURCES =
.PRECIOUS: $(top_srcdir)/Makefile.util.am
$(top_srcdir)/Makefile.util.am: $(top_srcdir)/gentpl.py $(top_srcdir)/Makefile.util.def $(top_srcdir)/Makefile.utilgcry.def
@ -31,7 +31,7 @@ index d2fedeaa3a5..3d21ed54031 100644
+ python3 $^ > $@.new || (rm -f $@.new; exit 1)
mv $@.new $@
diff --git a/gentpl.py b/gentpl.py
index bf8439fa743..6ab9eb3af71 100644
index baac6a2af69..6409736e81c 100644
--- a/gentpl.py
+++ b/gentpl.py
@@ -1,4 +1,4 @@
@ -40,4 +40,3 @@ index bf8439fa743..6ab9eb3af71 100644
# GRUB -- GRand Unified Bootloader
# Copyright (C) 2010,2011,2012,2013 Free Software Foundation, Inc.
#

View File

@ -278,14 +278,18 @@ git init \
echo '![[:digit:]][[:digit:]]_*.in' > util/grub.d/.gitignore \
echo '!*.[[:digit:]]' > util/.gitignore \
echo '!config.h' > include/grub/emu/.gitignore \
patch -p1 < %{SOURCE10} \
PYTHON=python3 ./autogen.sh \
git config user.email "%{name}-owner@fedoraproject.org" \
git config user.name "Fedora Ninjas" \
git config gc.auto 0 \
rm -f configure \
git add . \
git commit -a -q -m "%{tarversion} baseline." \
git am %%{patches} </dev/null \
autoreconf -vi \
git add . \
git commit -a -q -m "autoreconf" \
autoconf \
PYTHON=python3 ./autogen.sh \
git config --unset user.email \
git config --unset user.name \
%{nil}

View File

@ -370,3 +370,5 @@ Patch0369: 0369-Add-loadenv-to-blscfg-and-loadenv-source-file-list.patch
Patch0370: 0370-blscfg-Get-rid-of-the-linuxefi-linux16-linux-distinc.patch
Patch0371: 0371-grub-switch-to-blscfg-Only-fix-boot-prefix-for-non-g.patch
Patch0372: 0372-Have-another-stab-at-fixing-fdt-build-issues.patch
Patch0373: 0373-autogen-don-t-run-autoreconf-in-the-topdir.patch
Patch0374: 0374-Force-everything-to-use-python3.patch

View File

@ -22,7 +22,6 @@ Source5: theme.tar.bz2
Source6: gitignore
Source8: strtoull_test.c
Source9: 20-grub.install
Source10: Force-everything-to-use-python3.patch
%include %{SOURCE1}