Make kernel titles suck less.
Resolves: rhbz#1215839 Signed-off-by: Peter Jones <pjones@redhat.com>
This commit is contained in:
parent
3218556f85
commit
d1197b4f47
@ -0,0 +1,54 @@
|
||||
From 2c5fbe5cd72dc8225d49d75b714962787cc273f4 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Jones <pjones@redhat.com>
|
||||
Date: Tue, 28 Apr 2015 11:15:03 -0400
|
||||
Subject: [PATCH 1/2] Make grub2-mkconfig construct titles that look like the
|
||||
ones we want elsewhere.
|
||||
|
||||
Resolves: rhbz#1215839
|
||||
|
||||
Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||
---
|
||||
util/grub.d/10_linux.in | 14 +++++++++++---
|
||||
1 file changed, 11 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/util/grub.d/10_linux.in b/util/grub.d/10_linux.in
|
||||
index e8088a1..ed4c1b7 100644
|
||||
--- a/util/grub.d/10_linux.in
|
||||
+++ b/util/grub.d/10_linux.in
|
||||
@@ -66,6 +66,15 @@ case x"$GRUB_FS" in
|
||||
;;
|
||||
esac
|
||||
|
||||
+mktitle ()
|
||||
+{
|
||||
+ local OS_NAME="$(eval $(grep ^NAME= /etc/os-release) ; echo ${NAME})"
|
||||
+ local OS_VERS="$(eval $(grep ^VERSION= /etc/os-release) ; echo ${VERSION})"
|
||||
+
|
||||
+ local titlestr="${OS_NAME} (%s) ${OS_VERS}"
|
||||
+ echo -n ${titlestr}
|
||||
+}
|
||||
+
|
||||
title_correction_code=
|
||||
|
||||
linux_entry ()
|
||||
@@ -96,15 +105,14 @@ linux_entry ()
|
||||
if [ x$type != xsimple ] ; then
|
||||
case $type in
|
||||
recovery)
|
||||
- title="$(gettext_printf "%s, with Linux %s (recovery mode)" "${os}" "${version}")" ;;
|
||||
+ title="$(printf "$(mktitle) (recovery mode)" "${version}")" ;;
|
||||
*)
|
||||
- title="$(gettext_printf "%s, with Linux %s" "${os}" "${version}")" ;;
|
||||
+ title="$(printf "$(mktitle)" "${version}")" ;;
|
||||
esac
|
||||
if [ x"$title" = x"$GRUB_ACTUAL_DEFAULT" ] || [ x"Previous Linux versions>$title" = x"$GRUB_ACTUAL_DEFAULT" ]; then
|
||||
replacement_title="$(echo "Advanced options for ${OS}" | sed 's,>,>>,g')>$(echo "$title" | sed 's,>,>>,g')"
|
||||
quoted="$(echo "$GRUB_ACTUAL_DEFAULT" | grub_quote)"
|
||||
title_correction_code="${title_correction_code}if [ \"x\$default\" = '$quoted' ]; then default='$(echo "$replacement_title" | grub_quote)'; fi;"
|
||||
- grub_warn "$(gettext_printf "Please don't use old title \`%s' for GRUB_DEFAULT, use \`%s' (for versions before 2.00) or \`%s' (for 2.00 or later)" "$GRUB_ACTUAL_DEFAULT" "$replacement_title" "gnulinux-advanced-$boot_device_id>gnulinux-$version-$type-$boot_device_id")"
|
||||
fi
|
||||
echo "menuentry '$(echo "$title" | grub_quote)' ${CLASS} \$menuentry_id_option 'gnulinux-$version-$type-$boot_device_id' {" | sed "s/^/$submenu_indentation/"
|
||||
else
|
||||
--
|
||||
2.3.6
|
||||
|
@ -0,0 +1,43 @@
|
||||
From 97b30ff21f97a98dbb7de3fd676fb360b6e28040 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Jones <pjones@redhat.com>
|
||||
Date: Tue, 28 Apr 2015 11:17:02 -0400
|
||||
Subject: [PATCH 2/2] Make rescue and debug entries sort right /again/ in
|
||||
grub2-mkconfig.
|
||||
|
||||
Related: rhbz#12145839
|
||||
|
||||
Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||
---
|
||||
util/grub-mkconfig_lib.in | 16 ++++++++--------
|
||||
1 file changed, 8 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/util/grub-mkconfig_lib.in b/util/grub-mkconfig_lib.in
|
||||
index e85b60c..2e03651 100644
|
||||
--- a/util/grub-mkconfig_lib.in
|
||||
+++ b/util/grub-mkconfig_lib.in
|
||||
@@ -254,14 +254,14 @@ version_test_gt ()
|
||||
*.old:*.old) ;;
|
||||
*.old:*) version_test_gt_a="`echo -n "$version_test_gt_a" | sed -e 's/\.old$//'`" ; version_test_gt_cmp=gt ;;
|
||||
*:*.old) version_test_gt_b="`echo -n "$version_test_gt_b" | sed -e 's/\.old$//'`" ; version_test_gt_cmp=ge ;;
|
||||
- *-rescue-*:*-rescue-*) ;;
|
||||
- *.debug:*.debug) ;;
|
||||
- *-rescue-*:*.debug) return 1 ;;
|
||||
- *.debug:*-rescue-*) return 0 ;;
|
||||
- *-rescue-*:*) return 1 ;;
|
||||
- *:*-rescue-*) return 0 ;;
|
||||
- *.debug:*) return 1 ;;
|
||||
- *:*.debug) return 0 ;;
|
||||
+ *-rescue*:*-rescue*) ;;
|
||||
+ *?debug:*?debug) ;;
|
||||
+ *-rescue*:*?debug) return 1 ;;
|
||||
+ *?debug:*-rescue*) return 0 ;;
|
||||
+ *-rescue*:*) return 1 ;;
|
||||
+ *:*-rescue*) return 0 ;;
|
||||
+ *?debug:*) return 1 ;;
|
||||
+ *:*?debug) return 0 ;;
|
||||
esac
|
||||
version_test_numeric "$version_test_gt_a" "$version_test_gt_cmp" "$version_test_gt_b"
|
||||
return "$?"
|
||||
--
|
||||
2.3.6
|
||||
|
10
grub2.spec
10
grub2.spec
@ -215,6 +215,8 @@ Patch0152: 0152-Load-arm-with-SB-enabled.patch
|
||||
Patch0153: 0153-Try-prefix-if-fw_path-doesn-t-work.patch
|
||||
Patch0154: 0154-Try-to-emit-linux16-initrd16-and-linuxefi-initrdefi-.patch
|
||||
Patch0155: 0001-Update-to-minilzo-2.08.patch
|
||||
Patch0156: 0001-Make-grub2-mkconfig-construct-titles-that-look-like-.patch
|
||||
Patch0157: 0002-Make-rescue-and-debug-entries-sort-right-again-in-gr.patch
|
||||
|
||||
BuildRequires: flex bison binutils python
|
||||
BuildRequires: ncurses-devel xz-devel bzip2-devel
|
||||
@ -635,7 +637,7 @@ fi
|
||||
%exclude /boot/%{name}/themes/system/*
|
||||
%exclude %{_datarootdir}/grub/themes/
|
||||
%{_infodir}/%{name}*
|
||||
%exclude %{_mandir}
|
||||
%{_datadir}/man/man?/*
|
||||
%doc grub-%{tarversion}/COPYING grub-%{tarversion}/INSTALL
|
||||
%doc grub-%{tarversion}/NEWS grub-%{tarversion}/README
|
||||
%doc grub-%{tarversion}/THANKS grub-%{tarversion}/TODO
|
||||
@ -650,7 +652,11 @@ fi
|
||||
%{_datarootdir}/grub/themes/starfield
|
||||
|
||||
%changelog
|
||||
* Sat Feb 21 2015 Till Maas <opensource@till.name> - 1:2.02-0.16
|
||||
* Tue Apr 28 2015 Peter Jones <pjones@redhat.com> - 2.02-0.16
|
||||
- Make grub2-mkconfig produce the kernel titles we actually want.
|
||||
Resolves: rhbz#1215839
|
||||
|
||||
* Sat Feb 21 2015 Till Maas <opensource@till.name>
|
||||
- Rebuilt for Fedora 23 Change
|
||||
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user