Some more cleanup of our giant patch series.

Signed-off-by: Peter Jones <pjones@redhat.com>
This commit is contained in:
Peter Jones 2014-01-07 10:02:18 -05:00
parent 95e3ce411f
commit 5dc55b7bd8
39 changed files with 139 additions and 324 deletions

View File

@ -0,0 +1,40 @@
From e8f07821cce1bd0ab6d5622c2a42440f15f4fd71 Mon Sep 17 00:00:00 2001
From: Vladimir Serbinenko <phcoder@gmail.com>
Date: Tue, 24 Dec 2013 21:53:23 +0100
Subject: [PATCH 01/34] * configure.ac: Set version to 2.02~beta2.
---
ChangeLog | 4 ++++
configure.ac | 2 +-
2 files changed, 5 insertions(+), 1 deletion(-)
diff --git a/ChangeLog b/ChangeLog
index 3545ea1..41bcebf 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,9 @@
2013-12-24 Vladimir Serbinenko <phcoder@gmail.com>
+ * configure.ac: Set version to 2.02~beta2.
+
+2013-12-24 Vladimir Serbinenko <phcoder@gmail.com>
+
* grub-core/disk/efi/efidisk.c (name_devices): Skip Apple ghosts.
2013-12-24 Andrey Borzenkov <arvidjaar@gmail.com>
diff --git a/configure.ac b/configure.ac
index 2481410..7c5d080 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,7 +32,7 @@ dnl type, so there is no conflict. Variables with the prefix "TARGET_"
dnl (such as TARGET_CC, TARGET_CFLAGS, etc.) are used for the target
dnl type.
-AC_INIT([GRUB],[2.02~beta1],[bug-grub@gnu.org])
+AC_INIT([GRUB],[2.02~beta2],[bug-grub@gnu.org])
AC_CONFIG_AUX_DIR([build-aux])
--
1.8.4.2

View File

@ -1,7 +1,7 @@
From be4a014a8024153e201eb1f79069ec1584001305 Mon Sep 17 00:00:00 2001
From: Mark Hamzy <hamzy@us.ibm.com>
Date: Wed, 28 Mar 2012 14:46:41 -0500
Subject: [PATCH 01/37] Migrate PPC from Yaboot to Grub2
Subject: [PATCH 02/34] Migrate PPC from Yaboot to Grub2
Add configuration support for serial terminal consoles. This will set the
maximum screen size so that text is not overwritten.

View File

@ -1,7 +1,7 @@
From 6759845abe79871a4241041915b56f617679e0b5 Mon Sep 17 00:00:00 2001
From: Paulo Flabiano Smorigo <pfsmorigo@br.ibm.com>
Date: Wed, 19 Sep 2012 21:22:55 -0300
Subject: [PATCH 02/37] Add fw_path variable (revised)
Subject: [PATCH 03/34] Add fw_path variable (revised)
This patch makes grub look for its config file on efi where the app was
found. It was originally written by Matthew Garrett, and adapted to fix the

View File

@ -1,37 +0,0 @@
From d663a99ed928038306d3db96de500bbf258f37cf Mon Sep 17 00:00:00 2001
From: Matthew Garrett <mjg@redhat.com>
Date: Tue, 10 Jul 2012 11:58:52 -0400
Subject: [PATCH 04/37] Add support for crappy cd craparino
---
grub-core/disk/efi/efidisk.c | 14 ++++++++++++++
1 file changed, 14 insertions(+)
diff --git a/grub-core/disk/efi/efidisk.c b/grub-core/disk/efi/efidisk.c
index 3b12c34..9aaa01a 100644
--- a/grub-core/disk/efi/efidisk.c
+++ b/grub-core/disk/efi/efidisk.c
@@ -799,6 +799,20 @@ grub_efidisk_get_device_name (grub_efi_handle_t *handle)
if (! ldp)
return 0;
+ if (GRUB_EFI_DEVICE_PATH_TYPE (ldp) == GRUB_EFI_MEDIA_DEVICE_PATH_TYPE &&
+ (GRUB_EFI_DEVICE_PATH_SUBTYPE (ldp) == GRUB_EFI_CDROM_DEVICE_PATH_SUBTYPE))
+ {
+ grub_efi_uint8_t length[2];
+ ldp->type = GRUB_EFI_END_DEVICE_PATH_TYPE;
+ ldp->subtype = GRUB_EFI_END_ENTIRE_DEVICE_PATH_SUBTYPE;
+
+ length[0] = 4;
+ length[1] = 0;
+ grub_memcpy (&ldp->length, length, sizeof(ldp->length));
+
+ ldp = find_last_device_path(dp);
+ }
+
if (GRUB_EFI_DEVICE_PATH_TYPE (ldp) == GRUB_EFI_MEDIA_DEVICE_PATH_TYPE
&& (GRUB_EFI_DEVICE_PATH_SUBTYPE (ldp) == GRUB_EFI_CDROM_DEVICE_PATH_SUBTYPE
|| GRUB_EFI_DEVICE_PATH_SUBTYPE (ldp) == GRUB_EFI_HARD_DRIVE_DEVICE_PATH_SUBTYPE))
--
1.8.4.2

View File

@ -1,7 +1,7 @@
From c17e307b40695b73fd972a6a4526424e9a591310 Mon Sep 17 00:00:00 2001
From: Matthew Garrett <mjg@redhat.com>
Date: Tue, 10 Jul 2012 11:58:52 -0400
Subject: [PATCH 03/37] Add support for linuxefi
Subject: [PATCH 04/34] Add support for linuxefi
---
grub-core/Makefile.core.def | 8 +

View File

@ -1,7 +1,7 @@
From 421ff909d0735ae5b761b7b6707af3b3cdd50603 Mon Sep 17 00:00:00 2001
From 9309e5ea7f0c65e9c575508de59c09a0ff732fcb Mon Sep 17 00:00:00 2001
From: Peter Jones <pjones@redhat.com>
Date: Mon, 16 Jul 2012 18:57:11 -0400
Subject: [PATCH 05/37] Use "linuxefi" and "initrdefi" where appropriate.
Subject: [PATCH 05/34] Use "linuxefi" and "initrdefi" where appropriate.
---
util/grub.d/10_linux.in | 18 ++++++++++++++++--

View File

@ -1,7 +1,7 @@
From a4172844afe46b71dd999de13cc03dcafb4b193b Mon Sep 17 00:00:00 2001
From 926684b8498a820b2e1446b697ab9c746f5302ba Mon Sep 17 00:00:00 2001
From: Colin Watson <cjwatson@ubuntu.com>
Date: Tue, 23 Oct 2012 10:40:49 -0400
Subject: [PATCH 06/37] Don't allow insmod when secure boot is enabled.
Subject: [PATCH 06/34] Don't allow insmod when secure boot is enabled.
Hi,

View File

@ -1,7 +1,7 @@
From e8e559e2744559a89a53daf5508dd51f5e3d9374 Mon Sep 17 00:00:00 2001
From 0e470ac45edd8c3e6cd06d2c6bdd5cdcf389af34 Mon Sep 17 00:00:00 2001
From: Peter Jones <pjones@redhat.com>
Date: Mon, 1 Oct 2012 13:24:37 -0400
Subject: [PATCH 07/37] Pass "\x[[:hex:]][[:hex:]]" straight through
Subject: [PATCH 07/34] Pass "\x[[:hex:]][[:hex:]]" straight through
unmolested.
---

View File

@ -1,7 +1,7 @@
From 8830ffe331bca6ea702b3273943eef9e12fc2085 Mon Sep 17 00:00:00 2001
From 24dd7353a3c7691714661ddfdc1de1c0d8386d7f Mon Sep 17 00:00:00 2001
From: Gustavo Luiz Duarte <gustavold@linux.vnet.ibm.com>
Date: Tue, 25 Sep 2012 18:40:55 -0400
Subject: [PATCH 08/37] Fix crash on http
Subject: [PATCH 08/34] Fix crash on http
Don't free file->data on receiving FIN flag since it is used all over without
checking. http_close() will be called later to free that memory.

View File

@ -1,7 +1,7 @@
From fea52b34314b75378a3f5dac9f6ecd7218a83e9b Mon Sep 17 00:00:00 2001
From 51d201f7a26bba103408e83e872678835c70f7d6 Mon Sep 17 00:00:00 2001
From: Paulo Flabiano Smorigo <pfsmorigo@br.ibm.com>
Date: Thu, 20 Sep 2012 18:07:39 -0300
Subject: [PATCH 09/37] IBM client architecture (CAS) reboot support
Subject: [PATCH 09/34] IBM client architecture (CAS) reboot support
This is an implementation of IBM client architecture (CAS) reboot for GRUB.

View File

@ -1,7 +1,7 @@
From 9dc8eb2c40952b40c77053ac4134e97264687761 Mon Sep 17 00:00:00 2001
From e8b23062cac51d90f94971779bd69a1305ef3421 Mon Sep 17 00:00:00 2001
From: Paulo Flabiano Smorigo <pfsmorigo@br.ibm.com>
Date: Tue, 30 Oct 2012 15:19:39 -0200
Subject: [PATCH 10/37] Add vlan-tag support
Subject: [PATCH 10/34] Add vlan-tag support
This patch adds support for virtual LAN (VLAN) tagging. VLAN tagging allows
multiple VLANs in a bridged network to share the same physical network link but

View File

@ -1,7 +1,7 @@
From 760216796286cb0b26cba17f1097a9a492a574d9 Mon Sep 17 00:00:00 2001
From 57d2bab2505883efe87bab31a80c42984671e4ac Mon Sep 17 00:00:00 2001
From: Paulo Flabiano Smorigo <pfsmorigo@br.ibm.com>
Date: Tue, 27 Nov 2012 16:58:39 -0200
Subject: [PATCH 11/37] Add %X option to printf functions.
Subject: [PATCH 11/34] Add %X option to printf functions.
---
grub-core/kern/misc.c | 7 +++++--

View File

@ -1,7 +1,7 @@
From 9f1046ff402e991679bbe00d2bec34d12580a497 Mon Sep 17 00:00:00 2001
From 1c9b8bec85cd2600da2f8a16ed08820300c02bee Mon Sep 17 00:00:00 2001
From: Paulo Flabiano Smorigo <pfsmorigo@br.ibm.com>
Date: Tue, 27 Nov 2012 17:18:53 -0200
Subject: [PATCH 12/37] DHCP client ID and UUID options added.
Subject: [PATCH 12/34] DHCP client ID and UUID options added.
---
grub-core/net/bootp.c | 52 +++++++++++++++++++++++++++++++++++++++++++--------

View File

@ -1,7 +1,7 @@
From b90ea8ede5b4b817a80a92fe11fca64535a6ce44 Mon Sep 17 00:00:00 2001
From 981b0dc6adaf2686f84fd90afcea28e841661ed2 Mon Sep 17 00:00:00 2001
From: Paulo Flabiano Smorigo <pfsmorigo@br.ibm.com>
Date: Tue, 27 Nov 2012 17:22:07 -0200
Subject: [PATCH 13/37] Search for specific config file for netboot
Subject: [PATCH 13/34] Search for specific config file for netboot
This patch implements a search for a specific configuration when the config
file is on a remoteserver. It uses the following order:

View File

@ -1,64 +0,0 @@
From f7fd503bbed499c02eaf13b2e44b6d3ec06eb6a6 Mon Sep 17 00:00:00 2001
From: Fedora Ninjas <grub2-owner@fedoraproject.org>
Date: Fri, 14 Dec 2012 20:10:21 -0200
Subject: [PATCH 14/37] Add bootpath device to the list
When scanning the devices, always check (and add) the bootpath device if it
isn't in the device list.
---
grub-core/disk/ieee1275/ofdisk.c | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)
diff --git a/grub-core/disk/ieee1275/ofdisk.c b/grub-core/disk/ieee1275/ofdisk.c
index 6870b39..f13c4bb 100644
--- a/grub-core/disk/ieee1275/ofdisk.c
+++ b/grub-core/disk/ieee1275/ofdisk.c
@@ -274,6 +274,10 @@ dev_iterate (const struct grub_ieee1275_devalias *alias)
static void
scan (void)
{
+ char *bootpath;
+ int bootpath_size;
+ char *type;
+
struct grub_ieee1275_devalias alias;
FOR_IEEE1275_DEVALIASES(alias)
{
@@ -284,6 +288,34 @@ scan (void)
FOR_IEEE1275_DEVCHILDREN("/", alias)
dev_iterate (&alias);
+
+ if (grub_ieee1275_get_property_length (grub_ieee1275_chosen, "bootpath",
+ &bootpath_size)
+ || bootpath_size <= 0)
+ {
+ /* Should never happen. */
+ grub_printf ("/chosen/bootpath property missing!\n");
+ return;
+ }
+
+ bootpath = (char *) grub_malloc ((grub_size_t) bootpath_size + 64);
+ if (! bootpath)
+ {
+ grub_print_error ();
+ return;
+ }
+ grub_ieee1275_get_property (grub_ieee1275_chosen, "bootpath", bootpath,
+ (grub_size_t) bootpath_size + 1, 0);
+ bootpath[bootpath_size] = '\0';
+
+ type = grub_ieee1275_get_device_type (bootpath);
+ if (type && grub_strcmp (type, "block") == 0)
+ dev_iterate_real (bootpath, bootpath);
+
+ grub_free (bootpath);
+
+ grub_devalias_iterate (dev_iterate_alias);
+ grub_children_iterate ("/", dev_iterate);
}
static int
--
1.8.4.2

View File

@ -1,7 +1,7 @@
From 9b34a37fc2eb0192a7340a48bbcf189053564af1 Mon Sep 17 00:00:00 2001
From d36fd225cab91b4f33fe9217f79951ac5a626811 Mon Sep 17 00:00:00 2001
From: Fedora Ninjas <grub2-owner@fedoraproject.org>
Date: Tue, 22 Jan 2013 06:31:38 +0100
Subject: [PATCH 15/37] blscfg: add blscfg module to parse Boot Loader
Subject: [PATCH 14/34] blscfg: add blscfg module to parse Boot Loader
Specification snippets
http://www.freedesktop.org/wiki/Specifications/BootLoaderSpec

View File

@ -1,7 +1,7 @@
From 8d4fad25f19d30bcefa35faac58e8409faba5e95 Mon Sep 17 00:00:00 2001
From 2de33dbfb9f5b2a471e546d10c2ddf578aacdf32 Mon Sep 17 00:00:00 2001
From: Peter Jones <pjones@redhat.com>
Date: Wed, 3 Apr 2013 14:35:34 -0400
Subject: [PATCH 16/37] Move bash completion script (#922997)
Subject: [PATCH 15/34] Move bash completion script (#922997)
Apparently these go in a new place now.
---

View File

@ -1,7 +1,7 @@
From 7bbad98fa473db677f40d073e6c2d7a74b382537 Mon Sep 17 00:00:00 2001
From 89157f2a9b9c270bd6f2d4bc231cb6713c02128b Mon Sep 17 00:00:00 2001
From: Paulo Flabiano Smorigo <pfsmorigo@br.ibm.com>
Date: Wed, 24 Apr 2013 10:51:48 -0300
Subject: [PATCH 17/37] for ppc, reset console display attr when clear screen
Subject: [PATCH 16/34] for ppc, reset console display attr when clear screen
This should fix this bugzilla:
https://bugzilla.redhat.com/show_bug.cgi?id=908519

View File

@ -1,7 +1,7 @@
From 36b986f8d93282b139e3d0785fd16ddfd4b6759c Mon Sep 17 00:00:00 2001
From dbd8d3b9c616bf5a9e2b825a25bc441f092a11a2 Mon Sep 17 00:00:00 2001
From: William Jon McCann <william.jon.mccann@gmail.com>
Date: Wed, 15 May 2013 13:30:20 -0400
Subject: [PATCH 18/37] Don't write messages to the screen
Subject: [PATCH 17/34] Don't write messages to the screen
Writing messages to the screen before the menus or boot splash
happens so quickly it looks like something is wrong and isn't

View File

@ -1,7 +1,7 @@
From 2ddca048faf3d14cac3137693f05baa43814ddab Mon Sep 17 00:00:00 2001
From 71aab2b998c1c0c7e4b599f90f01adf754829c76 Mon Sep 17 00:00:00 2001
From: William Jon McCann <william.jon.mccann@gmail.com>
Date: Wed, 15 May 2013 13:53:48 -0400
Subject: [PATCH 19/37] Don't print GNU GRUB header
Subject: [PATCH 18/34] Don't print GNU GRUB header
No one cares.
---

View File

@ -1,7 +1,7 @@
From 844d6d3e0095ce2601ea1681b25445b83d69c202 Mon Sep 17 00:00:00 2001
From f69af9256a85c2f63ebce23957fa70cdabe0c3ee Mon Sep 17 00:00:00 2001
From: William Jon McCann <william.jon.mccann@gmail.com>
Date: Wed, 15 May 2013 17:49:45 -0400
Subject: [PATCH 21/37] Don't add '*' to highlighted row
Subject: [PATCH 19/34] Don't add '*' to highlighted row
It is already highlighted.
---
@ -9,15 +9,15 @@ It is already highlighted.
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/grub-core/normal/menu_text.c b/grub-core/normal/menu_text.c
index daf92b5..2f84fcc 100644
index 2ff2941..daf92b5 100644
--- a/grub-core/normal/menu_text.c
+++ b/grub-core/normal/menu_text.c
@@ -242,7 +242,7 @@ print_entry (int y, int highlight, grub_menu_entry_t entry,
unicode_title[i] = ' ';
if (data->geo.num_entries > 1)
- grub_putcode (' ', term);
+ grub_putcode (' ', data->term);
- grub_putcode (highlight ? '*' : ' ', data->term);
+ grub_putcode (' ', term);
grub_print_ucs4_menu (unicode_title,
unicode_title + len,

View File

@ -1,7 +1,7 @@
From fcb74241d96bd86f0ecb50eba27421078251d769 Mon Sep 17 00:00:00 2001
From 4dc5d2ee1a2cfe0fe120dd83b69fbdeee63b6c1e Mon Sep 17 00:00:00 2001
From: William Jon McCann <william.jon.mccann@gmail.com>
Date: Wed, 15 May 2013 17:49:45 -0400
Subject: [PATCH 20/37] Don't add '*' to highlighted row
Subject: [PATCH 20/34] Don't add '*' to highlighted row
It is already highlighted.
---
@ -9,15 +9,15 @@ It is already highlighted.
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/grub-core/normal/menu_text.c b/grub-core/normal/menu_text.c
index 2ff2941..daf92b5 100644
index daf92b5..2f84fcc 100644
--- a/grub-core/normal/menu_text.c
+++ b/grub-core/normal/menu_text.c
@@ -242,7 +242,7 @@ print_entry (int y, int highlight, grub_menu_entry_t entry,
unicode_title[i] = ' ';
if (data->geo.num_entries > 1)
- grub_putcode (highlight ? '*' : ' ', data->term);
+ grub_putcode (' ', term);
- grub_putcode (' ', term);
+ grub_putcode (' ', data->term);
grub_print_ucs4_menu (unicode_title,
unicode_title + len,

View File

@ -1,7 +1,7 @@
From 1ead3c560c50ad3a391331dc441c5a7f04baf8f9 Mon Sep 17 00:00:00 2001
From 8236dcd99b7e259d40317cafce236c8e77e2d9c5 Mon Sep 17 00:00:00 2001
From: William Jon McCann <william.jon.mccann@gmail.com>
Date: Fri, 7 Jun 2013 11:09:04 -0400
Subject: [PATCH 22/37] Message string cleanups
Subject: [PATCH 21/34] Message string cleanups
Make use of terminology consistent. Remove jargon.
---

View File

@ -1,7 +1,7 @@
From 05a286de64f28457140082caef238a83cc9465bd Mon Sep 17 00:00:00 2001
From 8724eb81bc2549c66e02a90da3e969e5e37d55d1 Mon Sep 17 00:00:00 2001
From: William Jon McCann <william.jon.mccann@gmail.com>
Date: Fri, 7 Jun 2013 14:08:23 -0400
Subject: [PATCH 23/37] Fix border spacing now that we aren't displaying it
Subject: [PATCH 22/34] Fix border spacing now that we aren't displaying it
---
grub-core/normal/menu_text.c | 6 +++---

View File

@ -1,7 +1,7 @@
From 47844331e2f4d8599f5a1f702600c7933cc04b0f Mon Sep 17 00:00:00 2001
From 177935794addb8b5161f8f59375965e6b5e9eae9 Mon Sep 17 00:00:00 2001
From: William Jon McCann <william.jon.mccann@gmail.com>
Date: Fri, 7 Jun 2013 14:08:49 -0400
Subject: [PATCH 24/37] Use the correct indentation for the term help text
Subject: [PATCH 23/34] Use the correct indentation for the term help text
That is consistent with the menu help text
---

View File

@ -1,7 +1,7 @@
From 1e7cb9ee6de26aea57bd7921543abe0d601d7f98 Mon Sep 17 00:00:00 2001
From 2a7f555009e4b66e9143fc2cea020c97c5eaf253 Mon Sep 17 00:00:00 2001
From: William Jon McCann <william.jon.mccann@gmail.com>
Date: Fri, 7 Jun 2013 14:30:55 -0400
Subject: [PATCH 25/37] Indent menu entries
Subject: [PATCH 24/34] Indent menu entries
---
grub-core/normal/menu_text.c | 3 ++-

View File

@ -1,7 +1,7 @@
From b46a40849da48fd70dde9253a55c80c1a0fe1216 Mon Sep 17 00:00:00 2001
From b506c9c46234afdf142a4bfa32d159916193f720 Mon Sep 17 00:00:00 2001
From: William Jon McCann <william.jon.mccann@gmail.com>
Date: Fri, 7 Jun 2013 14:59:36 -0400
Subject: [PATCH 26/37] Fix margins
Subject: [PATCH 25/34] Fix margins
---
grub-core/normal/menu_text.c | 8 +++-----

View File

@ -1,7 +1,7 @@
From 90fbb113660ba7157f0f3f8b89fccf1259c7ebcc Mon Sep 17 00:00:00 2001
From c0ed0f4c72c02ce90fd4a4a775b14b7510018216 Mon Sep 17 00:00:00 2001
From: Matthew Garrett <matthew.garrett@nebula.com>
Date: Wed, 12 Jun 2013 11:51:49 -0400
Subject: [PATCH 27/37] Add support for UEFI operating systems returned by
Subject: [PATCH 26/34] Add support for UEFI operating systems returned by
os-prober
os-prober returns UEFI operating systems in the form:

View File

@ -1,7 +1,7 @@
From e9c924a04e94f3fcc743fd297f183ade261ed717 Mon Sep 17 00:00:00 2001
From 5cd617fb2727a545de7a22439bd7d1a8e712e85a Mon Sep 17 00:00:00 2001
From: Paulo Flabiano Smorigo <pfsmorigo@br.ibm.com>
Date: Tue, 11 Jun 2013 15:14:05 -0300
Subject: [PATCH 28/37] Disable GRUB video support for IBM power machines
Subject: [PATCH 27/34] Disable GRUB video support for IBM power machines
Should fix the problem in bugzilla:
https://bugzilla.redhat.com/show_bug.cgi?id=973205

View File

@ -1,7 +1,7 @@
From 8409b67aedc302f60474b1633c03c3db1a7f4cec Mon Sep 17 00:00:00 2001
From af7ac4e7b446061fd865b61b90df37871984421b Mon Sep 17 00:00:00 2001
From: Peter Jones <pjones@redhat.com>
Date: Fri, 21 Jun 2013 14:44:08 -0400
Subject: [PATCH 31/37] Use -2 instead of -1 for our right-hand margin, so
Subject: [PATCH 28/34] Use -2 instead of -1 for our right-hand margin, so
linewrapping works (#976643).
Signed-off-by: Peter Jones <grub2-owner@fedoraproject.org>

View File

@ -1,65 +0,0 @@
From 7ed7010a4c3cbbd417afb12ba6eaabf250bbc38d Mon Sep 17 00:00:00 2001
From: Peter Jones <pjones@redhat.com>
Date: Wed, 12 Jun 2013 14:39:31 -0400
Subject: [PATCH 29/37] Revert "Add bootpath device to the list" (#967862)
commit c6e8465f fixes this issue.
This reverts commit a2780be06f7de35a0dd4cc19a68b151176707ae7.
---
grub-core/disk/ieee1275/ofdisk.c | 32 --------------------------------
1 file changed, 32 deletions(-)
diff --git a/grub-core/disk/ieee1275/ofdisk.c b/grub-core/disk/ieee1275/ofdisk.c
index f13c4bb..6870b39 100644
--- a/grub-core/disk/ieee1275/ofdisk.c
+++ b/grub-core/disk/ieee1275/ofdisk.c
@@ -274,10 +274,6 @@ dev_iterate (const struct grub_ieee1275_devalias *alias)
static void
scan (void)
{
- char *bootpath;
- int bootpath_size;
- char *type;
-
struct grub_ieee1275_devalias alias;
FOR_IEEE1275_DEVALIASES(alias)
{
@@ -288,34 +284,6 @@ scan (void)
FOR_IEEE1275_DEVCHILDREN("/", alias)
dev_iterate (&alias);
-
- if (grub_ieee1275_get_property_length (grub_ieee1275_chosen, "bootpath",
- &bootpath_size)
- || bootpath_size <= 0)
- {
- /* Should never happen. */
- grub_printf ("/chosen/bootpath property missing!\n");
- return;
- }
-
- bootpath = (char *) grub_malloc ((grub_size_t) bootpath_size + 64);
- if (! bootpath)
- {
- grub_print_error ();
- return;
- }
- grub_ieee1275_get_property (grub_ieee1275_chosen, "bootpath", bootpath,
- (grub_size_t) bootpath_size + 1, 0);
- bootpath[bootpath_size] = '\0';
-
- type = grub_ieee1275_get_device_type (bootpath);
- if (type && grub_strcmp (type, "block") == 0)
- dev_iterate_real (bootpath, bootpath);
-
- grub_free (bootpath);
-
- grub_devalias_iterate (dev_iterate_alias);
- grub_children_iterate ("/", dev_iterate);
}
static int
--
1.8.4.2

View File

@ -1,7 +1,7 @@
From 4d4c8f3afa586aa09632ad02f5d89c9717f7878f Mon Sep 17 00:00:00 2001
From fbcb0b99d3a4ee0c1d38c965b0dc7cda22d04f28 Mon Sep 17 00:00:00 2001
From: Peter Jones <pjones@redhat.com>
Date: Mon, 28 Oct 2013 10:05:07 -0400
Subject: [PATCH 32/37] Use linux16 when appropriate (#880840)
Subject: [PATCH 29/34] Use linux16 when appropriate (#880840)
The kernel group really would prefer that we use the 16 bit entry point
on x86 bios machines.
@ -14,16 +14,16 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
1 file changed, 7 insertions(+), 2 deletions(-)
diff --git a/util/grub.d/10_linux.in b/util/grub.d/10_linux.in
index e762e1f..6befbd1 100644
index e762e1f..600bfd2 100644
--- a/util/grub.d/10_linux.in
+++ b/util/grub.d/10_linux.in
@@ -74,6 +74,11 @@ linux_entry ()
type="$3"
args="$4"
+ 16bit=""
+ sixteenbit=""
+ case "$machine" in
+ i?86) 16bit="16" ;;
+ i?86|x86_64) sixteenbit="16" ;;
+ esac
+
if [ -z "$boot_device_id" ]; then
@ -34,7 +34,7 @@ index e762e1f..6befbd1 100644
else
sed "s/^/$submenu_indentation/" << EOF
- linux ${rel_dirname}/${basename} root=${linux_root_device_thisversion} ro ${args}
+ linux${16bit} ${rel_dirname}/${basename} root=${linux_root_device_thisversion} ro ${args}
+ linux${sixteenbit} ${rel_dirname}/${basename} root=${linux_root_device_thisversion} ro ${args}
EOF
fi
if test -n "${initrd}" ; then
@ -43,7 +43,7 @@ index e762e1f..6befbd1 100644
else
sed "s/^/$submenu_indentation/" << EOF
- initrd ${rel_dirname}/${initrd}
+ initrd${16bit} ${rel_dirname}/${initrd}
+ initrd${sixteenbit} ${rel_dirname}/${initrd}
EOF
fi
fi

View File

@ -1,7 +1,7 @@
From d0bd81970ba401035e2378a32989683e27940a1b Mon Sep 17 00:00:00 2001
From 6e1e5aef1da65e05561995ef449a9d9acefc086c Mon Sep 17 00:00:00 2001
From: Peter Jones <pjones@redhat.com>
Date: Mon, 28 Oct 2013 10:09:27 -0400
Subject: [PATCH 33/37] Enable pager by default. (#985860)
Subject: [PATCH 30/34] Enable pager by default. (#985860)
Signed-off-by: Peter Jones <pjones@redhat.com>
---

View File

@ -1,56 +0,0 @@
From df8b98634bc9113e54e14c98803fc89c02bc28f3 Mon Sep 17 00:00:00 2001
From: Gustavo Luiz Duarte <gustavold@linux.vnet.ibm.com>
Date: Wed, 12 Jun 2013 23:25:30 -0500
Subject: [PATCH 30/37] Initialize grub_file_filters_{all,enabled}
Without this we see an error on ppc during startup:
Elapsed time since release of system processors: 220520 mins 17 secs
DEFAULT CATCH!, exception-handler=fff00300
at %SRR0: 0000000000010d1c %SRR1: 0000000000003002
Open Firmware exception handler entered from non-OF code
Client's Fix Pt Regs:
00 000000000000b3a4 0000000001a3ff00 0000000000000000 000000000021ac50
04 000000000021a810 0000000000001240 00000000002195c0 000000000021ab30
08 000000000002195e 0000000065313237 0000000000000000 0000000001a3ff50
0c 0000000000000124 0000000000000000 0000000000000000 0000000000000000
10 0000000000000000 0000000000000000 0000000000000000 0000000000000000
14 0000000000c00000 0000000000000008 0000000000000000 0000000000000000
18 0000000000000000 0000000000000000 000000000021ab40 000000000020f8be
1c 000000000021aa40 000000000021ac50 0000000000000000 000000000021ac50
Special Regs:
%IV: 00000300 %CR: 40000044 %XER: 00000000 %DSISR: 40000000
%SRR0: 0000000000010d1c %SRR1: 0000000000003002
%LR: 000000000000b3a4 %CTR: 000000000000b378
%DAR: 000000006531323f
Virtual PID = 0
ofdbg
0 >
This doesn't appear to be the root cause of the problem; these should be
initalized by calls to grub_file_filter_register() called from various
GRUB_MOD_INIT() functions. Nevertheless, right now it fixes the symptom.
---
grub-core/kern/file.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/grub-core/kern/file.c b/grub-core/kern/file.c
index 24da12b..7841d57 100644
--- a/grub-core/kern/file.c
+++ b/grub-core/kern/file.c
@@ -28,8 +28,8 @@
void (*EXPORT_VAR (grub_grubnet_fini)) (void);
-grub_file_filter_t grub_file_filters_all[GRUB_FILE_FILTER_MAX];
-grub_file_filter_t grub_file_filters_enabled[GRUB_FILE_FILTER_MAX];
+grub_file_filter_t grub_file_filters_all[GRUB_FILE_FILTER_MAX] = {NULL, NULL, NULL, NULL};
+grub_file_filter_t grub_file_filters_enabled[GRUB_FILE_FILTER_MAX] = {NULL, NULL, NULL, NULL};
/* Get the device part of the filename NAME. It is enclosed by parentheses. */
char *
--
1.8.4.2

View File

@ -1,7 +1,7 @@
From 637e5364015fe4579f7520e169313684403f5955 Mon Sep 17 00:00:00 2001
From 172b22b0179a2e01b18a0c2ae2336ce05663abbc Mon Sep 17 00:00:00 2001
From: Peter Jones <pjones@redhat.com>
Date: Mon, 28 Oct 2013 10:13:27 -0400
Subject: [PATCH 34/37] F10 doesn't work on serial, so don't tell the user to
Subject: [PATCH 31/34] F10 doesn't work on serial, so don't tell the user to
hit it (#987443)
Signed-off-by: Peter Jones <pjones@redhat.com>

View File

@ -1,7 +1,7 @@
From 6237780a78b1e9914dd7135c8e2317972d26f585 Mon Sep 17 00:00:00 2001
From b08547f24825204674a1ef4dcbc5ce638ef99a12 Mon Sep 17 00:00:00 2001
From: Peter Jones <pjones@redhat.com>
Date: Mon, 14 Mar 2011 14:27:42 -0400
Subject: [PATCH 35/37] Don't say "GNU/Linux" in generated menus.
Subject: [PATCH 32/34] Don't say "GNU/Linux" in generated menus.
---
util/grub.d/10_linux.in | 4 ++--
@ -9,7 +9,7 @@ Subject: [PATCH 35/37] Don't say "GNU/Linux" in generated menus.
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/util/grub.d/10_linux.in b/util/grub.d/10_linux.in
index 6befbd1..2dc7b90 100644
index 600bfd2..c943a1e 100644
--- a/util/grub.d/10_linux.in
+++ b/util/grub.d/10_linux.in
@@ -29,9 +29,9 @@ export TEXTDOMAINDIR="@localedir@"

View File

@ -1,7 +1,7 @@
From 350be65f3028754599b8dbf370e516c41e0b9eb8 Mon Sep 17 00:00:00 2001
From 3209ab4020a0c660bb5df1d8ad5ccd530e465839 Mon Sep 17 00:00:00 2001
From: William Jon McCann <william.jon.mccann@gmail.com>
Date: Wed, 15 May 2013 16:47:33 -0400
Subject: [PATCH 36/37] Don't draw a border around the menu
Subject: [PATCH 33/34] Don't draw a border around the menu
It looks cleaner without it.
---

View File

@ -1,7 +1,7 @@
From 5af32cf8ad295055ee190f81d0258978c785fa9f Mon Sep 17 00:00:00 2001
From 3a1a0619d212adbaa19fc714997b006ede827d51 Mon Sep 17 00:00:00 2001
From: William Jon McCann <william.jon.mccann@gmail.com>
Date: Fri, 7 Jun 2013 10:52:32 -0400
Subject: [PATCH 37/37] Use the standard margin for the timeout string
Subject: [PATCH 34/34] Use the standard margin for the timeout string
So that it aligns with the other messages
---

View File

@ -54,10 +54,10 @@ Source3: README.Fedora
Source4: http://unifoundry.com/unifont-5.1.20080820.pcf.gz
Source5: theme.tar.bz2
#Source6: grub-cd.cfg
Patch0001: 0001-Migrate-PPC-from-Yaboot-to-Grub2.patch
Patch0002: 0002-Add-fw_path-variable-revised.patch
Patch0003: 0003-Add-support-for-linuxefi.patch
Patch0004: 0004-Add-support-for-crappy-cd-craparino.patch
Patch0001: 0001-configure.ac-Set-version-to-2.02-beta2.patch
Patch0002: 0002-Migrate-PPC-from-Yaboot-to-Grub2.patch
Patch0003: 0003-Add-fw_path-variable-revised.patch
Patch0004: 0004-Add-support-for-linuxefi.patch
Patch0005: 0005-Use-linuxefi-and-initrdefi-where-appropriate.patch
Patch0006: 0006-Don-t-allow-insmod-when-secure-boot-is-enabled.patch
Patch0007: 0007-Pass-x-hex-hex-straight-through-unmolested.patch
@ -67,30 +67,27 @@ Patch0010: 0010-Add-vlan-tag-support.patch
Patch0011: 0011-Add-X-option-to-printf-functions.patch
Patch0012: 0012-DHCP-client-ID-and-UUID-options-added.patch
Patch0013: 0013-Search-for-specific-config-file-for-netboot.patch
Patch0014: 0014-Add-bootpath-device-to-the-list.patch
Patch0015: 0015-blscfg-add-blscfg-module-to-parse-Boot-Loader-Specif.patch
Patch0016: 0016-Move-bash-completion-script-922997.patch
Patch0017: 0017-for-ppc-reset-console-display-attr-when-clear-screen.patch
Patch0018: 0018-Don-t-write-messages-to-the-screen.patch
Patch0019: 0019-Don-t-print-GNU-GRUB-header.patch
Patch0014: 0014-blscfg-add-blscfg-module-to-parse-Boot-Loader-Specif.patch
Patch0015: 0015-Move-bash-completion-script-922997.patch
Patch0016: 0016-for-ppc-reset-console-display-attr-when-clear-screen.patch
Patch0017: 0017-Don-t-write-messages-to-the-screen.patch
Patch0018: 0018-Don-t-print-GNU-GRUB-header.patch
Patch0019: 0019-Don-t-add-to-highlighted-row.patch
Patch0020: 0020-Don-t-add-to-highlighted-row.patch
Patch0021: 0021-Don-t-add-to-highlighted-row.patch
Patch0022: 0022-Message-string-cleanups.patch
Patch0023: 0023-Fix-border-spacing-now-that-we-aren-t-displaying-it.patch
Patch0024: 0024-Use-the-correct-indentation-for-the-term-help-text.patch
Patch0025: 0025-Indent-menu-entries.patch
Patch0026: 0026-Fix-margins.patch
Patch0027: 0027-Add-support-for-UEFI-operating-systems-returned-by-o.patch
Patch0028: 0028-Disable-GRUB-video-support-for-IBM-power-machines.patch
Patch0029: 0029-Revert-Add-bootpath-device-to-the-list-967862.patch
Patch0030: 0030-Initialize-grub_file_filters_-all-enabled.patch
Patch0031: 0031-Use-2-instead-of-1-for-our-right-hand-margin-so-line.patch
Patch0032: 0032-Use-linux16-when-appropriate-880840.patch
Patch0033: 0033-Enable-pager-by-default.-985860.patch
Patch0034: 0034-F10-doesn-t-work-on-serial-so-don-t-tell-the-user-to.patch
Patch0035: 0035-Don-t-say-GNU-Linux-in-generated-menus.patch
Patch0036: 0036-Don-t-draw-a-border-around-the-menu.patch
Patch0037: 0037-Use-the-standard-margin-for-the-timeout-string.patch
Patch0021: 0021-Message-string-cleanups.patch
Patch0022: 0022-Fix-border-spacing-now-that-we-aren-t-displaying-it.patch
Patch0023: 0023-Use-the-correct-indentation-for-the-term-help-text.patch
Patch0024: 0024-Indent-menu-entries.patch
Patch0025: 0025-Fix-margins.patch
Patch0026: 0026-Add-support-for-UEFI-operating-systems-returned-by-o.patch
Patch0027: 0027-Disable-GRUB-video-support-for-IBM-power-machines.patch
Patch0028: 0028-Use-2-instead-of-1-for-our-right-hand-margin-so-line.patch
Patch0029: 0029-Use-linux16-when-appropriate-880840.patch
Patch0030: 0030-Enable-pager-by-default.-985860.patch
Patch0031: 0031-F10-doesn-t-work-on-serial-so-don-t-tell-the-user-to.patch
Patch0032: 0032-Don-t-say-GNU-Linux-in-generated-menus.patch
Patch0033: 0033-Don-t-draw-a-border-around-the-menu.patch
Patch0034: 0034-Use-the-standard-margin-for-the-timeout-string.patch
BuildRequires: flex bison binutils python
BuildRequires: ncurses-devel xz-devel