grpc/grpc-1.37.0-unbundle-xxhash.patch
Benjamin A. Beasley ce88e01640 New version 1.37.1
- General:
  * New version 1.37.1
  * Drop patches that were upstreamed since the last packaged release, were
    backported from upstream in the first place, or have otherwise been
    obsoleted by upstream changes.
  * Rebase/update remaining patches as needed
  * Drop Fedora 32 compatibility
- C (core) and C++ (cpp):
  * Switch to CMake build system and add CMake files to -devel package
  * Build with C++17 for compatibility with the abseil-cpp package in Fedora
  * Run the port server during core tests
2021-05-11 08:57:48 -04:00

25 lines
1.1 KiB
Diff

diff -Naur grpc-1.37.0-original/cmake/xxhash.cmake grpc-1.37.0/cmake/xxhash.cmake
--- grpc-1.37.0-original/cmake/xxhash.cmake 2021-04-06 18:48:56.000000000 -0400
+++ grpc-1.37.0/cmake/xxhash.cmake 2021-04-08 15:57:39.157042527 -0400
@@ -12,4 +12,6 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-set(_gRPC_XXHASH_INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/third_party/xxhash")
+pkg_search_module(XXHASH REQUIRED libxxhash)
+set(_gRPC_XXHASH_INCLUDE_DIR "${XXHASH_INCLUDEDIR}")
+set(_gRPC_XXHASH_LIBRARIES "${XXHASH_LIBRARIES}")
diff -Naur grpc-1.37.0-original/CMakeLists.txt grpc-1.37.0/CMakeLists.txt
--- grpc-1.37.0-original/CMakeLists.txt 2021-04-06 18:48:56.000000000 -0400
+++ grpc-1.37.0/CMakeLists.txt 2021-04-08 15:53:39.462854440 -0400
@@ -262,7 +262,8 @@
elseif(_gRPC_PLATFORM_ANDROID)
set(_gRPC_ALLTARGETS_LIBRARIES ${CMAKE_DL_LIBS} m)
elseif(UNIX)
- set(_gRPC_ALLTARGETS_LIBRARIES ${CMAKE_DL_LIBS} rt m pthread)
+ set(_gRPC_ALLTARGETS_LIBRARIES
+ ${CMAKE_DL_LIBS} rt m pthread ${_gRPC_XXHASH_LIBRARIES})
endif()
if(WIN32)