Use new upstream PR#25635 as .pc path fix
This commit is contained in:
parent
ae5a7f2e8d
commit
48be285b28
50
29826.patch
Normal file
50
29826.patch
Normal file
@ -0,0 +1,50 @@
|
|||||||
|
From 4138f4bc0347e090431d2476610cbbcaf1397f41 Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Benjamin A. Beasley" <code@musicinmybrain.net>
|
||||||
|
Date: Fri, 27 May 2022 14:41:08 -0400
|
||||||
|
Subject: [PATCH 1/2] Use gRPC_INSTALL_LIBDIR for pkgconfig files
|
||||||
|
|
||||||
|
Fixes #25635.
|
||||||
|
|
||||||
|
If grpc libraries are installed in <prefix>/lib64, then .pc files should
|
||||||
|
be installed in <prefix>/lib64/pkgconfig. Before this commit, they were
|
||||||
|
always installed in <prefix>/lib/pkgconfig.
|
||||||
|
---
|
||||||
|
templates/CMakeLists.txt.template | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/templates/CMakeLists.txt.template b/templates/CMakeLists.txt.template
|
||||||
|
index 9096d9125965..ee3e1782533b 100644
|
||||||
|
--- a/templates/CMakeLists.txt.template
|
||||||
|
+++ b/templates/CMakeLists.txt.template
|
||||||
|
@@ -850,7 +850,7 @@
|
||||||
|
"<%text>${output_filepath}</%text>"
|
||||||
|
@ONLY)
|
||||||
|
install(FILES "<%text>${output_filepath}</%text>"
|
||||||
|
- DESTINATION "lib/pkgconfig/")
|
||||||
|
+ DESTINATION "<%text>${gRPC_INSTALL_LIBDIR}/pkgconfig</%text>")
|
||||||
|
endfunction()
|
||||||
|
|
||||||
|
# gpr .pc file
|
||||||
|
|
||||||
|
From 07a8e936c86b3852ebd14f6fccba53fdffb07a63 Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Benjamin A. Beasley" <code@musicinmybrain.net>
|
||||||
|
Date: Fri, 27 May 2022 14:45:52 -0400
|
||||||
|
Subject: [PATCH 2/2] Re-generate projects
|
||||||
|
|
||||||
|
---
|
||||||
|
CMakeLists.txt | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||||
|
index e7aa97e9fcff..76c9ef0eede9 100644
|
||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -19820,7 +19820,7 @@ function(generate_pkgconfig name description version requires
|
||||||
|
"${output_filepath}"
|
||||||
|
@ONLY)
|
||||||
|
install(FILES "${output_filepath}"
|
||||||
|
- DESTINATION "lib/pkgconfig/")
|
||||||
|
+ DESTINATION "${gRPC_INSTALL_LIBDIR}/pkgconfig")
|
||||||
|
endfunction()
|
||||||
|
|
||||||
|
# gpr .pc file
|
13
grpc.spec
13
grpc.spec
@ -283,6 +283,14 @@ Patch7: grpc-1.39.0-python2-test-scripts.patch
|
|||||||
# compatible with both 1.6.0 and 1.5.0, and upstream has not yet updated to
|
# compatible with both 1.6.0 and 1.5.0, and upstream has not yet updated to
|
||||||
# 1.6.0.
|
# 1.6.0.
|
||||||
Patch8: grpc-1.40.0-google-benchmark-1.6.0.patch
|
Patch8: grpc-1.40.0-google-benchmark-1.6.0.patch
|
||||||
|
# Use gRPC_INSTALL_LIBDIR for pkgconfig files
|
||||||
|
# https://github.com/grpc/grpc/pull/29826
|
||||||
|
#
|
||||||
|
# Fixes:
|
||||||
|
#
|
||||||
|
# Should install pkgconfig files under gRPC_INSTALL_LIBDIR
|
||||||
|
# https://github.com/grpc/grpc/issues/25635
|
||||||
|
Patch9: %{forgeurl}/pull/29826.patch
|
||||||
|
|
||||||
Requires: grpc-data = %{version}-%{release}
|
Requires: grpc-data = %{version}-%{release}
|
||||||
|
|
||||||
@ -719,11 +727,6 @@ sed -r -i 's/(std=c\+\+)11/\1%{cpp_std}/g' \
|
|||||||
tools/run_tests/artifacts/artifact_targets.py \
|
tools/run_tests/artifacts/artifact_targets.py \
|
||||||
tools/distrib/python/grpcio_tools/setup.py
|
tools/distrib/python/grpcio_tools/setup.py
|
||||||
|
|
||||||
echo '===== Fixing .pc install path =====' 2>&1
|
|
||||||
# Fix the install path for .pc files
|
|
||||||
# https://github.com/grpc/grpc/issues/25635
|
|
||||||
sed -r -i 's|lib(/pkgconfig)|\${gRPC_INSTALL_LIBDIR}\1|' CMakeLists.txt
|
|
||||||
|
|
||||||
echo '===== Patching to skip certain broken tests =====' 2>&1
|
echo '===== Patching to skip certain broken tests =====' 2>&1
|
||||||
# Confirmed in 1.39.0 2021-07-29
|
# Confirmed in 1.39.0 2021-07-29
|
||||||
# TODO figure out how to report this upstream in a useful/actionable way
|
# TODO figure out how to report this upstream in a useful/actionable way
|
||||||
|
Loading…
Reference in New Issue
Block a user