Update to 1.26.0
This commit is contained in:
parent
f302d3b94a
commit
3b94ecfeb9
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@
|
||||
/grpc-1.17.1.tar.gz
|
||||
/grpc-1.18.0.tar.gz
|
||||
/grpc-1.20.1.tar.gz
|
||||
/grpc-1.26.0.tar.gz
|
||||
|
@ -1,43 +0,0 @@
|
||||
From 58691d6301984afe2dbdab52e1cb2ea0d83a3686 Mon Sep 17 00:00:00 2001
|
||||
From: Sergey Avseyev <sergey.avseyev@gmail.com>
|
||||
Date: Fri, 16 Nov 2018 15:03:30 +0300
|
||||
Subject: [PATCH 2/4] patch from #15532
|
||||
|
||||
---
|
||||
Makefile | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 53e70c95ba..2bdfa6395d 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -348,7 +348,7 @@ HOST_LD ?= $(LD)
|
||||
HOST_LDXX ?= $(LDXX)
|
||||
|
||||
CFLAGS += -std=c99 -Wsign-conversion -Wconversion $(W_SHADOW) $(W_EXTRA_SEMI)
|
||||
-CXXFLAGS += -std=c++11
|
||||
+CXXFLAGS += -std=c++11 -Wno-class-memaccess -Wno-ignored-qualifiers -Wno-stringop-truncation -Wno-sizeof-pointer-div
|
||||
ifeq ($(SYSTEM),Darwin)
|
||||
CXXFLAGS += -stdlib=libc++
|
||||
endif
|
||||
@@ -8007,7 +8007,7 @@ LIBBORINGSSL_OBJS = $(addprefix $(OBJDIR)/$(CONFIG)/, $(addsuffix .o, $(basename
|
||||
|
||||
$(LIBBORINGSSL_OBJS): CPPFLAGS += -Ithird_party/boringssl/include -fvisibility=hidden -DOPENSSL_NO_ASM -D_GNU_SOURCE -DWIN32_LEAN_AND_MEAN -D_HAS_EXCEPTIONS=0 -DNOMINMAX
|
||||
$(LIBBORINGSSL_OBJS): CXXFLAGS += -fno-rtti -fno-exceptions
|
||||
-$(LIBBORINGSSL_OBJS): CFLAGS += -Wno-sign-conversion -Wno-conversion -Wno-unused-value -Wno-unknown-pragmas -Wno-implicit-function-declaration -Wno-unused-variable -Wno-sign-compare -Wno-implicit-fallthrough $(NO_W_EXTRA_SEMI)
|
||||
+$(LIBBORINGSSL_OBJS): CFLAGS += -Wno-sign-conversion -Wno-conversion -Wno-unused-value -Wno-unknown-pragmas -Wno-implicit-function-declaration -Wno-unused-variable -Wno-sign-compare -Wno-implicit-fallthrough -Wno-cast-function-type $(NO_W_EXTRA_SEMI)
|
||||
|
||||
$(LIBDIR)/$(CONFIG)/libboringssl.a: $(ZLIB_DEP) $(CARES_DEP) $(ADDRESS_SORTING_DEP) $(LIBBORINGSSL_OBJS)
|
||||
$(E) "[AR] Creating $@"
|
||||
@@ -8251,7 +8251,7 @@ PUBLIC_HEADERS_C += \
|
||||
LIBARES_OBJS = $(addprefix $(OBJDIR)/$(CONFIG)/, $(addsuffix .o, $(basename $(LIBARES_SRC))))
|
||||
|
||||
$(LIBARES_OBJS): CPPFLAGS += -Ithird_party/cares -Ithird_party/cares/cares -fvisibility=hidden -D_GNU_SOURCE $(if $(subst Darwin,,$(SYSTEM)),,-Ithird_party/cares/config_darwin) $(if $(subst FreeBSD,,$(SYSTEM)),,-Ithird_party/cares/config_freebsd) $(if $(subst Linux,,$(SYSTEM)),,-Ithird_party/cares/config_linux) $(if $(subst OpenBSD,,$(SYSTEM)),,-Ithird_party/cares/config_openbsd) -DWIN32_LEAN_AND_MEAN -D_HAS_EXCEPTIONS=0 -DNOMINMAX $(if $(subst MINGW32,,$(SYSTEM)),-DHAVE_CONFIG_H,)
|
||||
-$(LIBARES_OBJS): CFLAGS += -Wno-sign-conversion $(if $(subst Darwin,,$(SYSTEM)),,-Wno-shorten-64-to-32) $(if $(subst MINGW32,,$(SYSTEM)),-Wno-invalid-source-encoding,)
|
||||
+$(LIBARES_OBJS): CFLAGS += -Wno-sign-conversion -Wno-sizeof-pointer-memaccess -Wno-stringop-overflow $(if $(subst Darwin,,$(SYSTEM)),,-Wno-shorten-64-to-32) $(if $(subst MINGW32,,$(SYSTEM)),-Wno-invalid-source-encoding,)
|
||||
|
||||
$(LIBDIR)/$(CONFIG)/libares.a: $(LIBARES_OBJS)
|
||||
$(E) "[AR] Creating $@"
|
||||
--
|
||||
2.21.0
|
||||
|
@ -1,25 +0,0 @@
|
||||
From ec4ea511a15aef0de9760f3aad265faf4bf65cfa Mon Sep 17 00:00:00 2001
|
||||
From: Sergey Avseyev <sergey.avseyev@gmail.com>
|
||||
Date: Fri, 17 May 2019 10:53:34 +0300
|
||||
Subject: [PATCH 4/4] use gettid from glibc
|
||||
|
||||
---
|
||||
src/core/lib/gpr/log_linux.cc | 2 --
|
||||
1 file changed, 2 deletions(-)
|
||||
|
||||
diff --git a/src/core/lib/gpr/log_linux.cc b/src/core/lib/gpr/log_linux.cc
|
||||
index 561276f0c2..2656492d43 100644
|
||||
--- a/src/core/lib/gpr/log_linux.cc
|
||||
+++ b/src/core/lib/gpr/log_linux.cc
|
||||
@@ -40,8 +40,6 @@
|
||||
#include <time.h>
|
||||
#include <unistd.h>
|
||||
|
||||
-static long gettid(void) { return syscall(__NR_gettid); }
|
||||
-
|
||||
void gpr_log(const char* file, int line, gpr_log_severity severity,
|
||||
const char* format, ...) {
|
||||
/* Avoid message construction if gpr_log_message won't log */
|
||||
--
|
||||
2.21.0
|
||||
|
42
grpc.spec
42
grpc.spec
@ -1,6 +1,6 @@
|
||||
Name: grpc
|
||||
Version: 1.20.1
|
||||
Release: 5%{?dist}
|
||||
Version: 1.26.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Modern, open source, high-performance remote procedure call (RPC) framework
|
||||
License: ASL 2.0
|
||||
URL: https://www.grpc.io
|
||||
@ -22,12 +22,7 @@ BuildRequires: python3-setuptools
|
||||
BuildRequires: python3-Cython
|
||||
|
||||
Patch0: grpc-0001-enforce-system-crypto-policies.patch
|
||||
# https://github.com/grpc/grpc/pull/15532
|
||||
Patch1: grpc-0002-patch-from-15532.patch
|
||||
# https://github.com/grpc/grpc/pull/17732
|
||||
# Patch3: 0003-tcp_posix.cc-fix-typo-in-bitwise-condition.patch
|
||||
Patch2: grpc-0003-use-shell-loop-instead-makefile-function.patch
|
||||
Patch3: grpc-0004-use-gettid-from-glibc.patch
|
||||
|
||||
%description
|
||||
gRPC is a modern open source high performance RPC framework that can run in any
|
||||
@ -75,7 +70,6 @@ Development headers and files for gRPC libraries.
|
||||
%package -n python3-grpcio
|
||||
Summary: Python language bindings for grpc, remote procedure call (RPC) framework
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
%{?python_provide:%python_provide python3-%{pypi_name}}
|
||||
|
||||
%description -n python3-grpcio
|
||||
Python3 bindings for gRPC library.
|
||||
@ -83,9 +77,9 @@ Python3 bindings for gRPC library.
|
||||
%prep
|
||||
%autosetup -N
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
#%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
#%patch3 -p1
|
||||
sed -i 's:^prefix ?= .*:prefix ?= %{_prefix}:' Makefile
|
||||
sed -i 's:$(prefix)/lib:$(prefix)/%{_lib}:' Makefile
|
||||
sed -i 's:^GTEST_LIB =.*::' Makefile
|
||||
@ -112,8 +106,17 @@ find %{buildroot} -type f -name '*.a' -exec rm -f {} \;
|
||||
%files
|
||||
%doc README.md
|
||||
%license LICENSE
|
||||
%{_libdir}/*.so.1*
|
||||
%{_libdir}/*.so.7*
|
||||
%{_libdir}/libaddress_sorting.so.9*
|
||||
%{_libdir}/libgpr.so.9*
|
||||
%{_libdir}/libgrpc++.so.1*
|
||||
%{_libdir}/libgrpc++_error_details.so.1*
|
||||
%{_libdir}/libgrpc++_reflection.so.1*
|
||||
%{_libdir}/libgrpc++_unsecure.so.1*
|
||||
%{_libdir}/libgrpc.so.9*
|
||||
%{_libdir}/libgrpc_cronet.so.9*
|
||||
%{_libdir}/libgrpc_unsecure.so.9*
|
||||
%{_libdir}/libgrpcpp_channelz.so.1*
|
||||
%{_libdir}/libup*.so.9*
|
||||
%{_datadir}/grpc
|
||||
|
||||
%files cli
|
||||
@ -125,7 +128,17 @@ find %{buildroot} -type f -name '*.a' -exec rm -f {} \;
|
||||
%{_bindir}/grpc_*_plugin
|
||||
|
||||
%files devel
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/libaddress_sorting.so
|
||||
%{_libdir}/libgpr.so
|
||||
%{_libdir}/libgrpc++.so
|
||||
%{_libdir}/libgrpc++_error_details.so
|
||||
%{_libdir}/libgrpc++_reflection.so
|
||||
%{_libdir}/libgrpc++_unsecure.so
|
||||
%{_libdir}/libgrpc.so
|
||||
%{_libdir}/libgrpc_cronet.so
|
||||
%{_libdir}/libgrpc_unsecure.so
|
||||
%{_libdir}/libgrpcpp_channelz.so
|
||||
%{_libdir}/libupb.so
|
||||
%{_libdir}/pkgconfig/*
|
||||
%{_includedir}/grpc
|
||||
%{_includedir}/grpc++
|
||||
@ -137,6 +150,9 @@ find %{buildroot} -type f -name '*.a' -exec rm -f {} \;
|
||||
%{python3_sitearch}/grpcio-%{version}-py?.?.egg-info
|
||||
|
||||
%changelog
|
||||
* Wed Jan 15 2020 Sergey Avseyev <sergey.avseyev@gmail.com> - 1.26.0-1
|
||||
- Update to 1.26.0
|
||||
|
||||
* Thu Dec 19 2019 Orion Poplawski <orion@nwra.com> - 1.20.1-5
|
||||
- Rebuild for protobuf 3.11
|
||||
|
||||
|
3
sources
3
sources
@ -1,2 +1 @@
|
||||
SHA512 (grpc-1.18.0.tar.gz) = 2489860a395b9f59d4eb81db5a8d873683e317145ad140b72fabb13693e166c122ce8526d34e2380a52d18493e8b2b49d6d28e53878af2c43523a5791da8fe52
|
||||
SHA512 (grpc-1.20.1.tar.gz) = e0dd0318d2b4ec07e0eafffa218938d91b1440c5053a557460ea7fceaab3d76f0cccc1d595abe7de9fa79f068b71cfbc5a28a3b688bc9c1e2737086928149583
|
||||
SHA512 (grpc-1.26.0.tar.gz) = 4f7d067c582d0a9be7b7d4dd1e08acdbe6ff0686dfe92b5db5b7927f779410a4237acfd1c61d9f79eb2d00f86cf93cc7492fa372c1877e57c1aa23e9bb2648bb
|
||||
|
Loading…
Reference in New Issue
Block a user